Quads not staying flat

General discussion on SUbD for SketchUp

Quads not staying flat

Postby Zaacharms » Thu Apr 30, 2020 9:00 pm

Hi,
I've been practicing using SubD and I've run into an issue and was wondering if It's me or something I can work around.
It seams like my quads start out okay but after working with the mesh such as attaching other surfaces, adding/removing quads, adjusting vertices etc. I find that some of the quads are out of plane, and must be closed by using two triangles. these are not quads that I'm working on! The area looks planer but it's clearly not. This happens a lot and it effects the subdivisions.
Thanks,
Marc
0

Zaacharms 
Premium Member
Premium Member
 

Re: Quads not staying flat

Postby Zaacharms » Thu Apr 30, 2020 9:34 pm

I think I found my answer! I guess it's only a visual thing.

How to "make planar" multi quad face?
0

Zaacharms 
Premium Member
Premium Member
 

Re: Quads not staying flat

Postby pbacot » Thu Apr 30, 2020 10:09 pm

I'm not using SubD but would "Make Planar" in VertextTools work?
0
MacOSX Mojave High Sierra SketchUp Pro v19 Twilight v2 Thea v2 PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: Quads not staying flat

Postby thomthom » Fri May 01, 2020 1:21 pm

I'm not sure I fully understand your question.

SUbD support QuadFace Tools quads - which can be non-planar provided the edge between them have the appropriate properties: https://github.com/thomthom/quadface-to ... i/Overview

Can you elaborate a bit more on what you are doing (what steps you are performing) and what the expected results are? (Screenshots perhaps?)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: Quads not staying flat

Postby Zaacharms » Sun May 03, 2020 7:34 pm

Thanks for the responses.
I think my biggest problem was just my lever of inexperience with SubD. I'm getting along better now.

One issue for me was errant pieces of lines that were (and can be) so small that they go unnoticed but SubD tries using them and the surface goes haywire. I'm pretty good at finding them now and know how to avoid making them in the first place.

I still have a ling way to go but it is exactly what I was looking for in a CAD program.

Marc
0

Zaacharms 
Premium Member
Premium Member
 

Re: Quads not staying flat

Postby thomthom » Sat May 09, 2020 11:04 am

Zaacharms wrote:One issue for me was errant pieces of lines that were (and can be) so small that they go unnoticed but SubD tries using them and the surface goes haywire. I'm pretty good at finding them now and know how to avoid making them in the first place.


You might be able to use Solid Inspector2 to help locating them. Even though you are not trying to make a solid, the extension has an option to report small/short edges.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: Quads not staying flat

Postby Zaacharms » Sun May 10, 2020 9:16 pm

Still working improve my skills in SubD so I am trying to recreate the couch back in Tatin Sofa part 3.

Edit: I figured out why this is happening. In order to 'shrink selection' you must first deselect Vertex tools by hitting space bar. Second issue is still under investigation.

[My issue is when I Grow Selection (of Quads) and then click Vertex Tools all the quads are deselected so it's not possible to 'shrink selection' as in the video. That is shrinking the selection one quad at a time to allow raising them one by one.]

A second issue is that when I raise the first selection (All quads minus the first one), the first quad goes out of plane (note diagonal line). This doesn't appear to happen in the video. This was my original issue that I still don't seem to have figured out- Quads not staying flat.

Please see attached, Is there something I'm missing?

Marc
0

Zaacharms 
Premium Member
Premium Member
 

Re: Quads not staying flat

Postby thomthom » Mon May 11, 2020 5:28 pm

Zaacharms wrote:Edit: I figured out why this is happening. In order to 'shrink selection' you must first deselect Vertex tools by hitting space bar.

Yea, normal selection changes, done by for instance QuadFace Tools, will not work when in Vertex Mode.
I've been thinking about how to improve Vertex Mode interaction with QuadFace Tools - make the two extensions better work together.

Zaacharms wrote:[My issue is when I Grow Selection (of Quads) and then click Vertex Tools all the quads are deselected so it's not possible to 'shrink selection' as in the video. That is shrinking the selection one quad at a time to allow raising them one by one.]

In the upcoming version 2, if the selected vertices include the vertices of a face, that face will be selected when existing Vertex Mode.

Zaacharms wrote:A second issue is that when I raise the first selection (All quads minus the first one), the first quad goes out of plane (note diagonal line). This doesn't appear to happen in the video. This was my original issue that I still don't seem to have figured out- Quads not staying flat.

Please see attached, Is there something I'm missing?

Is Auto-Smooth turned off for you?
2020-05-11_18h27_23.png


When Auto-Smooth is turned on, any face that is broken up due to SketchUp's Auto-Fold will be made soft+smooth compatible with QuadFace Tools.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: Quads not staying flat

Postby Zaacharms » Mon May 11, 2020 10:53 pm

Thanks thomthom that resolved the last of my problems with the sofa.

One thing did come up that I've had happen while practicing and that's using 'select loop'. Sometimes it doesn't go all the way around. It was happening on the sofa but it's easy to work around using shift select. I was wondering if it is a anomaly in the model or just geometry or something else.

I've attached a new model that I can't select loop and get a continuous result. Can you take a look?

I'm using SU 2016 and the info under the R mouse button looks a little different than the image you sent. I guess that's to be expected.

Marc
0

Zaacharms 
Premium Member
Premium Member
 

Re: Quads not staying flat

Postby thomthom » Sat May 16, 2020 7:18 pm

There wasn't any model attached to your post there. Did you forget?
Loops will stop at forks, where there is too many possible paths to be able to determine where it should go.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SUbD

Who is online

Users browsing this forum: No registered users and 0 guests

Visit our sponsors: