[RELEASE] Alpha 0.0.9

General discusson for Skatter for SketchUp

Moderator: jiminy-billy-bob

[RELEASE] Alpha 0.0.9

Postby jiminy-billy-bob » Thu Apr 09, 2015 9:08 pm

Alpha 0.0.9

Don't forget to restart Sketchup after install.

Nothing very exciting for you this time, I'm afraid. But I need you more than ever.
I implemented the licensing system. Here is the serial you can use : 6sblp-7GdCN-Z1Y3X-E0O4a
I need you to test if anything is broken.

Please try everything you can to break the licensing stuff.
After activating, the license file is located at C:\ProgramData\Skatter\License\license.lc
It's a txt file, you can open it and change stuff, delete it, etc. Be creative.

Thanks a lot for your precious time!
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.9

Postby jiminy-billy-bob » Thu Apr 09, 2015 9:14 pm

The licensing system is almost done only on the client side. I still need to do a lot of stuff on the server side. That's why I can give one serial for all of you at once.
This won't be possible in the future.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.9

Postby Rich O Brien » Thu Apr 09, 2015 9:57 pm

installed = ok

activated = ok

destroyed .lc file = error on next startup preventing using (ok)

pasted in licence = ok

net result = i couldn't break it
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [RELEASE] Alpha 0.0.9

Postby JQL » Thu Apr 09, 2015 11:01 pm

Jiminy,

Would you be interested if I would spread skatter on all computers around here?

I have two networks on one internet account and several different OS.
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [RELEASE] Alpha 0.0.9

Postby jiminy-billy-bob » Thu Apr 09, 2015 11:04 pm

Not now, but definitly later when the server-side licensing system is done.
Thanks!
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.9

Postby Pixero » Fri Apr 10, 2015 7:20 am

Installation went fine here too. Will try to break it now...
1
User avatar
Pixero 
 

Re: [RELEASE] Alpha 0.0.9

Postby caecarvalho » Fri Apr 10, 2015 1:52 pm

Instalation went fine here! Just noticed that it's not ready for v-ray 2.00.25539...But just changed the version in the vray.rb file and it's fine.
Couldn't break the license. Tryed deleting and changing the text file but this prevented skatter to work.
0

caecarvalho 
 

Re: [RELEASE] Alpha 0.0.9

Postby Pixero » Tue Apr 14, 2015 1:52 pm

I would like to have the option to use center of base as insertion point.
Maybe even a setting to raise/lower the component insertion point.
0
User avatar
Pixero 
 

Re: [RELEASE] Alpha 0.0.9

Postby jiminy-billy-bob » Tue Apr 14, 2015 1:57 pm

Pixero wrote:I would like to have the option to use center of base as insertion point.
Maybe even a setting to raise/lower the component insertion point.

You already can do these things.

Click on the scattered object in the list, this will display its properties and you'll be able to select "Insertion Point : Center" (which is acutally base center)

To lower it, enable "Translation" and put the same value in Z Min and Max.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.9

Postby Pixero » Tue Apr 14, 2015 3:23 pm

Ok, but it doesn't seem to work for me.
I have these (badly made) proxies with the axis in the center but even if I click use center (base center you said it was) they appear half way through the ground. In SU view they look OK but in Thea it doesn't.
0
User avatar
Pixero 
 

Re: [RELEASE] Alpha 0.0.9

Postby jiminy-billy-bob » Tue Apr 14, 2015 3:26 pm

Pixero wrote:In SU view they look OK but in Thea it doesn't.

Oh? Then it's probably a Thea issue.

Do you have this issue with every component in every file?
If not, could you provide the problematic file?
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.9

Postby Pixero » Wed Apr 15, 2015 7:18 am

After shutting down SU and restarting. Not sure why but now center works. :thumb:
0
User avatar
Pixero 
 

Re: [RELEASE] Alpha 0.0.9

Postby JQL » Sun Apr 19, 2015 12:53 pm

Just tested the licencing system too and it seems to be working fine. Win7
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [RELEASE] Alpha 0.0.9

Postby NigeC » Wed Apr 29, 2015 12:39 pm

Seeing as Tomasz hasn't updated yet I'm using this one.. I can't get it to activate, no folder is created in C:\programdata.....
If I enter the above serial nothing appears to happen and no errors in the Ruby console
I'm using 2015 on Win7 64.. uac is off, tried as an Admin

Maybe its because I've not used previous versions? the dialog displays ok but obviously its not doing anything other than the Pro nag dialog

edit 0.10 activated fine
1
Last edited by NigeC on Wed Apr 29, 2015 12:44 pm, edited 1 time in total.
“It’s only impossible if you stop and think about it!”
User avatar
NigeC 
 

Re: [RELEASE] Alpha 0.0.9

Postby jiminy-billy-bob » Wed Apr 29, 2015 12:44 pm

Please try Alpha 0.0.10 anyway, just for the licensing part.
1
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.9

Postby NigeC » Wed Apr 29, 2015 12:45 pm

yes I just tried and it did activate fine, thanks :thumb:
1
“It’s only impossible if you stop and think about it!”
User avatar
NigeC 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Skatter

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: