[Plugin] Hidden to Layer

[Plugin] Hidden to Layer

Postby TIG » Fri Mar 14, 2008 1:34 pm

This script Hidden2Layer.rb moves hidden active entities onto a layer called HIDN...

Usage: Put this file into the Plugins Folder.
Pick "Hidden to Layer" off Plugins Menu...
Any Hidden Active Entities are moved onto Layer HIDN
This means that any Hidden Model-based Geometry is moved,
BUT if you want to do Hidden Entities that are inside of
Groups or Component Definitions then you need to Edit them
so their Entities are then 'Active' and then on running
this tool they will be moved to HIDN...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Hidden to Layer

Postby mischka » Tue Apr 01, 2014 12:07 am

Hello there..

Im trying out the HIDDN layer plugin, but the layer won't show up in autocad.

what am i doing wrong ?

bests

Alex
0

mischka 
 

Re: [Plugin] Hidden to Layer

Postby TIG » Tue Apr 01, 2014 10:23 am

I don't know. :roll:

Let's assume the following:
You've moved all hidden lines to the HIDDN layer.
That HIDDN layer is OFF.
If you switch it ON, and also have View > Hidden Geometry set to ON, then do you see the hidden geometry ?
If not something is wrong.

But if they are there, then a 3d export to DWG/DXF will include all of the SKP's layers, including those layers that are currently OFF in the SKP, and it will include the geometry assigned to the OFF layers too.
Proper layering etc is preserved in the exported file, just as in the SKP.
What 'Options' do you have ticked for your 3d export ?

IN CAD switching the layer HIDDN on should show the hidden lines on that layer.

I have just tested it to make sure I wasn't mistaken !
It works fine for me.

Possible mess up...
If you ill-advisedly export a 2d DWG/DXF version then it's not really a useful CAD file - more a 'graphic' - it will be in inches, there will be no recognizable layers brought over from the SKP - all geometry is moved onto layer 0, and if any layer is OFF its geometry is simply =NOT exported.
If you have hidden lines with their layer ON, then in 2d export, if the appropriate option is ticked, you should be prompted to include those in the export - but then these are lumped with other lines on layer 0 so they are no longer separated.
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Plugins

Who is online

Users browsing this forum: coconm, temppiz, thalamix and 12 guests

Visit our sponsors: