Drawing or Erasing Lines, Are Just Slow and Lagging

General discussion related to SketchUp Pro and Make

Drawing or Erasing Lines, Are Just Slow and Lagging

Postby oguzkaya » Sun Nov 23, 2014 3:52 am

Hi there,

Im really pissed off, so quickly heres my problem and story.

Im using;
SU Pro 2014 and 2015 on Win 8.1
SU Pro 8, 2013 and 2015 on Mac OSX 10.9.3

I draw some contour lines in Autocad 2014 as SPLINE,
(Heres the .DWG file if you want to look)
Then I import it to SU and pushpull and stuff..

(And heres the zipped .SKP file I want you to download it and give a try)

Here is the problem;
I tried same file on WIN and MAC, and all versions that I have.

On WIN: When I try to draw a line its starts to Lagging. Blue dot on surface follows the cursor without lag which is okay. But When I click and move mouse around line just follows 1 or 2 seconds later. Some times its dissappear, and I cant see what Im drawing. Erasing a line in windows its just okay, no lag.

On MAC: With the same .skp file, same statistics, same stuff I tried.. I can draw a line without lag. But I cant erase the line without lag. Its like Im moving over the line, and 1-2 second later line gets blue, and again 1-2 second later line dissappear. It is took my 3 seconds to erase a single line.




Win;
i7-3820 @ 4.00 Ghz, 16gb Ram, GeForce GT430
Mac;
i5 @ 2.4 Ghz, 10gb Ram, Intel HD 3000, MBP-Late-2011


What could it be the problem? The Groups says try without Hardwareacc. but yes I tried nothing happend. And also FYI I dont have any lag problems on Rotating or Panning or Zooming.
Well Im currently, tearing my hair out. :cry:
Thank you.
0

oguzkaya 
 

Re: Drawing or Erasing Lines, Are Just Slow and Lagging

Postby jeff hammond » Sun Nov 23, 2014 4:39 am

yeah, i tried your model and am seeing the same thing you're describing.. not with all the groups though.. with the extruded buildings for instance, i can erase the lines just fine but when i try to erase lines in the group on the Roads layer, it lags.

usually, i'll experience navigation lag prior to anything like that happening but i can navigate this model just fine.

so, i don't know what you can do to improve the performance.. hopefully someone will come along with better info.
?

tried it with sketchup pro 2015 and osx 10.10

3.5 GHz Intel Core i7
24 GB 1600 MHz DDR3
NVIDIA GeForce GTX 780M 4096 MB




[EDIT] oh wait, there's something a little iffy with the way the model is organized..
the group i have trouble with is on layer0.. it's the big group with the elevations/roads..
the weird part is that inside the group, the individual lines are on other layers.. the edges are on ROADS while the group is on Layer0..
this may (or may not) be part of the problem
0
dotdotdot
User avatar
jeff hammond 
Global Moderator
 

Re: Drawing or Erasing Lines, Are Just Slow and Lagging

Postby oguzkaya » Sun Nov 23, 2014 6:13 am

Thanks jeff for your efforts.

I know there is lots of layers, and also I tried moving everything to a Layer0 which is sketchup default layer I believe but nothing changed in that model that you tried.

Well I realize something I'm not sure about it but, SU automatically smooths some edges I think?

I mean each Height Level (contours) was COMPONENT when I imported from autocad anyway, yesterday I exploded them to make it GROUP to get rid of components, and to make it just single geometry. Maybe that causes such behaviour like this..

Now I think, SU changes or soften some edges in every "make component/explode" situation in bigger geometries, models.


This is the model that Im talking about.
I didnt tried on this before, shame for me :?

If you still interesting you may check this model with unexploded height contours components.

Looks like problem solved spontaneously for me :o . fyi, this 2nd model that I upload have much more edges than other. Thanks for your time.
0

oguzkaya 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: Laurence_T and 14 guests

Visit our sponsors: