Fredo6 Animator update problem

General discussion about Animator for SketchUp

Fredo6 Animator update problem

Postby CjWhitsett » Fri May 17, 2019 5:06 pm

The recent update for Fredo6's Animator seems to have disrupted the animations I created the day before. Please don't get me wrong, I really, really love this plugin. I work as a graphic artist and I use SU to create illustrations and animations so this is perfect.

I have created an animation with seven (7) tracks for movement plus a camera track. On Wednesday, 15 May it was working perfectly. On Thursday the plugin required an update to operate so I did that and now my complicated animation isn't working properly. All objects are starting from their end points and moving as though they have shifted along their intended path starting from the end point and ending far beyond where they did originally. The same thing is happening with rotations. All objects are now starting in their fully rotated end position as their starting point and rotation the same degree to a new and unintended position. Objects that were previously moving in parallel and now offset from one another and moving from their end points to new arbitrary positions. Some objects are now also moving in the reverse direction from end to start.

The other problem that I was having before the update is that if I adjusted any movement on the timeline, it would jump to another track and bump the starting/ending time of other movements. This was a little frustrating but I was getting used to what would happen and was able to anticipate what might need to be fixed as a result.

Fredo - In my mind the Animator plugin is possibly the greatest thing to every happen to SketchUp so I am a huge fan of it and the work you have done to create it. I'd like very much to continue using it. I'm curious to know if anyone else is experiencing similar problems and if there is some way to revert back to the plugin in it's previous state.

Thanks very much,
Clint
1
User avatar
CjWhitsett 
 

Re: Fredo6 Animator update problem

Postby fredo6 » Sun May 19, 2019 11:42 pm

This is strange. None else signaled it so far. And I don't have this kind of problems on my own animations.

The best would be to post or PM the model so that I have a look.

Fredo

PS: Did you save object positions using the Position Manager?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: Fredo6 Animator update problem

Postby Glastulla » Tue Apr 21, 2020 11:01 pm

Hi, I'm having this same problem now. The exact same as described. Has anyone else came across this of found a fix for it?
0

Glastulla 
 

Re: Fredo6 Animator update problem

Postby Wibe1981 » Mon Jun 15, 2020 9:04 am

Did have the same problem, but i did find a way around that.
When exiting sketchup, dont save it with the player at the end of the animation, but reset it to the start, then save it.

But just finding a new problem:
When i start sketchup, and wanting to make a new animation or opening an existing one, it says "this version of animator has expired" and sending me to the downloadpage, but there is the version i have installed already. Removing the existing one and reinstalling isnt working. Also reinstalled Libfredo to be sure, but still saying it everytime i try to start the extension.

Is there a newer version at this moment then "V2.6c releasedate 19 mar 2020"?
2

Wibe1981 
 

Re: Fredo6 Animator update problem

Postby Borodine33 » Mon Jun 15, 2020 2:03 pm

Hello,

i have exactly the same problem than you Wibe1981 since today...
0

Borodine33 
 

Re: Fredo6 Animator update problem

Postby Wibe1981 » Mon Jun 15, 2020 2:09 pm

Borodine33 wrote:Hello,

i have exactly the same problem than you Wibe1981 since today...




check this topic:

viewtopic.php?f=401&t=72661
0

Wibe1981 
 

Re: Fredo6 Animator update problem

Postby SKEnthusiest » Wed Jan 27, 2021 11:54 pm

Fredo_ Love Animator but have two questions I cannot find an answer to:

1. Sometimes when I want to move a sub object in a group away from another, it will move both objects - the first one I selected goes where I want it to go but the other object (that I did not select to move) moves at 2x the distance and does not stay put. Do I need to get back into sketchup and ungroup all sub groups from each other to keep them from being sticky?

2. When I make a group explosion in my sketchup model and save - my timeline becomes red in Animator. What does that mean and how do I update it to become blue again?
2

SKEnthusiest 
 

Re: Fredo6 Animator update problem

Postby SKEnthusiest » Thu Jan 28, 2021 12:00 am

One more question - How do you delete translations completely if you want to start all over. There seems to be a ghost list in the fly out even if I drag them off of the timeline.
0

SKEnthusiest 
 

Re: Fredo6 Animator update problem

Postby fredo6 » Thu Jan 28, 2021 8:28 am

Difficult to answer without seeing the model.

Note that
  • never change the hierarchy of objects
  • A red element in the timeline is precisely due to an object having been moved or deleted
  • You can move several objects in the same translation
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: Fredo6 Animator update problem

Postby Augusteijn » Sun May 08, 2022 1:39 pm

I cannot update my version of animator, also the same problem with fredo6lib.
When you clic "install" with the update, nothing happens.
In the extentionmanager you can see that the old versions are installed, but when you look "tool", only curviloft shows up.
0

Augusteijn 
 

Re: Fredo6 Animator update problem

Postby fredo6 » Sun May 08, 2022 7:39 pm

Augusteijn wrote:I cannot update my version of animator, also the same problem with fredo6lib.
When you clic "install" with the update, nothing happens.
In the extentionmanager you can see that the old versions are installed, but when you look "tool", only curviloft shows up.

You probably try to update Animator from the Sketchup Extension Manager...
This will not work, because Animator and LibFredo6 are not hosted on Extension WareHouse, but on Sketchucation.

So,
- Either use the Sketchucation ExtensionStore to manage the installation and update of my plugins
- or download the rbz file and install it from the Sketchup Extension Manager.
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: Fredo6 Animator update problem

Postby jomelg12 » Tue May 10, 2022 1:49 am

Same problem. :( :( have anyone know how to fix this issue?
0

jomelg12 
 

Re: Fredo6 Animator update problem

Postby fredo6 » Tue May 10, 2022 9:04 am

jomelg12 wrote:Same problem. :( :( have anyone know how to fix this issue?

What is this 'same problem'?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: Fredo6 Animator update problem

Postby paradescargarplugin » Sun Jun 19, 2022 10:19 pm

Pero encontré un nuevo problema:
cuando inicio Sketchup y quiero hacer una nueva animación o abrir una existente, dice "esta versión de animador ha caducado" y me envía a la página de descarga, pero está la versión que tengo instalada. ya. Quitar el existente y reinstalarlo no funciona. También reinstalé Libfredo para estar seguro, pero aún lo digo cada vez que intento iniciar la extensión. tanto para le version 2021 y 2022

Translation
But I found a new problem: when I start Sketchup and want to make a new animation or open an existing one, it says "this animator version has expired" and sends me to the download page, but it's the version I have installed. already. Removing the existing one and reinstalling it does not work. I also reinstalled Libfredo to be sure, but I still say that every time I try to launch the extension. both for the 2021 and 2022 versions

0

paradescargarplugin 
 

Re: Fredo6 Animator update problem

Postby fredo6 » Mon Jun 20, 2022 10:35 am

Strange. Version 3.7a is still valid.

Can you check the version of Animator, via menu "Tools > Fredo6 Collection > Animator > About...."
0
User avatar
fredo6 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Animator Beta

Who is online

Users browsing this forum: No registered users and 1 guest