Exporting to Maxwell MXS Trouble

Exporting to Maxwell MXS Trouble

Postby edwinfolk » Wed May 13, 2020 6:06 am

Hello Sketchers,

I have a question about exporting. I usually use Maxwell Render for my CGs but sometimes have trouble getting good MXS references worth using. I was told that I might be able to use MODO to take a file and turn it into Collada file and from there export it as an MXS. When I import the .dae file there is no problem - I can use it and move around the scene.

The problem is when I try to export the SKP data to a MXS format. If anyone knows how to work around this, it would be greatly appreciated. There are some good mxs file on the net but not enough in my opinion.

Thanks and I look forward to hearing from someone.

Edwin
1

edwinfolk 
 

Re: Exporting to Maxwell MXS Trouble

Postby JD Hill » Wed May 13, 2020 3:41 pm

When I wrote the plugin you could use File > Export > 3D Model to save an MXS, or if you have maxwell studio, you could export to studio. Not sure now, though, so it depends on your version. If it still uses much of the same code, there is also a temporary mxs written at <documents>/Maxwell/SketchUp/temp/temp.mxs when rendering in FIRE.
0
Developer - Bella Render
User avatar
JD Hill 
Bella Render
 

Re: Exporting to Maxwell MXS Trouble

Postby edwinfolk » Fri May 15, 2020 1:12 am

Hello JD,

I send a direct message but not sure if you got it. Anyway, thanks for looking at this and responding. I am using SKU 2018 Pro and Maxwell Render Suite. The problem is that when I take a Collada file and import and then try to send it to anything Maxwell it takes a long time to set the textures etc. I mean like 10+ hours before I lose my patience and nix the export. Thanks again and any ideas are always welcome. Stay safe.
0

edwinfolk 
 

Re: Exporting to Maxwell MXS Trouble

Postby JD Hill » Fri May 15, 2020 1:56 am

Shot in the dark -- group the whole model, right-click the group, and enable Maxwell > UV Coordinates > Ignore Distortion.

(I am not seeing any private message here btw)
1
Developer - Bella Render
User avatar
JD Hill 
Bella Render
 

Re: Exporting to Maxwell MXS Trouble

Postby edwinfolk » Fri May 15, 2020 2:13 am

Hello JD,

Thanks for the fast response. Work like a charm. Is this is a common fix for exporting to mxs? Simple explanation would be great since am not the most adept at coding etc. Again thanks. It is so helpful.

Stay safe
0

edwinfolk 
 

Re: Exporting to Maxwell MXS Trouble

Postby JD Hill » Fri May 15, 2020 2:58 am

It depends on the model; you know how you can distort textures, well sometimes you do that and it is important, while other times it is not, e.g. you import a tree or shrub, where each leaf has had its texture distorted just a very slight bit -- not enough to matter (sometimes it seems so slight as to have been produced by small numerical errors when the model was perhaps generated or processed by some software tool).

By telling the plugin to ignore distortion, it just uses the non-distorted texture, which means it doesn't have to ask sketchup to write a unique bitmap for each leaf.

Since attributes in that menu are applied hierarchically, you can enable them for just a single group (or component instance), or a group of groups, and so forth, all the way up to what we did here, by quickly grouping the whole model, and making everything ignore distortion, just to see if that was the cause of the slowdown.

It was my first guess because the exporter is generally pretty quick, so when there is an unreasonable slowdown, distorted textures are a prime suspect.
1
Developer - Bella Render
User avatar
JD Hill 
Bella Render
 

Re: Exporting to Maxwell MXS Trouble

Postby edwinfolk » Fri May 15, 2020 3:55 am

Hi JD,

Thanks for the explanation. Really helps to understand this stuff.
0

edwinfolk 
 

Re: Exporting to Maxwell MXS Trouble

Postby JD Hill » Fri May 15, 2020 4:48 am

Sure thing, good luck and stay safe. :)
0
Developer - Bella Render
User avatar
JD Hill 
Bella Render
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Extensions & Applications Discussions

Who is online

Users browsing this forum: No registered users and 0 guests

Visit our sponsors: