Anomalie LibFredo6 v9.5a

Anomalie LibFredo6 v9.5a

Postby chon » Fri Jan 03, 2020 10:02 am

Salut à tous, salut Fredo,

Je ne comprenais pas pourquoi j'avais perdu mes prefs depuis la dernière MaJ de LibFredo6 en v9.5a.
Je me suis aperçu que depuis cette dernière MaJ, un nouveau dossier "LIBFREDO6_DATA_Dir" a été recréé à la racine du disque C. Je suppose que LibFredo6 pointe sur ce dossier de paramètres en remplacement du dossier du même nom qui lui est dans "C:\Users\X\AppData\Local".
Je me rappelle que par le passé, ce dossier a déjà été localisé à la racine de C.

Fredo, est-ce une volonté, une obligation, une petite erreur ou il n'y a que moi qui ai cette anomalie ?
0
SU2019 pro 19.3.253 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: Anomalie LibFredo6 v9.5a

Postby fredo6 » Fri Jan 03, 2020 9:36 pm

chon wrote:Salut à tous, salut Fredo,

Je ne comprenais pas pourquoi j'avais perdu mes prefs depuis la dernière MaJ de LibFredo6 en v9.5a.
Je me suis aperçu que depuis cette dernière MaJ, un nouveau dossier "LIBFREDO6_DATA_Dir" a été recréé à la racine du disque C. Je suppose que LibFredo6 pointe sur ce dossier de paramètres en remplacement du dossier du même nom qui lui est dans "C:\Users\X\AppData\Local".
Je me rappelle que par le passé, ce dossier a déjà été localisé à la racine de C.

Fredo, est-ce une volonté, une obligation, une petite erreur ou il n'y a que moi qui ai cette anomalie ?

C'est tres bizarre. Dans v9.5, j'ai changé la façon de determiner l'emplacement du dossier ...\Local avec une methode plus fiable pour les version de SU > SU2014.

Peux tu ouvrir la console Ruby et taper une des 4 commandes suivantes et noter le resultat.

- LibFredo6.su_appdata

- Sketchup.temp_dir

- ENV["LOCALAPPDATA"]

- ENV["APPDATA"]

...mais aussi m'indiquer quelle version de Sketchup tu utilises.

Merci

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Anomalie LibFredo6 v9.5a

Postby chon » Mon Jan 06, 2020 9:03 am

Salut à tous,

Désolé pour le contretemps, le WE est passé par là ! :fro:

Alors...

- LibFredo6.su_appdata :
Code: Select all
C:/

- Sketchup.temp_dir :
Code: Select all
C:/Temp

- ENV["LOCALAPPDATA"] :
Code: Select all
C:\Users\X\AppData\Local

- ENV["APPDATA"] :
Code: Select all
C:\Users\X\AppData\Roaming


Quant à la version de SU, voir ma signature. ;)
0
SU2019 pro 19.3.253 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: Anomalie LibFredo6 v9.5a

Postby fredo6 » Mon Jan 06, 2020 9:27 am

OK. Merci.
Tres étrange.

EDIT: Pourrais tu verifier si le repertoire C:\Users\AppData\Local\Temp existe sur ton PC. Merci
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Anomalie LibFredo6 v9.5a

Postby chon » Mon Jan 06, 2020 3:28 pm

fredo6 wrote:Pourrais tu verifier si le repertoire C:\Users\X\AppData\Local\Temp existe sur ton PC.

Oui il existe.

J'ai fait un autre test :
J'ai remis la v9.4b et déplacé le "C:\LIBFREDO6_DATA_Dir" > LibFredo6 retrouve bien son dossier dans "C:\Users\X\AppData\Local".
J'ai remis ensuite la v9.5a > LibFredo6 me recrée bien "C:\LIBFREDO6_DATA_Dir" en zappant les infos de l'autre dossier.
0
SU2019 pro 19.3.253 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: Anomalie LibFredo6 v9.5a

Postby fredo6 » Mon Jan 06, 2020 7:03 pm

Ce qui est bizarre, c'est que Sketchup.temp_dir retourne C:\Temp et non C:\Users\X\AppData\Local\Temp, comme sur la plupart des machines, dont la mienne.

Dans v9.5b, LibFredo6 se base sur Sketchup.temp_dir pour trouver la directory de stockage local, ce qui et normalement plus fiable que de se fier aux variables d'environnement.

Je fais un update avec un changement pour retrouver le comportement habituel, mais j'aimerai quand meme comprendre ce qui se passe avec l'API Sketchup.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Anomalie LibFredo6 v9.5a

Postby TIG » Mon Jan 06, 2020 8:31 pm

If I might interject...

First...

We keep seeing you use the path .../Users/X/...
But what is your actual user-name ?
If it contains some non-ASCII characters it might mess things up ??


Next...

Did you install SketchUp correctly ?
If not, then it might have affected the returned Temp directory's string...

To check this, whilst logged into Windows as your normal Windows user-name, ensure that SketchUp/Layout are closed.
Find the SketchUp installer's exe file - probably in your Downloads folder ?
Select the exe file's icon and right-click > context-menu > "Run as administrator"
When prompted choose "Repair".
Restart SketchUp and re-run Fredo's tests...

Installing any complex app in any other way can cause weird and unpredictable problems, often around permissions...
So never double-click an installer's exe file to 'Run' it - even if you have admin-powers, it is not the same thing.


Si je peux vous interrompre ...

Premier...

Nous continuons de vous voir utiliser le chemin .../Users/X/...
Mais quel est votre nom d'utilisateur réel ?
S'il contient des caractères non-ASCII, cela pourrait gâcher les choses ??


Prochain...

Avez-vous installé SketchUp correctement?
Sinon, cela pourrait avoir affecté la chaîne du répertoire Temp retourné ...

Pour vérifier cela, lorsque vous êtes connecté à Windows en tant que nom d'utilisateur Windows normal, assurez-vous que SketchUp/Layout sont fermés.
Trouvez le fichier exe de l'installateur SketchUp - probablement dans votre dossier Téléchargements [Downloads] ?
Sélectionnez l'icône du fichier exe et faites un clic droit> menu contextuel> "Exécuter en tant qu'administrateur"
Lorsque vous y êtes invité, choisissez "Réparer".
Redémarrez SketchUp, et relancez les tests de Fredo ...

L'installation d'une application complexe de toute autre manière peut provoquer des problèmes étranges et imprévisibles, souvent autour des autorisations ...
Donc, ne double-cliquez jamais sur le fichier exe d'un installateur pour l'exécuter - même si vous avez des pouvoirs d'administrateur, ce n'est pas la même chose.
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Anomalie LibFredo6 v9.5a

Postby fredo6 » Mon Jan 06, 2020 11:16 pm

TIG,

For info, I logged a question / issue on the github repository.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Anomalie LibFredo6 v9.5a

Postby chon » Tue Jan 07, 2020 9:31 am

fredo6 wrote:Ce qui est bizarre, c'est que Sketchup.temp_dir retourne C:\Temp et non C:\Users\X\AppData\Local\Temp, comme sur la plupart des machines, dont la mienne.

Dans v9.5b, LibFredo6 se base sur Sketchup.temp_dir pour trouver la directory de stockage local, ce qui et normalement plus fiable que de se fier aux variables d'environnement.

J'ai remis la 9.4b et relancé Sketchup.temp_dir pour voir. La réponse est la même que pour la v9.5a : "C:\Temp". Ce qui ne l'empêche pas de pointer vers le bon dossier "LIBFREDO6_DATA_Dir".
Petite précision, sur mon PC, pour centraliser le plus possible les fichiers temp, j'ai modifié les variables d'environnement les concernant :

Variables.jpg

Je précise que j'ai fait ça sur tous les PC sous Windows qui me sont passés entre les mains depuis que nous utilisons des PC sous Windows.

Thanks TIG for your interest of our problems ! ;)
TIG wrote:We keep seeing you use the path .../Users/X/...
But what is your actual user-name ?
If it contains some non-ASCII characters it might mess things up ??

My user-name uses only ASCII characters.
TIG wrote:Did you install SketchUp correctly ?
If not, then it might have affected the returned Temp directory's string...

To check this, whilst logged into Windows as your normal Windows user-name, ensure that SketchUp/Layout are closed.
Find the SketchUp installer's exe file - probably in your Downloads folder ?
Select the exe file's icon and right-click > context-menu > "Run as administrator"
When prompted choose "Repair".
Restart SketchUp and re-run Fredo's tests...

I always install apps with administrator rights (context-menu > "Run as administrator").
Btw, i did the repair and the problem is still running in SU.
0
SU2019 pro 19.3.253 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: Anomalie LibFredo6 v9.5a

Postby fredo6 » Tue Jan 07, 2020 10:13 am

Au moins nous avons l'explication, avec ce changement de ENV variables.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Anomalie LibFredo6 v9.5a

Postby chon » Thu Jan 09, 2020 12:15 pm

Impec la v9.5b ! :thumb: Tout est rentré dans l'ordre.

Merci Fredo ! ;)
0
SU2019 pro 19.3.253 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: Anomalie LibFredo6 v9.5a

Postby fredo6 » Thu Jan 09, 2020 3:39 pm

chon wrote:Impec la v9.5b ! :thumb: Tout est rentré dans l'ordre.

Marci aussi. Ca a permis de clarifier un problème qui aurait pu se poser plus tard de manière moins claire.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Français

Who is online

Users browsing this forum: No registered users and 8 guests

Visit our sponsors: