Filling holes in model

General discussion related to SketchUp Pro and Make

Filling holes in model

Postby philem » Sat Dec 21, 2019 11:36 am

Hey guys I need a little help please.

I have just bought an entry level 3D Printer, I have downloaded a model of a spool holder to put extra spools of filament on, the first print of the model came out ok but there were a couple of small issues with the model.
So I bought it into Sketchup to see what the problem may be and maybe do some small modifications to help with the printing.

When I opened the model I noticed some small holes in the external radius of one corner and a larger one in the internal radius of another corner. Is there a way I can get Sketchup to "Fill" the holes ?

Thanks in advance

Philip
0
Just do it, it might be fun.
User avatar
philem 
 

Re: Filling holes in model

Postby Dave R » Sat Dec 21, 2019 2:23 pm

You probably won't be able to fill the holes automatically but you might be able to avoid them during import. I'm guessing your file is in .stl format. In the Import options, set the units to meters. This should get the file into SketchUp at a size to avoid the tiny face issue. Set Model Units to Meters, too.

Right after importing, run ThomThom's CleanUp3 to get rid of unneeded coplanar edges. Because of the nature of .stl files, there will be lots of them.

After making any changes to the file, export the new .stl and you should be good to go. Make sure when you import the .stl into the slicer you are selecting the right units (millimeters or inches).

By the way, are you still using SketchUp 2014 Make?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Filling holes in model

Postby philem » Sat Dec 21, 2019 10:39 pm

Dave R wrote:You probably won't be able to fill the holes automatically but you might be able to avoid them during import. I'm guessing your file is in .stl format. In the Import options, set the units to meters. This should get the file into SketchUp at a size to avoid the tiny face issue. Set Model Units to Meters, too.

Right after importing, run ThomThom's CleanUp3 to get rid of unneeded coplanar edges. Because of the nature of .stl files, there will be lots of them.

After making any changes to the file, export the new .stl and you should be good to go. Make sure when you import the .stl into the slicer you are selecting the right units (millimeters or inches).

By the way, are you still using SketchUp 2014 Make?


Hi Dave, I will give do what you suggest to sort out the hole issue, and let you know the result, I am running Sketchup Make 2017.

Latest. Hi again Dave, It didn't work, after the Cleanup I still had the holes, I managed to fill the holes in the external radius because they were small, basically one face that was missing in each hole, but the internal radius hole was a reasonable size and I don't know Sketchup well enough to redraw the radius to fill the holes.

I may jusut redraw the item in a CAD programme.

Thanks again for the help.
0
Just do it, it might be fun.
User avatar
philem 
 

Re: Filling holes in model

Postby Dave R » Sun Dec 22, 2019 12:40 am

How big is the model? Physical dimensions? Did you scale it up?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Filling holes in model

Postby philem » Sun Dec 22, 2019 11:25 am

Dave R wrote:How big is the model? Physical dimensions? Did you scale it up?


Hi Dave,

1/ I changed the Template to Meters
2/ I imported the STL File and changed the import options to Meters
3/ Used cleanup3 to clean the model
4/ I tidied up the external radius
5/ Saved it to the SKP format.

The dimensions in Sketchup after the import are 121000mm X 108000mm x 50310mm

The actual size of the printed model is 120mm x 110mm x 50mm

It is a bracket to hold a cylindrical pin thay will hold a 3d printing filament spool, its basic shape is like the letter "L" with the inside corner having a radius.

Hope this helps
0
Just do it, it might be fun.
User avatar
philem 
 

Re: Filling holes in model

Postby Dave R » Sun Dec 22, 2019 12:08 pm

How about sharing the .stl and your .skp file from the import?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Filling holes in model

Postby philem » Mon Dec 23, 2019 9:51 am

Dave R wrote:How about sharing the .stl and your .skp file from the import?


Hi Dave,
For some reason it wouldn't allow me to attach the STL file, I got an error message saying that the extension *.stl is not allowed.

So, I changed the extension of the stl file to .skp

So the file named Holder1 - Copy.skp needs to have the extension renamed back to stl = Holder1 - Copy.stl



Thanks
0
Just do it, it might be fun.
User avatar
philem 
 

Re: Filling holes in model

Postby Box » Mon Dec 23, 2019 10:53 am

Is that the original .stl? It has issues.


As you can see from your post above the size isn't the correct scale of what you want in mm. It can be adjusted but not knowing which are (if any) the critical dimensions, I can only guess.
So I have fixed the holes, easier to do than explain how, and have made the width 50mm.

Try this.
1
User avatar
Box 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: Bing [Bot], boroko28 and 8 guests

Visit our sponsors: