[Bug] older skatter setups with 0.0.5

General discusson for Skatter for SketchUp

Moderator: jiminy-billy-bob

[Bug] older skatter setups with 0.0.5

Postby andybot » Tue Dec 23, 2014 3:39 pm

I've started playing with 0.0.5 version, and I began with loading up a simple terrain I used before. I already had a skatter setup, so I thought I would delete it and start a new one. When I did that, I couldn't make a new skatter, everything seemed frozen. (BTW vray was not loaded when doing this, but don't know if it matters)

part 2: now I tried with a clean file, and was able to pick the area and component, but no preview showed up.

part 3. aack! - 0.0.5 having some major issues for me, can't find any way to get a preview to show up. No skatter showing up in render list, clicking on "area" button doesn't hold down button and I don't get the blue selection thing when I hover over objects. Where do I begin to trouble-shoot? :(

Edit: part 4 - just checked, 0.0.4 is working properly for me. (minus the scrollbar css edit)
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: [Bug] older skatter setups with 0.0.5

Postby JQL » Tue Dec 23, 2014 4:14 pm

I've also had similar problems.

I've noticed the behaviour could be related to the area's feature for inclusion/exclusion.

It gets more stable if I only use areas for including. If I change area's inclusion/exclusion properties, most times the preview vanishes and when this happens the render is also missing that skatter.

Anther thing I noticed is that if I open a file with a preconfigured skatter, I must Regenerate each skatter so it will show on preview and render again.
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [Bug] older skatter setups with 0.0.5

Postby andybot » Tue Dec 23, 2014 4:18 pm

area also didn't work for me unfortunately. Couldn't get a preview under any combination of button pressing
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: [Bug] older skatter setups with 0.0.5

Postby andybot » Tue Dec 23, 2014 4:20 pm

Not sure if this is related or not, let me know if this should be a separate bug post: If I don't close out of the SU session and just open a new file, the old skatter setups from the previously open file are still there.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: [Bug] older skatter setups with 0.0.5

Postby jiminy-billy-bob » Tue Dec 23, 2014 4:53 pm

Any error in the ruby console ?
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [Bug] older skatter setups with 0.0.5

Postby andybot » Tue Dec 23, 2014 7:11 pm

I only opened the console after things weren't going right. Once I had it open, nothing.

Now that I am coming back to it with a new file, everything works fine. Sheesh!

However:
I did retrace my steps working with a file with a previous skatter setup. The first thing I did was delete the skatter setup from before that shows up in the render list window. There I get an error thus:

Code: Select all
Error: #<NoMethodError: undefined method `delete' for nil:NilClass>
C:/Users/Andy Orban1/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:307:in `block in start_dialog'
C:/Users/Andy Orban1/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:15:in `call'
C:/Users/Andy Orban1/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:15:in `block in add_bridge_callback'
SketchUp:1:in `call'


after that I can't use the "surfaces" or "areas" picker and all the craziness from the above posts ensues.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: [Bug] older skatter setups with 0.0.5

Postby jiminy-billy-bob » Tue Dec 23, 2014 9:16 pm

Ok thanks. I'm starting my christmas marathon for the next week, so I won't be able to look at this right now. I'll get back to you in time.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [Bug] older skatter setups with 0.0.5

Postby andybot » Tue Dec 23, 2014 10:05 pm

jiminy-billy-bob wrote:Ok thanks. I'm starting my christmas marathon for the next week, so I won't be able to look at this right now. I'll get back to you in time.


no problem, likewise. Merry Christmas!
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: [Bug] older skatter setups with 0.0.5

Postby jiminy-billy-bob » Tue Dec 30, 2014 1:03 pm

So it breaks only whith existing files created with 0.0.4?
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Skatter

Who is online

Users browsing this forum: No registered users and 3 guests

Visit our sponsors: