Shape bender doesn't really work

Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 2:49 pm

Doesn't seem like Chris is available. I have no choice but just create a new post here. Shape bender doesn't really work for this kind of shape. Anyone know why?
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby SketchUpNoobie » Mon Jul 25, 2011 3:03 pm

Works fine for me.

Try to be a little more specific. What does "not work" mean? Does SketchUp crash? Does does the plugin just hang? Do you get an error message? Do you get messed up geometry?

You'll get a better answer if you let people know whats going on.
0
--

SketchUpNoobie: the complete noob in all things SketchUp.

SketchUpNoobie 
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 3:08 pm

SketchupNoobie wrote:Works fine for me.

Try to be a little more specific. What does "not work" mean? Does SketchUp crash? Does does the plugin just hang? Do you get an error message? Do you get messed up geometry?

You'll get a better answer if you let people know whats going on.



I run the shape bender command but the object doesn't bender at all.
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby Box » Mon Jul 25, 2011 3:25 pm

Works for me.

Did you hit enter after you clicked the two lines?
0
User avatar
Box 
 

Re: Shape bender doesn't really work

Postby TIG » Mon Jul 25, 2011 3:27 pm

It does...
See this... I have moved the group/line/curve onto the origin.
The bent copy was being made up in the air because nothing was at z=0. It is onlt slightly bent because the curve you use is very 'flat'...
Capture.PNG
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 3:37 pm

Box wrote:Works for me.

Did you hit enter after you clicked the two lines?




Of course, I did.

I think it might have something to do with this:
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby TIG » Mon Jul 25, 2011 3:40 pm

Doh!

You never mentioned that error-message until now!
Help us help you. :roll:
We are not that psychic... :?

If you read the tool's download page it clearly says it also requires 'progressber.rb'.
This is a helper file that shows progress in the status-bar.
Download it free from Smustard.com - there is even a link........
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender doesn't really work

Postby Box » Mon Jul 25, 2011 3:41 pm

Link is in the download post.
0
User avatar
Box 
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 4:02 pm

TIG wrote:Doh!

You never mentioned that error-message until now!
Help us help you. :roll:
We are not that psychic... :?

If you read the tool's download page it clearly says it also requires 'progressber.rb'.
This is a helper file that shows progress in the status-bar.
Download it free from Smustard.com - there is even a link........



Thanks Tig.

I works now, takes long though. but how come it created some pieces separated from the shape. I don't see yours come out like that.
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 4:13 pm

and how do I get rid of those doted vertical line on surface. I can't really use offset when they r there.
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby Box » Mon Jul 25, 2011 4:16 pm

Turn off Hidden Geometry.

View/untic Hidden Geometry


P.S. Normal offset won't work on a curved surface, you need the offset from Tools On Surface.
0
User avatar
Box 
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 5:03 pm

Box wrote:Turn off Hidden Geometry.

View/untic Hidden Geometry


P.S. Normal offset won't work on a curved surface, you need the offset from Tools On Surface.



Thanks Box. It helps.

BTW, How do I weld these two pieces together seamlessly?
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby Vicspa » Mon Jul 25, 2011 5:21 pm

Select the middle joining lines and delete them.
0

Vicspa 
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 5:31 pm

vicspa wrote:Select the middle joining lines and delete them.


On the flat one of course you can do that. the one I was showing is on a curve. when deleting the joining lines it will only destroy the structure.
Like this:
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby TIG » Mon Jul 25, 2011 5:32 pm

Hide them - Erase+Shift
or
Smooth them - Erase+Ctrl
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender doesn't really work

Postby Vicspa » Mon Jul 25, 2011 5:34 pm

Yes Jet that happened to me, so I only deleted the front, back and bottom, left the curved one in place.
0
Last edited by Vicspa on Mon Jul 25, 2011 5:36 pm, edited 1 time in total.

Vicspa 
 

Re: Shape bender doesn't really work

Postby TIG » Mon Jul 25, 2011 5:36 pm

As Victor shows it's probably best to copy/mirror one half so you bend the whole thing centered on the line/curve so you avoid the 'seam' problems...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender doesn't really work

Postby Vicspa » Mon Jul 25, 2011 5:37 pm

Tig, :thumb: :thumb: :thumb:
0

Vicspa 
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 6:19 pm

TIG wrote:Hide them - Erase+Shift
or
Smooth them - Erase+Ctrl



I knew. that's what I've done.
I need to delete the line, but not just hide them. Cause I need to work on a seamless surface.
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby TIG » Mon Jul 25, 2011 6:32 pm

'Smooth' them then!
They will then be like any other surface edge :?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender doesn't really work

Postby Jet » Mon Jul 25, 2011 6:56 pm

vicspa wrote:Yes Jet that happened to me, so I only deleted the front, back and bottom, left the curved one in place.



thanks, vicspa. I did that too. but the curved shape became too big. Is there a way to control it?
0
Never give up, Never surrender!

Jet 
 

Re: Shape bender doesn't really work

Postby gilles » Mon Nov 21, 2011 7:12 pm

I did that too. but the curved shape became too big. Is there a way to control it?


Make the curve the shape and the line the same length (entity info).
0
" c'est curieux chez les marins ce besoin de faire des phrases "
User avatar
gilles 
Top SketchUcator
 

Re: Shape bender doesn't really work

Postby sondos » Mon May 06, 2013 11:40 pm

SketchUpNoobie wrote:Works fine for me.

Try to be a little more specific. What does "not work" mean? Does SketchUp crash? Does does the plugin just hang? Do you get an error message? Do you get messed up geometry?

You'll get a better answer if you let people know whats going on.

why shape bend can't choose the line when it ask me to choose it
0

sondos 
 

Re: Shape bender doesn't really work

Postby sondos » Mon May 06, 2013 11:45 pm

I recently started using plugins on sketchup and Im also kinda amateur in using this program. I added your Plugin to my sketchup. Im trying to bend a wall with all its windows and openings but Im having a problem. Every time that I wanna activate the plugin it says "Please have a single group or Component to bend selected before activating the script."



I tried it with making my wall into a group and then selecting it, or exploding it and selecting the very bottom line, or drawing a line at the bottom of the wall and selecting it, or selecting both the line from the wall and the curved single line that I had made but nothing is working. Any suggestion?
0

sondos 
 

Re: Shape bender doesn't really work

Postby TIG » Tue May 07, 2013 8:29 am

sondos wrote:...why shape bend can't choose the line when it ask me to choose it
The line AND the curve must NOT touch any other geometry, including each other.
This first picked line must also be parallel to the X-axis [red].
Tips:
If you get Ruby Console errors relating to 'cursors' it suggests that you have not installed this tool correctly and its folder of cursor images etc is missing or it's incomplete.
If you get other errors in the Ruby Console or the tool 'stalls' after starting, then also ensure that you have downloaded and installed the helper file 'progressbar.rb' from 'smustard.com', as instructed in this tool's download page notes...


EDIT: the v2014 compliant version no longer needs progressbar.rb !

0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender doesn't really work

Postby 1232sean » Sun Jun 15, 2014 7:59 pm

I am having a problem with shapebender where I get it to work but it only gives me the frame of my shape and not the surfaces. Do you know what is going on?
1

1232sean 
 

Re: Shape bender doesn't really work

Postby cotty » Mon Jun 16, 2014 7:03 am

Do you have a picture?
0
User avatar
cotty 
Top SketchUcator
 

Re: Shape bender doesn't really work

Postby Painreliever » Wed Feb 19, 2020 10:45 am

Hi guys,

when I select the horizontal line drawn on red axes, it does not really be selected (I don't get the notification of start&end) so the bending does not occur??

Moreover, in extension manager a warning is shown "Unsigned", may that be the problem?

Thnx
0

Painreliever 
 

Re: Shape bender doesn't really work

Postby TIG » Wed Feb 19, 2020 1:37 pm

What version of SketchUp are you using - I suspect your profile is out of date ?

The unsigned issue is a red-herring.
It just means that it's an older tool and will run in Extension loading policy > Unrestricted - which you must have set, otherwise it wouldn't even appear in the menu !

Run it with the Ruby Console open to see any error messages...

Is the 'red' line really parallel to the model's red-axis or have you perhaps reset the axes to confuse things ?

There was a version of v2019 that broke this tool, it was fixed by a latest MR - so do you have that later version ?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Shape bender not working correctly

Postby muazzam5abbas » Tue Apr 14, 2020 7:21 pm

hi!
i am stuck with shape bender. i recently added shape bender plugin from sketchUcation in SU pro 2019.
i am doing everything right as told in various tutorials. placing base line along red axis. but when i select base line after initiating shape bender , it selects the base line successfully and ask to select the curve for bend. but doesn't show start and end point as shown in tutorials. similarly when i select the curve, it neither shows the start and end points and does nothing. what should i do.
i have already tried uninstalling and reinstalling shape bender tool.
0

muazzam5abbas 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

Next


 

Return to Organic Modelling

Who is online

Users browsing this forum: No registered users and 0 guests

Visit our sponsors: