[Plugin] ExtrudeTools - Full Set

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Fri Aug 31, 2012 5:10 pm

camsoccer2 wrote:Hey Tig, in the lattice tool, is it possible to have the material choices include the material layers I have created in the project instead of the generic red, green, etc.?

Cam
No, not unless you recode it yourself, and then the material-list will become unmanageably long ! ...
So make it say 'Red', then edit the group, select a 'Red' face and use the context-menu to select 'all matching material'... Then use the Materials Browser to paint what's selected with any other material you desire - either in the Model or from an external Collect. You can do something similar for the 'Glass' too...
It's only seconds to do, and this method allows you to change to whatever you want at any time...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Sun Sep 02, 2012 5:31 pm

OK here is whole error string... I believe the top is relating to extrude tools.


Error Loading File #extrusionToolbar.rb
can't convert nil into StringError Loading File 2D#.rb
can't convert nil into StringError Loading File __loader.rb
uninitialized constant TraductorError Loading File arc.rb
can't convert nil into StringError Loading File attributes.rb
can't convert nil into StringError Loading File babelfish.rb
can't convert nil into StringError Loading File bezier.rb
can't convert nil into StringError Loading File binary.rb
can't convert nil into StringError Loading File bootstrap_Curvizard.rb
uninitialized constant Curvizard::T6Error Loading File bounds.rb
can't convert nil into StringError Loading File color.rb
can't convert nil into StringError Loading File core.rb
can't convert nil into StringError Loading File cursor.rb
can't convert nil into StringError Loading File CurvizardAlgo.rb
uninitialized constant Curvizard::T6Error Loading File CurvizardTool.rb
uninitialized constant Curvizard::T6Error Loading File debug.rb
can't convert nil into StringError Loading File definition.rb
can't convert nil into StringError Loading File dimension.rb
can't convert nil into StringError Loading File edges.rb
can't convert nil into StringError Loading File entities.rb
can't convert nil into StringError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/examples/exampleScripts.rb
undefined method `file_loaded?' for main:ObjectError Loading File examples.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByEdges.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByFace.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByFaces.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByLathe.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByLoft.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByOffset.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByRails.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByRailsByFace.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByRailsToLattice.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByVector.rb
undefined method `file_loaded?' for main:ObjectError Loading File extrudeEdgesByVectorToObject.rb
undefined method `file_loaded?' for main:ObjectError Loading File faces.rb
can't convert nil into StringError Loading File FredoTools.rb
uninitialized constant FredoTools::T6Error Loading File FredoTools__ConstructFaceNormal.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__CountFacesBySides.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__CurviShear.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__MarkVertices.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__RemoveLonelyVertices.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__ReportLabelArea.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__ReverseOrientFaces.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__RevertCurve.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File FredoTools__ThruPaint.rb
undefined method `register_plug' for FredoTools:ModuleError Loading File geom3d.rb
can't convert nil into StringError Loading File gizmo_manipulator.rb
can't convert nil into StringError Loading File gui.rb
can't convert nil into StringError Loading File image.rb
can't convert nil into StringError Loading File Image2Model.rb
undefined method `file_loaded?' for main:ObjectError Loading File inputbox.rb
can't convert nil into StringError Loading File instance.rb
can't convert nil into StringError Loading File javascript.rb
can't convert nil into StringError Loading File json.rb
can't convert nil into StringError Loading File locale.rb
can't convert nil into StringError Loading File materials.rb
can't convert nil into StringError Loading File Mirror.rb
undefined method `file_loaded?' for main:ObjectError Loading File modal_wrapper.rb
can't convert nil into StringError Loading File model.rb
can't convert nil into StringError Loading File point3d.rb
can't convert nil into StringError Loading File point3d_ex.rb
can't convert nil into StringError Loading File progressbar.rb
can't convert nil into StringError Loading File ray.rb
can't convert nil into StringError Loading File SectionCutFace.rb
undefined method `file_loaded?' for main:ObjectError Loading File selection.rb
can't convert nil into StringError Loading File settings.rb
can't convert nil into StringError Loading File simpletask.rb
can't convert nil into StringError Loading File system.rb
can't convert nil into StringError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/TheaExporter_files/loader.rb
undefined method `file_loaded?' for SU2TH:ModuleError Loading File TheaExporter_loader.rb
undefined method `file_loaded?' for SU2TH:ModuleError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/TIG-Superdrape/TIG-Superdrape.rb
undefined method `file_loaded?' for TIG:ModuleError Loading File TIG-Superdrape.rb
undefined method `file_loaded?' for TIG:ModuleError Loading File toolbarwindow.rb
can't convert nil into StringError Loading File toolwindow.rb
can't convert nil into StringError Loading File tt_cleanup.rb
can't convert nil into StringError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/TT_UV_Toolkit/loader.rb
can't convert nil into StringError Loading File tt_uv_toolkit_2.rb
undefined method `file_loaded' for main:ObjectError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/Utilities/utilitiesTools.rb
undefined method `add_separator_to_menu' for main:ObjectError Loading File utilities.rb
undefined method `add_separator_to_menu' for main:ObjectError Loading File uv_plane.rb
can't convert nil into StringError Loading File uvq.rb
can't convert nil into StringError Loading File version.rb
can't convert nil into StringError Loading File webdialog_patch.rb
undefined method `is_osx?' for TT::System:ModuleError Loading File win32.rb
can't convert nil into StringError Loading File window.rb
can't convert nil into StringError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Tools/AdvancedCameraTools/actloader.rb
undefined method `add_separator_to_menu' for FSCameraData:ModuleError Loading File advancedcameratools.rb
undefined method `add_separator_to_menu' for FSCameraData:ModuleError Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Tools/Sandbox/SandboxMenus.rb
undefined method `add_separator_to_menu' for main:ObjectError Loading File sandboxtools.rb
undefined method `add_separator_to_menu' for main:Object
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Sun Sep 02, 2012 5:33 pm

Should I attempt to have clean install of SketchUp?
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Sun Sep 02, 2012 5:38 pm

OK... guess I was wrong... after clean install I have now ruby console. I will now first install thea and twilight and do one plugin in time and see.
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Sun Sep 02, 2012 6:26 pm

Good idea... :roll:
A screen-shot of your Tools & Plugins folder will help if you continue to have problems...
Check that you haven't [re]installed any old 'toolbar' compilations etc that might put old versions of 'system files' into Plugins when they should only ever be in Tools - e.g. 'sketchup.rb' ...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Sun Sep 02, 2012 6:44 pm

I have found the culprit which triggered all this problems. It is solar north extension.
Now I have Ruby Console and plugins so far installed are all loading without error.... :enlight:
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby Dave R » Sun Sep 02, 2012 6:59 pm

I wonder how the Solar North extension could cause all that?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Sun Sep 02, 2012 8:19 pm

Are you sure it's called Solar-North??
There was a known rogue script called something like Solar-Position...
That might have messed with the system-file Solar-North that has NO KNOWN issues :roll:

Can you please post a screen-shot of your problem folders............ you make it doubly difficult for us to help when you don't help us...
We try to help... but the help goes to those that help themselves...
[missing out a 'God' reference there - as the more astute of you might have spotted...]

This lack of common-sense seems endemic :roll:
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Sun Sep 02, 2012 8:39 pm

I did not have any other plugins bar Twilight and Thea. Now everything looks fine apart from UV tools.
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Sun Sep 02, 2012 8:48 pm

and here is SU folder
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby panixia » Tue Sep 04, 2012 8:05 am

TIG wrote:Solar-North that has NO KNOWN issues

i remember i had some trouble using solar north about a year ago. it caused bugsplats every time i tried to use it.. so i don't try to use it anymore..
0
User avatar
panixia 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Tue Sep 04, 2012 8:59 am

The Extrusion tools are 11 in number - you have managed to get an extra blank first button :roll: What does it do if you press it ?
This suggests something is [mis]loading twice ???
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby wind-borne » Tue Sep 04, 2012 9:12 am

TIG wrote:The Extrusion tools are 11 in number - you have managed to get an extra blank first button :roll: What does it do if you press it ?
This suggests something is [mis]loading twice ???


this toolbar behavior on Mac was discussed at length early in the thread when there were only a few tools :?

viewtopic.php?p=218480#p218480
0
"To read between the lines was easier than to follow the text."OSX 10.11.6 _ _ _ _ _ SU 8 pro
User avatar
wind-borne 
Premium Member
Premium Member
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Tue Sep 04, 2012 9:13 am

TIG wrote:The Extrusion tools are 11 in number - you have managed to get an extra blank first button :roll: What does it do if you press it ?
This suggests something is [mis]loading twice ???

It does nothing
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Tue Sep 04, 2012 9:15 am

As mentioned in earlier threads, try changing it from a horizontal to a vertical toolbar arrange.
Close and restart Sketchup and set the toolbar back to horizontal - the extra button should disappear - it seems to be a MAC only occasional glitch :?
The code makes an empty toolbar and adds the various tools onto it one at a time.
Somehow on a MAC if the bar is horizontal it decides it needs an empty button, before the real buttons are made - however, flipping it vertical, restarting and making it horizontal again removes this oddity... Most MAC users and all PC users never get this happening... :roll:
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Tue Sep 04, 2012 9:50 am

TIG wrote:As mentioned in earlier threads, try changing it from a horizontal to a vertical toolbar arrange.
Close and restart Sketchup and set the toolbar back to horizontal - the extra button should disappear - it seems to be a MAC only occasional glitch :?
The code makes an empty toolbar and adds the various tools onto it one at a time.
Somehow on a MAC if the bar is horizontal it decides it needs an empty button, before the real buttons are made - however, flipping it vertical, restarting and making it horizontal again removes this oddity... Most MAC users and all PC users never get this happening... :roll:

OK thanks ... I will try that when I get back home.
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby sepo » Tue Sep 04, 2012 11:15 am

TIG wrote:As mentioned in earlier threads, try changing it from a horizontal to a vertical toolbar arrange.
Close and restart Sketchup and set the toolbar back to horizontal - the extra button should disappear - it seems to be a MAC only occasional glitch :?
The code makes an empty toolbar and adds the various tools onto it one at a time.
Somehow on a MAC if the bar is horizontal it decides it needs an empty button, before the real buttons are made - however, flipping it vertical, restarting and making it horizontal again removes this oddity... Most MAC users and all PC users never get this happening... :roll:

It worked...Thanks for your help Tig.
0

sepo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby pbacot » Fri Sep 14, 2012 10:36 pm

I went back to an old project file and was looking at a part and thinking, "Now how did I do that?"

Someone (my earlier self) left a message. :?
mushroom.png


Thanks TIG!
0
MacOSX Mojave ShetchUp Pro v19 Twilight Pro v2 M2 Kerkythea PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby Lana » Thu Oct 11, 2012 5:50 am

Thanks, thanks Tig. :fecstatic:
0
User avatar
Lana 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby dinsa2 » Thu Oct 18, 2012 9:16 pm

Thank you for this great contribution....
0

dinsa2 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby pureinhere » Wed Oct 31, 2012 5:28 pm

Hello all, first post here. Love the plugin and all the others I found hear. I have a quick question.

When I use the extrude edges by faces command, say an oval on the end of a curve, and a circle at the beginning of the curve, I often get a flat spot when the two merge together at a certain point in the middle. Is there a way for it to stay perpinddicular to the path at all times? If someone can let me know how to post an image I can do that as well. Thanks for the great plugins and your time as well.

DC
0

pureinhere 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Wed Oct 31, 2012 6:17 pm

You need to fix the start of both curves; otherwise the 'real start' gets taken and as these might not be near each other, you'll get a 'twist' as the surface is bent around...
So if you add a line square to each of the circle/oval perimeter so that it 'splits' it where it meets, then this tool should start each surface aligned at the same place and therefore not 'twist' it...
The alternative is to try one of Fredo's CurviLoft tools, which can give similar results...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby victor hugo » Tue Nov 27, 2012 9:36 pm

Hi TIG.

Is there any pdf documentation for this really cool :thumb: plugins?

Thanks.
0

victor hugo 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby TIG » Tue Nov 27, 2012 11:43 pm

Each individual tool has its own thread - each of which is linked through the zipped set's download page.
On each tool's page are detailed explanations, images etc; there are some videos for some of them too...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby redgray » Wed Dec 12, 2012 6:48 am

Wow, this is what I'm looking for, thanks for this excellent tool!!!
0

redgray 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby christopher shaw » Wed Dec 19, 2012 5:45 pm

Hi, ive downloaded and unzipped but nothing seems to have changed in sketchup, there doesnt appear to be a plugin menu. Can anyone help? Mnay thanks :)
Chris
0

christopher shaw 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby Rich O Brien » Wed Dec 19, 2012 6:58 pm

Is it enabled under preferences?
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby christopher shaw » Wed Dec 19, 2012 9:30 pm

Rich O Brien wrote:Is it enabled under preferences?

Yes i believe plugins are enabled as there is a tab fro plugins between "window" and "help" at the top of the screen. But when i click on the plugin tab the dropdown only offers "cost" and there is no extrude sub heading. Any jelp much appreciated
Chris
0

christopher shaw 
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby Rich O Brien » Thu Dec 20, 2012 1:06 am

go to Window > Preferences > Extensions and see if Extrude Tools is listed and checked/enabled
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] ExtrudeTools - Zipped Set 20111207

Postby christopher shaw » Thu Dec 20, 2012 1:15 am

Rich O Brien wrote:go to Window > Preferences > Extensions and see if Extrude Tools is listed and checked/enabled

I've checked as you suggested but extrude is not in the list to be checked/enabled :/
Sorry to be a pain, thanks for your input
Chris
0

christopher shaw 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: murina, Warr and 11 guests

Visit our sponsors: