Clothworks fail to load.  Topic is solved

Clothworks fail to load.

Postby endlessfix » Sun Apr 17, 2022 5:51 pm

Apologies if I have failed to format the following text correctly, I am inexperienced on this forum. This morning my licensed Clothworks Extensions fails to load, I get the following error message. Could anyone help me interpret this message so that I can fix the situation? Incidentally, in this state SketchUp now also not fails to quit, it hangs after selecting quit and I must force quit to exit, possibly related? Any help would be appreciated.

Code: Select all
Error: #<LoadError: An exception occurred while loading ams_clothworks, version 1.7.5a!

dlopen(/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/libraries/1.7.5a/osx64/2.7/cw_lib.bundle, 9): no suitable image found.  Did find:
   /users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/libraries/1.7.5a/osx64/2.7/cw_lib.bundle: code signature invalid for '/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/libraries/1.7.5a/osx64/2.7/cw_lib.bundle'
 - /users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/libraries/1.7.5a/osx64/2.7/cw_lib.bundle>
/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/extension_manager.rbe:173:in `rescue in block in require_all'
/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/extension_manager.rbe:169:in `block in require_all'
/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/extension_manager.rbe:165:in `each'
/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/extension_manager.rbe:165:in `require_all'
/users/riley/library/application support/sketchup 2022/sketchup/plugins/ams_clothworks/main.rbe:746:in `<main>'
/Applications/SketchUp 2022/ `eval'
/Applications/SketchUp 2022/ `require'
/Applications/SketchUp 2022/ `load'
/Users/riley/Library/Application Support/SketchUp 2022/SketchUp/Plugins/ams_ClothWorks.rb:38:in `register_extension'
/Users/riley/Library/Application Support/SketchUp 2022/SketchUp/Plugins/ams_ClothWorks.rb:38:in `<module:ClothWorks>'
/Users/riley/Library/Application Support/SketchUp 2022/SketchUp/Plugins/ams_ClothWorks.rb:7:in `<module:AMS>'
/Users/riley/Library/Application Support/SketchUp 2022/SketchUp/Plugins/ams_ClothWorks.rb:6:in `<top (required)>'


Re: Clothworks fail to load.  Topic is solved

Postby Rich O Brien » Sun Apr 17, 2022 7:38 pm

You need to update your Clothworks to v1.7.6
User avatar
Rich O Brien 

Re: Clothworks fail to load.

Postby endlessfix » Sun Apr 17, 2022 8:05 pm

Excellent. Done and all working again, embarrassed I didn't try that first. Thank you for your reply.


Re: Clothworks fail to load.

Postby Box » Mon Apr 18, 2022 12:16 am

Here's a link to the post where Anton mentions the problem and solution, for anyone coming along looking for more info.
User avatar

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago

Ad Machine 


Return to Extensions & Applications Discussions

Who is online

Users browsing this forum: No registered users and 2 guests