Error: #<Errno::EACCES: Permission denied @ rb_sysopen

Error: #<Errno::EACCES: Permission denied @ rb_sysopen

Postby Rickwoody » Sun Feb 14, 2021 1:22 am

After upgrading to Sketchup 2021 I have been receiving this error on startup;

Error: #<Errno::EACCES: Permission denied @ rb_sysopen - C:/Users/Rick/AppData/Local/Temp/SCF/SketchUcation_Usage.log>
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:192:in initialize' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:192:in open’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:192:in log_write' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf-rbztools.rbe:181:in rescue in module:RBZtool’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf-rbztools.rbe:175:in <module:RBZtool>' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf-rbztools.rbe:158:in ’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:66:in eval' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:66:in require’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:66:in block in load_files' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:64:in each’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:64:in load_files' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:69:in module:SCF’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:13:in <main>' C:/Program Files/SketchUp/SketchUp 2021/Tools/extensions.rb:197:in eval’
C:/Program Files/SketchUp/SketchUp 2021/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2021/Tools/extensions.rb:197:in load’
C:/Users/Rick/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins/SketchUcation.rb:181:in register_extension' C:/Users/Rick/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins/SketchUcation.rb:181:in module:SCF’
C:/Users/Rick/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins/SketchUcation.rb:17:in `<top (required)>’

I do not get the error if I disable Sketchucation tools
I have repaired, removed and reinstalled, as administrator, removed previous versions (now I’m worried) and tried everything I know. I believe I am missing a script?

I just tried...Close SketchUp. Go to User/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins. Find the folder called Sketchucation and the .rb file with the same name. Delete them. Then go to User/AppData/Local and delete the SCF and SCF Licenses folders. Next, go to Sketchucation and get the latest version of the tool. Download it and then use Install Extension under Window>Extension Manager to install it. Quit SketchUp again and restart it.

Any ideas? Thanks!
0

Rickwoody 
Premium Member
Premium Member
 

Re: Error: #<Errno::EACCES: Permission denied @ rb_sysopen

Postby TIG » Sun Feb 14, 2021 2:10 pm

Error: #<Errno::EACCES: Permission denied @ rb_sysopen - C:/Users/Rick/AppData/Local/Temp/SCF/SketchUcation_Usage.log>

The SketchUcation toolset writes a log file used in our own debugging.
It does it silently as you use its tools.

Fortunately the error is quite clearly explained in the error message [often it can be somewhat arcane !]

SketchUp is unable to open the log file to write into it - this suggests a folder/file permissions limitation which was probably created by initially installing SketchUp incorrectly [i.e. not using ...right-click installer's exe > "Run as administrator"]... subsequent corrections of the installation - perhaps using 'Repair' - didn't reset that particular permission as it's outside the main 'SketchUp' domain...
A simple fix would be to exit SketchUp and use Windows Explorer to open the Temp folder
C:/Users/Rick/AppData/Local/Temp
Then delete its SCF subfolder.
This will delete the subfolder and its contents [i.e. SketchUcation_Usage.log], if any.
When you restart SketchUp and the SketchUcation toolset loads it will not find the subfolder or log file and recreate both of them, this time using the correct permissions as were reset by any 'Repair' you might have done to the main SketchUp installation...

If you get error-message problems with the other SCF files [not in Temp], then deleting those might help too... C:\Users\Rick\AppData\Local\SCF
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Extensions & Applications Discussions

Who is online

Users browsing this forum: No registered users and 2 guests

Visit our sponsors: