Проблемы с производительностью и их решения

Проблемы с производительностью и их решения

Postby mr_Crow » Sun Feb 10, 2008 4:06 pm

Люди, весь инет перерыл - неужели никто не в курсе чем помочь?
Проблема заключается в том что в Скетчапе жуткие тормоза при отображении 3D в режиме OGL.
а без него в сложных сценах как знаете никак...
В чем может быть проблема?
Две машины, конфиг одинаковый - разница в виидео только, проблема на обоих.
Win XP SP2
Скетчап про 6.4.112
Коре E6300
4*1Гб DDR800
Видео 3850 512/ 1950GT 256
каталист 8,1

ЗЫ: схожая проблема обсуждается ТУТ, и ТУТ, но как понял из аглицкого - однозначного решения нет пока... :cry:
0

mr_Crow 
 

Re: Проблемы с производительностью и их решения

Postby ups » Sat Mar 08, 2008 2:10 am

mr_Crow wrote:Win XP SP2
4*1Гб DDR800


Насколько я понимаю, это 64-битная версия? Может, проблема в этом?
Вот одно решение, которое тут обсуждалось: For all those who has, directx10 compatible graphic cards, all you have to do is to make sure that your antialising settings are set to "let the application choose". That's all. No glitches no absurd graphics.
http://www.sketchucation.com/forums/scf/viewtopic.php?f=11&t=2109
0

ups 
 

Re: Проблемы с производительностью и их решения

Postby mr_Crow » Thu Mar 13, 2008 8:43 pm

ups wrote:Насколько я понимаю, это 64-битная версия? Может, проблема в этом?

нет. ось 32 битная.
чесслово не знаю в чем проблема. перепробывал разные комбинации настроек, но желаемого не добился..
есть подозрение что все случилось после осеннего обновления DX. скоро буду переустанавливать виндовс - будет возможность проверить... :fro:

зы: в первом своем посте неточно выразился - не в OGL режиме, а в режиме аппаратного ускорения... :oops:
0

mr_Crow 
 

Re: Проблемы с производительностью и их решения

Postby ups » Fri Mar 14, 2008 1:04 am

Вообще, SU очень прожорлив, по моим наблюдениям. На моём стареньком компе я модель больше 4Мб уже с трудом поворачиваю (при включённых тени и текстурах). Но у меня P4 и видео ATI Rage 128 c 32Мб памяти. Хотя, и на более приличных машинах то же не супер скорость и качество.
Интересно то, что разработчики никаких конкретных рекомендаций по видеокартам не дают.

А у вас насколько большие модели?
0
Last edited by ups on Sat Mar 22, 2008 5:27 pm, edited 1 time in total.

ups 
 

Re: Проблемы с производительностью и их решения

Postby mr_Crow » Fri Mar 21, 2008 10:11 pm

я б не сказал что прожорлив. есть свои нюансы, но в общем - на уровне других 3d редакторов.
а модельки у меня разные - в аттаче образец.
и, как говорил до декабря месяца проблемы не наблюдалось все было ок. и что странно, проблема наблюдается только на моих на домашних компах. причем на обоих сразу. переуcтановка винды не помогла. пробовал с настройками биоса и вообще с разгоном повозиться - опять таки безрезультатно...
в итоге работаю без аппаратного ускорения :(
зы: а на работе все работает ок. даже позволяет на аналогичных сценах включать антиалиасинг при работе:) там конфиг такой: C2D e6400/2Gb/p5b/7900GS_256/WinXP SP2
0

mr_Crow 
 

Re: Проблемы с производительностью и их решения

Postby ups » Sat Mar 22, 2008 5:14 pm

Я посмотрел модель - у меня тоже она очень тяжело вращалась. Однако, когда я отключил туман, то даже с текстурами и тенями работало относительно приемлемо по скорости. Но, это, конечно, очень субъективное мнение.
А винда переустанавливалась поверху или делался формат диска?
0

ups 
 

Re: Проблемы с производительностью и их решения

Postby mr_Crow » Sun Mar 23, 2008 4:57 pm

работаю канешна с отключенным туманом и тенями и прочими эффектами... это включается и настраивается только для получения картинки..
а как иначе??, никаких ресурсов не хватит ;)..
эх.. никто не может понять суть проблемы:)впрочем как и я раньше - наверняка бы не понял пока не столкнулся.
дело не в закономерном снижении производительности по мере наполнения сцены, а катострофических лагов при активировании аппаратного ускорения. такое ощущение что возникают задержки перерисовки окна.

вот подробные симптомы (наблюдается на обоих компах):
1. поставил атитрейтулс (они в реалтайме отображают в уголке окна скорость прорисовки кадров аналогично фрапс, и опережу возможный вопрос - на результат не влияют - проверено). в скетчапе включил аппаратное ускорение. открыл файл - 500.skp (тот что в предыдущем моем посте в аттаче), отключил все визуальные эффекты.
при вращении сначала замирание 1-2 сек, потом показывает стабильные 70-90 ФПС. прекратил вращение - счетчик замер на последней цифре. начал вращение/приближение/удаление - опять, фриз 1-2 сек и снова 70-90. пробовл разные Face Style - Shaded, Shaded with Texture, Hidden Line, Monochrome, с X-ray и без - результат тот же. хотя в режиме Face Style - Wireframe - заметное улучшение, но все равно фриз присутствует...
отключаю аппаратное ускорение - произвожу те же операции - в принципе комфортно, кроме режимов Face Style - Shaded with Texture, ожидение подгрузки/обработки текстур вызывает дискомфорт..но работать можно. вот так и перебиваюсь..

и еще: эта модель создавалась примерно в сентябре месяце на моем домашнем компе где стоит x1950GT и на рабочем компе где GF7900GS. ни тут, ни там абсолютно никаких проблем не было - я даже баловался антиалиасингом!!! потом до нового года не пользовался скетчапом. после нового года пришлось опять воспользоваться, и столкнулся с этими проблемами. у меня появился второй комп. с приблизительно аналогичной конфигурацией, но с отличием в видеокарте - HD 3850 512 - и на нем тоже проявилась эта проблема!!! а на работе на GF7900GS - до сих пор такой проблемы нет!
хм, думал может быть проблема в последних драйверах АТИ? но в других программах, играх и пр. каких-либо проблем не наблюдается - все как часики..
как уже говорил, после этого делалась переустановка винды, с форматированием раздела. пробовал версию с необновлением Dx. пробовал разные настройки драйверов, перепробовал от 7.9 до 8.3 каталиста. с полным/неполным удалением старых... пробовал разные настройки в биоcе - по дефолту, с разгоном проца, шины PCIEx, памяти, разные напряжения...бесполезно..вопщем непонятно..раньше же как то оно работало...и очень даже неплохо работало..
что я делаю неправильно?? :fro:
и стоит ли вообще искать правды? :) в принципе уже привык - терпимо...
0

mr_Crow 
 

Re: Проблемы с производительностью и их решения

Postby ups » Mon Mar 24, 2008 11:41 pm

отключаю аппаратное ускорение - произвожу те же операции - в принципе комфортно, кроме режимов Face Style - Shaded with Texture, ожидение подгрузки/обработки текстур вызывает дискомфорт..но работать можно. вот так и перебиваюсь..


Ну, я бы тогда и не особенно переживал по этому поводу. У меня схожие задержки появились тоже не так давно, но в игре. И не понятно почему (вроде бы появились после того, как нахватался троянов или же некорректного выключения компа, произошедшего в тот же день). Все настройки менял, троянов поубивал - задержки остаются. Не знаю, может не всех поубивал...
Если так, то возможно они грузят процессор. Разработчики SU что-то там такое говорили что в SU процессор работает 50 на 50 с видеокартой, что вполне возможно, т.к. просчёт теней - задача процессора, ИМХО.

Насчёт драйверов ати - я тут где-то читал, что при возникновении проблем советовали установить старые, предварительно почистив машину от новых. Надеюсь, это поможет.
0

ups 
 

Re: Проблемы с производительностью и их решения

Postby mr_Crow » Tue Apr 29, 2008 8:10 pm

помогло:)
сменил свои обе видеокарточки от ати - на 8800gt и 8800gts.
сразу изчезли все проблемы:) эх... вот так и вкладываем в компустер сотни и сотни $ из-за одной программулины или игрушки :mrgreen: :mrgreen:
0

mr_Crow 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Pусский

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: