Error running ComponentFinder

Discussions for FlexTools - Responsive Sketchup Modeling

Error running ComponentFinder

Postby wenzhi1099 » Fri Nov 30, 2018 4:00 am

After installing ComponentFinder, I reload the SU, and then prompt error, like this

Error: C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/openssl.rb:17:in `<top (required)>'
C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/modules/application.rbe:3:in `<main>'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:58:in `eval'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:58:in `require'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:58:in `main'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:80:in `<module:FlexTools>'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:15:in `<module:F3d>'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:14:in `<main>'
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in `eval'
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in `require'
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in `load'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:22:in `register_extension'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:22:in `<module:FlexTools>'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:7:in `<module:F3d>'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:6:in `<top (required)>'
Error: #<NameError: uninitialized constant F3d::FlexTools::Application>
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:76:in `main'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:80:in `<module:FlexTools>'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:15:in `<module:F3d>'
c:/users/administrator/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/f3d_flextools/main.rbe:14:in `<main>'
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in `eval'
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in `require'
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in `load'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:22:in `register_extension'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:22:in `<module:FlexTools>'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:7:in `<module:F3d>'
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:6:in `<top (required)>'


how can i fix it?
thank you
0

wenzhi1099 
 

Re: Error running ComponentFinder

Postby halroach » Sat Dec 01, 2018 12:46 pm

Hi Wenzhi,

We have seen this error come up a few times before. Please see the following explanation and solution:
https://flextools.cc/help/load-error-127/
1
User avatar
halroach 
 

Re: Error running ComponentFinder

Postby TIG » Sun Dec 02, 2018 12:31 am

I am not a FlexTool expert.
However, there might be a clue in your error message...
Code: Select all
C:/Users/Administrator/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/f3d_flextools.rb:22:in `register_extension'

Is your normal Windows user-name 'Administrator' ?
Usually you'd choose something like 'Wenzhi' ?

Assuming it is your normal Windows user-name...
When you initially installed SketchUp did you do it in the proper way ?

Even if you [as a normal Windows user] have admin-powers you must install complex apps this way...
[Note that if SketchUp is already installed you should close it, then choose the Repair option offered...]
Find the SketchUp installer exe file - probably in your downloads folder ?
Select that exe file's icon.
Right-click > context-menu > "Run as administrator"
When prompted choose "Repair" and agree to all prompts thereafter...
[If it's a fresh install choose "Install" !]

Installing it in any other way - even if you have full admin-powers is not the same thing.
Double-clicking on the exe file's icon might 'Run' it, but NOT as 'the administrator'.

It's not recommended to run SketchUp while logged in as the full 'system-administrator' - but if you have another user-name called [confusingly] 'Administrator', probably with admin-powers that IS OK, BUT you will still need to use "Run as administrator"... as explained...

If you have really messed up permissions on the C:/Users/Administrator/AppData/Roaming/SketchUp path then you might also need to fix then using Right-click > context-menu > Properties > Security > Edit and ensure that every entry has 'Full Control' set and that this permissions trickles down to apply to all subfolders and files in the tree...
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to FlexTools

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: