[Plugin Beta] Animator - v2.7a - 15 Jun 20 (SU2017+)

General discussion about Animator for SketchUp

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby Chelle » Sun Apr 12, 2020 10:28 am

Hi,

Thanks for replying.

I've attached the model as well for you to look at.

Ruby Console was showing the following, however I was having the same issue where it was rendering the first frame on repeat/no movement :

Code: Select all
RENDERING INIT
Status natural = {}
Status thea = :not_supported
Status ambient_occlusion = :not_supported
Status sketchFX = :not_supported
Status twilight = :not_supported

VRAY Init
Status vray = nil
:beg_time => 0
:end_time => 6.0
:frame_rate => 15
:speed_factor => 1.0
:reversed_play => nil
:transparent => false
:dimX => 1440
:dimY => 864
:dim_mode => "r5_3"
:filter => {
}  (:filter)
:root_dir => (Don't want to post this bit publicly)
:movie_dir => "Cedar Garden Room Doors - 12-Apr-2020 10-18-12"
:movie_name => "Door Move"
:date_modified => 1586615101.854707
:movie_formats => {
   :mp4 => true
   :mov => false
}  (:movie_formats)
:rendering_method => :vray
MOVIE PX = 1440 PY = 864 transpa = false

VRAY Movie frame 1 animation time = 0.00s
Path = U1586683108_Image01.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 2.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 4.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 5.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 8.46s
VRAY Status check - status = 4
VRAY Finished after 10.47s

VRAY Movie frame 2 animation time = 0.07s
Path = U1586683108_Image02.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 1.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 3.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 5.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 7.99s
VRAY Status check - status = 4
VRAY Finished after 9.99s

VRAY Movie frame 3 animation time = 0.13s
Path = U1586683108_Image03.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 2.01s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 4.01s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 6.01s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 8.02s
VRAY Status check - status = 4
VRAY Finished after 10.01s

VRAY Movie frame 4 animation time = 0.20s
Path = U1586683108_Image04.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 2.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 4.02s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 6.02s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 8.02s
VRAY Status check - status = 4
VRAY Finished after 10.02s

VRAY Movie frame 5 animation time = 0.27s
Path = U1586683108_Image05.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 1.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 3.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 5.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 7.99s
VRAY Status check - status = 4
VRAY Finished after 9.99s

VRAY Movie frame 6 animation time = 0.33s
Path = U1586683108_Image06.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 2.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 4.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 5.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 8.01s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 10.02s
VRAY Status check - status = 4
VRAY Finished after 12.03s

VRAY Movie frame 7 animation time = 0.40s
Path = U1586683108_Image07.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 1.99s
VRAY Status check - status = 1
VRAY Error or Time out

VRAY Movie frame 8 animation time = 0.47s
Path = U1586683108_Image08.png
AFTER launching Rendering and Timer: status = true
INTERRUPT true
VRAY STOP timer = 31539
VRAY STOP timer =


I stopped the render at this point as this is when there is a gap in the door which is easily visible to see if it is working.

Thanks.
0

Chelle 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby Serge73 » Tue Apr 14, 2020 8:07 pm

fredo6 wrote:Could you post or PM the model.

Also, when you run the video generation, could you leave the Ruby Console open. There are traces showing the processing of frames. And there may be errors as well.

Fredo

The problem appears on any primitive model. For example, rectilinear movement of a cube.

The problem with SketchUP 2020 and V-REY 4.20.01
Render only the first frame. The clip consists of the same frames, the duration is not important.

there is a problem on the forum

Code: Select all
:beg_time => 0
:end_time => 2.0
:frame_rate => 25
:speed_factor => 1.0
:reversed_play => false
:transparent => false
:dimX => 740
:dimY => 416
:dim_mode => "r16_9"
:filter => {
}  (:filter)
:root_dir => "C:/TEMP/Animator Videos"
:movie_dir => "test - 14-Apr-2020 23-57-29"
:movie_name => "Film 1"
:date_modified => 1586890168.103433
:movie_formats => {
   :mp4 => true
   :mov => false
}  (:movie_formats)
:rendering_method => :vray
MOVIE PX = 740 PY = 416 transpa = false

VRAY Movie frame 1 animation time = 0.00s
Path = U1586890672_Image01.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 4
VRAY Finished after 1.99s

VRAY Movie frame 2 animation time = 0.04s
Path = U1586890672_Image02.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 4
VRAY Finished after 1.99s

VRAY Movie frame 3 animation time = 0.08s
Path = U1586890672_Image03.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 4
VRAY Finished after 2.00s


......cut out........


VRAY Movie frame 49 animation time = 1.92s
Path = U1586890672_Image49.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 4
VRAY Finished after 2.00s

VRAY Movie frame 50 animation time = 1.96s
Path = U1586890672_Image50.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 4
VRAY Finished after 1.99s

VRAY Movie frame 51 animation time = 2.00s
Path = U1586890672_Image51.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 4
VRAY Finished after 2.00s
VRAY STOP timer =

Command FFmpeg for mp4 = "C:/Program Files/ffmpeg/bin/ffmpeg.exe" -framerate 25 -i "U1586890672_Image%02d.png" -c:v libx264 -pix_fmt yuv420p -q:v 1  "Film 1.mp4" 2> FFmpeg_log_mp4.txt
===> Status FFmpeg for mp4 = true

Command FFmpeg for mov = "C:/Program Files/ffmpeg/bin/ffmpeg.exe" -i "Film 1.mp4" -acodec copy -vcodec copy -f mov "Film 1.mov" 2> FFmpeg_log_mov.txt
===> Status FFmpeg for mov = true
0

Serge73 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby TonyAU » Sat Apr 25, 2020 5:00 am

Hi,
Before I get into my issue I would like to thank Fredo for the hard work in creating this plug-in, it's awesome!!
Now I just need to check if anyone else is having issues with animating camera views, For some reason in this release the camera's seem to be glitching.. If I save a camera view in the animator, they start in the correct position then jump out to an unexpected view then finish on the correct location.. There's no fluidity to the movement, not sure if it's something I'm doing wrong though.. It definitely could be.. :)

Let me know your thoughts

Cheers..
0

TonyAU 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby fredo6 » Sat Apr 25, 2020 9:02 am

@tonyAU

It would help to have the model.

Do you use only ONE camera or several?
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby TonyAU » Mon Apr 27, 2020 2:40 am

Hi Fredo,
File attached, I think it happens on all my files so don't know if it's my end or yours.. I can live without it, I just thought I would put it out there and give you the heads up.

cheers for all your hard work..
0

TonyAU 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby fredo6 » Mon Apr 27, 2020 10:58 am

@TonyAU,

Thanks for the model.

It helped me to realize that there was a bug in the interpolation of cameras when they are in Parallel projection.

I fixed it and it will go in LibFredo6 v10.1.

Fredo

Film 1.gif
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby TonyAU » Tue Apr 28, 2020 1:57 am

Your a legend..

Thank you Fredo
1

TonyAU 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby serland » Wed Apr 29, 2020 11:47 am

Hi all,

Sorry but the problem persits, with LibFredo 10.1 and lastest Animator ver. when the VRay mode is selected it only renders the first frame in the final video.

I attach the skp file and the video.

Code: Select all
Natural Animation

:beg_time => 0
:end_time => 1.0
:frame_rate => 25
:speed_factor => 1.0
:reversed_play => nil
:transparent => false
:dimX => 1498
:dimY => 856
:dim_mode => "viewport"
:filter => {
}  (:filter)
:root_dir => "C:/Users/serland/Desktop/Animator Videos"
:movie_dir => "Sin título - 29-Apr-2020 12-08-02"
:movie_name => "Film 1"
:date_modified => 1588154844.373782
:movie_formats => {
   :mp4 => true
   :mov => false
}  (:movie_formats)
:rendering_method => :natural
MOVIE PX = 1498 PY = 856 transpa = false

NATURAL image 1 time = 0s Image01.png frame = 1 res = 1498x856

NATURAL image 2 time = 0.04s Image02.png frame = 2 res = 1498x856

NATURAL image 3 time = 0.08s Image03.png frame = 3 res = 1498x856

NATURAL image 4 time = 0.12s Image04.png frame = 4 res = 1498x856

... cut ...

NATURAL image 24 time = 0.9200000000000003s Image24.png frame = 24 res = 1498x856

NATURAL image 25 time = 0.9600000000000003s Image25.png frame = 25 res = 1498x856

NATURAL image 26 time = 1.0s Image26.png frame = 26 res = 1498x856

Command FFmpeg for mp4 = "D:/FFMPEG/bin/ffmpeg.exe" -framerate 25 -i "Image%02d.png" -c:v libx264 -pix_fmt yuv420p -q:v 1  "Film 1.mp4" 2> FFmpeg_log_mp4.txt
===> Status FFmpeg for mp4 = true

Command FFmpeg for mov = "D:/FFMPEG/bin/ffmpeg.exe" -i "Film 1.mp4" -acodec copy -vcodec copy -f mov "Film 1.mov" 2> FFmpeg_log_mov.txt
===> Status FFmpeg for mov = true

VRay Animation
:beg_time => 0
:end_time => 1.0
:frame_rate => 25
:speed_factor => 1.0
:reversed_play => nil
:transparent => false
:dimX => 1498
:dimY => 856
:dim_mode => "viewport"
:filter => {
}  (:filter)
:root_dir => "C:/Users/serland/Desktop/Animator Videos"
:movie_dir => "Sin título - 29-Apr-2020 12-09-18"
:movie_name => "Film 1"
:date_modified => 1588154844.373782
:movie_formats => {
   :mp4 => true
   :mov => false
}  (:movie_formats)
:rendering_method => :vray
MOVIE PX = 1498 PY = 856 transpa = false

VRAY Movie frame 1 animation time = 0.00s
Path = U1588154971_Image01.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 1.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 3.99s
VRAY Status check - status = 4
VRAY Finished after 6.00s

VRAY Movie frame 2 animation time = 0.04s
Path = U1588154971_Image02.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 1.99s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 3.99s
VRAY Status check - status = 4
VRAY Finished after 5.99s

... cut...

VRAY Movie frame 26 animation time = 1.00s
Path = U1588154971_Image26.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 2.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 4.00s
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 6.00s
VRAY Status check - status = 4
VRAY Finished after 8.00s
VRAY STOP timer =

Command FFmpeg for mp4 = "D:/FFMPEG/bin/ffmpeg.exe" -framerate 25 -i "U1588154971_Image%02d.png" -c:v libx264 -pix_fmt yuv420p -q:v 1  "Film 1.mp4" 2> FFmpeg_log_mp4.txt
===> Status FFmpeg for mp4 = true

Command FFmpeg for mov = "D:/FFMPEG/bin/ffmpeg.exe" -i "Film 1.mp4" -acodec copy -vcodec copy -f mov "Film 1.mov" 2> FFmpeg_log_mov.txt
===> Status FFmpeg for mov = true


Thanks for your job
0

serland 
Premium Member
Premium Member
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby Atilla_Ahmediye » Sun May 03, 2020 11:27 am

Hello Thank your for this amazing plug-in...it is really cool :thumb:

I guess it is needs to be patch to work with Vray Next (4.20.02).
0

Atilla_Ahmediye 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby TDahl » Mon May 04, 2020 2:16 pm

Is there a way to control the thickness or weight of edges (lines) as they appear in the exported movie frames (MP4, etc.)? I am using SketchUp Pro 2018 with Animator v2.6c. I noticed that edges are rendered with thicker lines in Animator's frames than they are when I use SketchUp Pro 2018's native Export > Animation function.

In a video editor, I would like to seamlessly transition from a native animation exported clip to an Animator-exported clip, but there is a clear visual discontinuity between the line thicknesses of the two clips at the transition point. Attached is a still picture with a native animation-export on the left and an Animator-export on the right. The boundary is a bit subtle side-by-side, but it is a quite evident "pop" when viewing a video that abruptly jumps from the thinner to the thicker line weight.
LineComparison.jpg
0

TDahl 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby fredo6 » Mon May 04, 2020 2:45 pm

TDahl wrote:Is there a way to control the thickness or weight of edges (lines) as they appear in the exported movie frames (MP4, etc.)?

Yes. I need to update Animator for that, because there is now an option about the line thickness.
That would be an extra parameter in the generation dialog.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby Mill29 » Thu Jun 04, 2020 10:37 am

Hi,
Thanks a lot Fredo for this wonderfull tool!
Just for information, it works well with Thea render V2
0

Mill29 
Premium Member
Premium Member
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby lazara » Fri Jun 05, 2020 12:22 am

Fredo my sincere congratulations on your wonderful animation tool for Sketchup. It is very useful to me in the reconstruction of 3D traffic accidents. Thank you very much for your development and constant updating. :thumb:
1

lazara 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby TDahl » Mon Jun 15, 2020 2:33 am

Animator v2.6c is telling me that it has expired, but there does not seem to be a newer version available yet. Any estimate on when a new version (or a re-release of v2.6c with an extended expiration date) might be available?
0

TDahl 
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby TimHforProMinent » Mon Jun 15, 2020 2:47 am

Hi,

I am having trouble with Animator V2.6c. I get the below message,
I run 2020 on a Windows Machine.

This version of Animator has expired
Please upgrade to the latest version

and I have the latest version.

Thanks, Tim
0

TimHforProMinent 
 

Re: [Plugin Beta] Animator - v2.7a - 15 Jun 20 (SU2017+)

Postby fredo6 » Mon Jun 15, 2020 2:51 pm

New Release: Animator - v2.7a - 15 Jun 20

Requirement: LibFredo6 v9.5k

Minor release

  • Extension of validity

_______________________________________________________________________________________

See plugin home page of Animator for Download of RBZ from the PluginStore.

See Main Post of the Animator thread for more information.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Beta] Animator - v2.6c - 19 Mar 20 (SU2017+)

Postby fredo6 » Mon Jun 15, 2020 2:54 pm

TimHforProMinent wrote:Hi,

I am having trouble with Animator V2.6c. I get the below message,
I run 2020 on a Windows Machine.

This version of Animator has expired
Please upgrade to the latest version

and I have the latest version.

Ooops! My fault. Forgot to update it in due time. Thanks for signaling.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Beta] Animator - v2.7a - 15 Jun 20 (SU2017+)

Postby TDahl » Mon Jun 15, 2020 10:41 pm

Animator v2.7a downloaded, installed, and started up fine - thank you for the quick turn-around!
0

TDahl 
 

Re: [Plugin Beta] Animator - v2.7a - 15 Jun 20 (SU2017+)

Postby TimHforProMinent » Tue Jun 16, 2020 1:20 am

Fredo,
Thank you very much, downloaded and installed without problems.
Thanks for such a great Plugin.
I am still learning all the functions.
Tim
0

TimHforProMinent 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

Previous


 

Return to Animator Beta

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: