Play Button not Working

General discussion about Animator for SketchUp

Play Button not Working

Postby Keniff » Tue Jan 11, 2022 3:39 pm

Hi All
I’ve just recently installed Fredo Animator and been watching all the tuts etc but I cannot get the “Play” button to work. I have tried everything. I am new to this extension so am keeping it really simple, just a box along a path. I add the transition and it will play if I “scrub” the timeline but pressing the play button does nothing. I have followed all the tutorials I can find but I’ve no clue why it’s not working. Probably something obvious but I can’t figure it out. As ever, any help gratefully appreciated.
I’m using Pro 2018 on Mac, in case that’s relevant. Cheers
0

Keniff 
 

Re: Play Button not Working

Postby fredo6 » Tue Jan 11, 2022 5:52 pm

Could you leave the Ruby Console opened when in Animator. This may show if there are script errors.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Play Button not Working

Postby Keniff » Wed Jan 12, 2022 3:13 pm

fredo6 wrote:Could you leave the Ruby Console opened when in Animator. This may show if there are script errors.


Hi Fredo, thanks for the response. I can see this error in Ruby Console

Error: #<NameError: uninitialized constant G6::G6B>
0

Keniff 
 

Re: Play Button not Working

Postby fredo6 » Wed Jan 12, 2022 7:44 pm

Could you tell me which systems your run and which version of Sketchup.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Play Button not Working

Postby Keniff » Thu Jan 13, 2022 11:28 am

fredo6 wrote:Could you tell me which systems your run and which version of Sketchup.


I'm using an iMac running Monterey, 3.1GHz Intel i5 Processor and using Pro 2018
0

Keniff 
 

Re: Play Button not Working

Postby fredo6 » Thu Jan 13, 2022 12:38 pm

Very strange. Although Monterey is not officially supported for SU2018, it seems to work on my Mac.

There is a problem with the installation and runtime of LibFredo6 (hence the error).

Could you upgrade to the latest version and reinstall.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Play Button not Working

Postby Keniff » Thu Jan 13, 2022 12:50 pm

fredo6 wrote:Very strange. Although Monterey is not officially supported for SU2018, it seems to work on my Mac.

There is a problem with the installation and runtime of LibFredo6 (hence the error).

Could you upgrade to the latest version and reinstall.

Fredo


SU itself has been working just fine. I upgraded my libfredo6 before installing Animator but I'll reinstall and see if there's any difference. Thanks for your help
0

Keniff 
 

Re: Play Button not Working

Postby Keniff » Thu Jan 13, 2022 1:00 pm

Hi Fredo,

I reinstalled Libfredo and Animator and it seems to be working fine now.

Thanks for your help and thanks SO much for all the great extensions you produce for SU. Wouldn't be the same without you !!!!! Cheers
0

Keniff 
 

Re: Play Button not Working

Postby samodelkin_77 » Fri Jan 14, 2022 8:04 am

I will ask a question about the animator here.
I decided to try to work with him, but I don't see him in the sketchup. Everything is installed correctly (I use a large set of plugins, maybe some of the plugins get in the way?)
LibFredo6 has been updated by your link. Maybe the problem lies in this message (it constantly pops up at startup, but does not interfere with the sketchup):
sorry for big text:
"Ошибка при загрузке файла «Fredo6_!LibFredo6.rb»
Code: Select all
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:820:in `match'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:820:in `block (2 levels) in load_from_config'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:819:in `each'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:819:in `block in load_from_config'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:817:in `foreach'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:817:in `load_from_config'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:1232:in `block in load_all_plugins'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:1232:in `each'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:1232:in `load_all_plugins'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:310:in `startup'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:68:in `process'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:76:in `<module:LibFredo6_Loader>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'
Ошибка при загрузке файла «Fredo6_Animator.rb»
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `-'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `<top (required)>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_Animator.rb:52:in `<module:Fredo6>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_Animator.rb:28:in `<top (required)>'
Ошибка при загрузке файла «Fredo6_FredoGhost.rb»
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `-'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `<top (required)>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_FredoGhost.rb:47:in `<module:Fredo6>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_FredoGhost.rb:26:in `<top (required)>'
Ошибка при загрузке файла «Fredo6_FredoGuides.rb»
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `-'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `<top (required)>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_FredoGuides.rb:47:in `<module:Fredo6>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_FredoGuides.rb:26:in `<top (required)>'
Ошибка при загрузке файла «Fredo6_FredoTools.rb»
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `-'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_!LibFredo6.rb:86:in `<top (required)>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Fredo6_FredoTools.rb:25:in `<top (required)>'
Error: C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/part.rbe:6:in `<module:QCutList>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/part.rbe:4:in `<module:Labyrinth>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/part.rbe:3:in `<main>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:14:in `eval'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:14:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:14:in `<main>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `eval'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `<main>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `eval'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `load'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `register_extension'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `<module:QCutList>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:11:in `<module:Labyrinth>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:10:in `<top (required)>'
Error: #<NameError: uninitialized constant Labyrinth::QCutList::Part>
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/board.rbe:6:in `<module:QCutList>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/board.rbe:5:in `<module:Labyrinth>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/board.rbe:4:in `<main>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:15:in `eval'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:15:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:15:in `<main>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `eval'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `<main>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `eval'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `load'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `register_extension'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `<module:QCutList>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:11:in `<module:Labyrinth>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:10:in `<top (required)>'
Error: #<NameError: uninitialized constant Labyrinth::QCutList::Part>
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/sheet.rbe:7:in `<module:QCutList>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/sheet.rbe:6:in `<module:Labyrinth>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/sheet.rbe:5:in `<main>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:16:in `eval'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:16:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/qcutlist.rbe:16:in `<main>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `eval'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:2:in `<main>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `eval'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `load'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `register_extension'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `<module:QCutList>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:11:in `<module:Labyrinth>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:10:in `<top (required)>'
Error: C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:6:in `<module:QCutList>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:4:in `<module:Labyrinth>'
c:/users/dell/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/la_cutmap/loader.rbe:3:in `<main>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `eval'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `load'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `register_extension'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:21:in `<module:QCutList>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:11:in `<module:Labyrinth>'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/la_cutmap.rb:10:in `<top (required)>'
Error: C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/PowerBar_Load.rb:1:in `eval'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/PowerBar_Load.rb:1:in `require'
C:/Users/Dell/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/PowerBar_Load.rb:1:in `<top (required)>'"
0

samodelkin_77 
 

Re: Play Button not Working

Postby samodelkin_77 » Wed Jan 19, 2022 10:12 am

sombody? please help for that (many letters upper)
0

samodelkin_77 
 

Re: Play Button not Working

Postby Rich O Brien » Wed Jan 19, 2022 11:25 am

A quick way to establish if Animator is causing issues would be to rename your plugins folder to #plugins. This would basically disable all plugins.

Start SketchUp and it will remake the folder plugins and now you can install Animator on it's own with LibFredo.

If that works then it the not so quick way to slowly add back plugins from the #plugins folder to the plugins folder and see which one cause the issue.

Also posting more system info and SU version would also help. That ruby console error message mentions more than just Animator and LibFredo. There's also PowerBar and CutMap spitting out their dummies.
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: Play Button not Working

Postby samodelkin_77 » Wed Jan 19, 2022 12:14 pm

No, no, the Animator does not cause problems, I stupidly do not see him in the Fredo collection. The sketch itself works without problems (just press ESC) And all plugins work (even those listed in this list). I just don't understand why the Animator doesn't appear at all...
and hoped that the problem could be seen in this long list... There is a suspicion that this is due to UTF encoding, because I have a verified version of the sketch 2018
0

samodelkin_77 
 

Re: Play Button not Working

Postby samodelkin_77 » Wed Jan 19, 2022 12:17 pm

Perhaps somehow I will decide to gradually remove plugins to see if any of them is interfering with the Animator... But suddenly I will find answers to the problem here?))
0

samodelkin_77 
 

Re: Play Button not Working

Postby Rich O Brien » Wed Jan 19, 2022 12:53 pm

I think you would benefit from isolating the issue on your end first. It would help you get better advice here.
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: Play Button not Working

Postby samodelkin_77 » Wed Jan 19, 2022 1:48 pm

Oh, if I could figure out from this long list what the problem is.... but I'm not good at Ruby, I started learning it a little bit, but it's not that simple))
0

samodelkin_77 
 

Re: Play Button not Working

Postby Rich O Brien » Wed Jan 19, 2022 2:47 pm

You don't need to know Ruby to find out if Animator/LibFredo is the issue.

It's eliminating other tools first to identify if there is a conflict. That is why I suggested renaming your plugins folder so you have a clean slate.

Then slowly add plugins back and source which ones are causing issues.
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: Play Button not Working

Postby samodelkin_77 » Tue Jan 25, 2022 9:58 am

Thanks for the idea, everything worked!
0

samodelkin_77 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Animator Beta

Who is online

Users browsing this forum: No registered users and 5 guests