Pointing at sequence hides Animator tools; bug?

General discussion about Animator for SketchUp

Pointing at sequence hides Animator tools; bug?

Postby DaBouncer » Tue Dec 04, 2018 12:15 pm

Hi,

I'm experiencing a strange behavior in Animator 2.3c.

When I point at sequence some of the tools are hidden and sometimes all of them disappears completely; then if I try to "restart" Animator by clicking any of the icons in the toolbar, Windows throws a warning sound; I have to quit Sketchup and once closed the "Exit temporary to Sketchup" windows appears...

Rgds,

Petter

0

DaBouncer 
 

Re: Pointing at sequence hides Animator tools; bug?

Postby fredo6 » Wed Dec 05, 2018 4:00 am

DaBouncer wrote:I'm experiencing a strange behavior in Animator 2.3c.

When I point at sequence some of the tools are hidden and sometimes all of them disappears completely; then if I try to "restart" Animator by clicking any of the icons in the toolbar, Windows throws a warning sound; I have to quit Sketchup and once closed the "Exit temporary to Sketchup" windows appears...

I think there is an error.

Would you mind opening the Ruby Console before you click on the icons and report what you see there (just copy the text and paste it in your post).

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Pointing at sequence hides Animator tools; bug?

Postby DaBouncer » Wed Dec 05, 2018 8:57 am

Thanks Fredo, I get this:

Error: #<NoMethodError: undefined method `x' for nil:NilClass>
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/body_lib6pathmanager.rbe:605:in `draw_trace_effective_curve'
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/body_lib6compmanager.rbe:1844:in `movement_trace_draw'
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_animator/animatorclipmanager.rbe:3909:in `sequence_movement_draw_trace'
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_animator/animatorclipmanager.rbe:3890:in `sequence_draw_trace'
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_animator/animatorclipsequencer.rbe:4721:in `drawing_trace_element'
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_animator/animatorclipsequencer.rbe:4687:in `draw'
c:/users/****/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_animator/animatortool.rbe:1523:in `draw'
0

DaBouncer 
 

Re: Pointing at sequence hides Animator tools; bug?

Postby fredo6 » Wed Dec 05, 2018 5:32 pm

This is fixed normally with LibFredo6 8.6p.

Thanks to advise

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Pointing at sequence hides Animator tools; bug?

Postby DaBouncer » Thu Dec 06, 2018 8:49 am

That sorted it, thanx!

Superb extension for Sketchup, keep up the good work ('',)
0

DaBouncer 
 

Re: Pointing at sequence hides Animator tools; bug?

Postby DaBouncer » Fri Dec 07, 2018 2:26 pm

Seems I pulled the trigger a bit to fast on this one; the issue remains with LibFredo6 8.6p

Note the status in the bottom left of this image; could that be relevant here?

0

DaBouncer 
 

Re: Pointing at sequence hides Animator tools; bug?

Postby fredo6 » Sat Dec 08, 2018 1:29 pm

DaBouncer wrote:Seems I pulled the trigger a bit to fast on this one; the issue remains with LibFredo6 8.6p

Same thing. Could you open the Ruby Console.

Would be helpful that I get your model too.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Pointing at sequence hides Animator tools; bug?

Postby DaBouncer » Mon Dec 10, 2018 9:33 am

The issue does not happen all the time so I have not been able to capture anything in Ruby Console yet. I've sendt the two files I'm currently working on in a PM.
0

DaBouncer 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Animator Beta

Who is online

Users browsing this forum: No registered users and 2 guests

Visit our sponsors: