Thea Render and Skatter not using all devices?

General discussion on Thea Render for SketchUp

Moderator: Frederik

Thea Render and Skatter not using all devices?

Postby ark » Mon Jan 15, 2018 11:18 am

I'm testing Thea with Skatter and have made a quite simple scene with grass, trees and bushes from Skatter library.

The attached image
Thea Render window.png
shows the Thea Render window when IR-Presto with interactive render is running... only problem is the image never gets better then this very grainy quality - quite difficult to use for setup!
I notice only the CPU is active :shock: ...but both graphic cards is activated?!
Is this because of Skatter?

When rendering with same settings but without interactive render the image is rendered... but still only one device is active?!

Any ideas what's wrong? :ugeek:
0

ark 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby JQL » Mon Jan 15, 2018 11:59 am

Your interactive resolution seems it might be too low and your sample limit is at 512px. When defining what is the interactive rendering resolution reduction there is also a "more responsive" tickbox that makes pixels square and bigger like that. You can try unticking it.

I have interactively rendered images like this at 3840x2160.
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby samnorth » Mon Jan 15, 2018 12:11 pm

Try setting that GPU to 'Low' or 'Lowest' priority and re-boot.

You may have had a watchdog error.
0

samnorth 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby ark » Mon Jan 15, 2018 1:59 pm

samnorth wrote:Try setting that GPU to 'Low' or 'Lowest' priority and re-boot.

You may have had a watchdog error.


Watchdog!?! :o What is that? But it helped rebooting, now all devices is running :D

JQL wrote:Your interactive resolution seems it might be too low and your sample limit is at 512px. When defining what is the interactive rendering resolution reduction there is also a "more responsive" tickbox that makes pixels square and bigger like that. You can try unticking it.

I have interactively rendered images like this at 3840x2160.


What is the connection between render image size and sample limit?! :ugeek:
0

ark 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby samnorth » Mon Jan 15, 2018 2:11 pm

Great. Some info on the issue here -

http://kb.thearender.com/tech-tips/kern ... -priority/

In simple terms when the priority is too high windows reports an error as it thinks the system has stopped responding.

There's a way around it if you go with Thea [noted in the link].

May be then you can benchmark your system and add an 8700K to the list :-P :ugeek:

https://www.thearender.com/benchmark/results3.php
1

samnorth 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby Charlie__V » Mon Jan 15, 2018 11:09 pm

samnorth wrote:Great. Some info on the issue here -

http://kb.thearender.com/tech-tips/kern ... -priority/

In simple terms when the priority is too high windows reports an error as it thinks the system has stopped responding.

There's a way around it if you go with Thea [noted in the link].

May be then you can benchmark your system and add an 8700K to the list :-P :ugeek:

https://www.thearender.com/benchmark/results3.php


Samnorth
Very interesting and timely at that.......was just experiencing this very thing the last week or so and figured it was GPU driver related or Thea version related
Updated driver and Thea just this morning, and no dice.

I am now going to try lowering priority to normal, and if I get some nerve I may try “the way around it” provided in your link .

Thanks for the info,Charlie
0
Precision M1710/Win 7 Pro 64 bit/i-7 6920 Quad core 2.9 Ghz -3.8/16Gb ram/NVIDIA M5000M 8Gb

Charlie__V 
 

Re: Thea Render and Skatter not using all devices?

Postby JQL » Tue Jan 16, 2018 12:26 am

Don't lower to normal, use low or lowest instead.
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby ark » Tue Jan 16, 2018 8:28 am

samnorth wrote:Great. Some info on the issue here -

http://kb.thearender.com/tech-tips/kern ... -priority/

In simple terms when the priority is too high windows reports an error as it thinks the system has stopped responding.

There's a way around it if you go with Thea [noted in the link].

May be then you can benchmark your system and add an 8700K to the list :-P :ugeek:

https://www.thearender.com/benchmark/results3.php


Thanks samnorth for your explanation :thumb: I'll try to benchmark my system :ugeek:
0

ark 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby Charlie__V » Tue Jan 16, 2018 7:48 pm

JQL wrote:Don't lower to normal, use low or lowest instead.


JQL
I lowered from High on both GPU and CPU to Normal and so far problem is resolved.

Curious why low or lowest would be better selection?

Thanks,
Charlie
0
Precision M1710/Win 7 Pro 64 bit/i-7 6920 Quad core 2.9 Ghz -3.8/16Gb ram/NVIDIA M5000M 8Gb

Charlie__V 
 

Re: Thea Render and Skatter not using all devices?

Postby juju » Tue Jan 16, 2018 8:57 pm

Charlie__V wrote:Curious why low or lowest would be better selection?

The way I understand it is that the program is more easily interrupted, or the use of the resource is more easily interrupted. This causes better response to calls from the OS (amongst others), which then doesn't trigger the gatekeeper.

But then, I may have completely misunderstood the whole thing...
2
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby JQL » Wed Jan 17, 2018 12:10 am

Apart from what Juju says, setting thea's priority to lowest will overall make your system more responsive which, in turn, will make your handling of Thea faster. You can cancel or pause faster, move your mouse faster, orbit in IR faster and can eventually surf the web while rendering too. There's also a flickering issue when turning on your monitor while a render is in progress for a long time that seems to be less evident when lowest is in place.

Either way, when you are doing nothing else, Thea will use every resource available so there will be no considerable loss in Low or Lowest, hence it's the recommended setting.
1
User avatar
JQL 
Premium Member
Premium Member
 

Re: Thea Render and Skatter not using all devices?

Postby Charlie__V » Wed Jan 17, 2018 3:45 pm

JQL wrote:Either way, when you are doing nothing else, Thea will use every resource available so there will be no considerable loss in Low or Lowest, hence it's the recommended setting.


Thank you both (JuJu & JQL) :thumb:
This makes perfect sense to me now, since I did not know that Thea would take advantage of idle resources.

Best regards,
Charlie
0
Precision M1710/Win 7 Pro 64 bit/i-7 6920 Quad core 2.9 Ghz -3.8/16Gb ram/NVIDIA M5000M 8Gb

Charlie__V 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Thea

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: