Do not see GPU in Rendering Window

General discussion on Thea Render for SketchUp

Moderator: Frederik

Do not see GPU in Rendering Window

Postby valerostudio » Tue May 12, 2015 8:45 pm

I have an Nvidia GeForce GTX 580, I am playing with the latest demo of Thea for SketchUp, when I open the Rendering tab I only see a checkbox for CPU, no GPU box. Is this a demo limit or is it my card?
0

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby Rich O Brien » Tue May 12, 2015 9:04 pm



Pick IR-Presto as the mode and the UI will then list the GPU options
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: Do not see GPU in Rendering Window

Postby valerostudio » Wed May 13, 2015 8:46 am

Nope. Doesnt seem to appear for me.
Presto ScreenShot.JPG
0

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby Pixero » Wed May 13, 2015 10:44 am

It might be the graphics drivers that need updating.

See this post at the Thea forum:
http://www.thearender.com/forum/viewtop ... rs#p122326
0
User avatar
Pixero 
 

Re: Do not see GPU in Rendering Window

Postby JQL » Wed May 13, 2015 10:46 am

valerostudio wrote:I have an Nvidia GeForce GTX 580, I am playing with the latest demo of Thea for SketchUp, when I open the Rendering tab I only see a checkbox for CPU, no GPU box. Is this a demo limit or is it my card?


Welcome to Thea!
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: Do not see GPU in Rendering Window

Postby andybot » Wed May 13, 2015 1:01 pm

JQL wrote:
Welcome to Thea!


Yes, tell me how it goes :D
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Do not see GPU in Rendering Window

Postby valerostudio » Wed May 13, 2015 1:39 pm

To be very honest I am a hardcore V-Ray user that has been a little bummed lately that it hasn't developed more and consistently like Thea and other rendering plugins. The UI, parsing speed, and quickness of Presto are all things that are really starting to convert me just playing with it for 30 minutes yesterday. I will report back and let everyone know what I think.

The one thing I would like to see if there is a 15 day full version or something I can use because the only real way to get a good sense of render times is to crank out a resolution I would normally produce for production stuff. 800 pixels is great for a open demo to the public but to really sell me I need to see how it does on a 5K wide image.
0

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby valerostudio » Wed May 13, 2015 1:40 pm

Pixero wrote:It might be the graphics drivers that need updating.

See this post at the Thea forum:
http://www.thearender.com/forum/viewtop ... rs#p122326



It says I need to be a licensed user to view this. Currently I am only in demo.
0

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby JQL » Wed May 13, 2015 2:02 pm

valerostudio wrote:To be very honest I am a hardcore V-Ray user that has been a little bummed lately that it hasn't developed more and consistently like Thea and other rendering plugins. The UI, parsing speed, and quickness of Presto are all things that are really starting to convert me just playing with it for 30 minutes yesterday. I will report back and let everyone know what I think.

The one thing I would like to see if there is a 15 day full version or something I can use because the only real way to get a good sense of render times is to crank out a resolution I would normally produce for production stuff. 800 pixels is great for a open demo to the public but to really sell me I need to see how it does on a 5K wide image.


Why don't you ask for that on thea's forums, I'm sure they will, at least consider it.

If you'd want I'd fire a render up for you in my system, if you wouldn't mind sharing it.

i7 5820K
Titan X
32 Gb ram
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: Do not see GPU in Rendering Window

Postby Pixero » Wed May 13, 2015 2:04 pm

In short it says what I said.
That you must update your Nvidia drivers:
http://www.nvidia.co.uk/download/driver ... 1941/en-uk
0
User avatar
Pixero 
 

Re: Do not see GPU in Rendering Window

Postby JQL » Wed May 13, 2015 2:08 pm

There's also something else you might read for optimizing Presto:

Thea Presto Optimization Tips (version 1.4)
•Device not recognized

Presto GPU is currently based on Nvidia CUDA, which means that a compatible graphic card is needed to run it. In case an Nvidia card is available it should be listed to the Select Devices window.
In case you are not able to see your card listed there please check the following:

- Make sure your Card is CUDA-Enabled. A list with all CUDA-Enabled cards can be found here.
Note that NVidia Graphic cards of compute capability 1.x are not supported anymore due to shifting to CUDA 6.5, so you will need a card of compute capability 2.x, 3.x or 5.x.
- Check out to see if your NVidia graphics adapter has the latest reference drivers installed.
If not please make the needed driver update.
(Presto GPU will need CUDA 6.5 compatible driver.)
•Performance Issues - Run Presto at max effectiveness

In case Presto is not able to render a scene (black scene appears) or when an error appears, some devices customizations may be needed (these have not to do with the engine overall stability).
Two factors that may need tweaking to optimize the Presto engine performance are the following:

- Altering the priority of your devices. In cases of heavy rendering jobs, lowering your devices priority is a workaround for making the device respond faster.

- Performance Improvement: Presto CPU should not be configured with Normal or High priority when Presto GPU is also enabled it order to achieve better synchronization and overall results.

- Configure Windows Watchdog (Windows only). Windows runs a service, called "watchdog" that monitors the graphic driver. If the driver does not respond within 2 seconds, it decides that there is a kind of instability so it terminates and restarts the driver process. The driver is the process responsible for handling all Presto commands to the GPU and - unfortunately - Presto is responsible for keeping the driver super-busy when there is a heavy rendering job.
You can actually configure watchdog service. And this is the recommendation to stay in the safe side, in all cases. In that situation, you can even set your device priorities to Highest (which means fastest Presto - at the expense of a less responsive graphic system).
Read here about watchdog service.

Recommendation: Do not disable watchdog driver completely, but set timeout between 30s and 1m.
Note: Disabling/Altering watchdog service is needed even for a graphic card that is not used for display.

- Power Supply and Ventilation. Presto should be used with proper hardware, this means proper PSU (Power Supply), cooling and ventilation. Please make sure that there is enough power supply for your card (you can see the hardware specifications for each card at Nvidia site) and that your machine has been configured appropriately. Adequate ventilation of the devices and chipset plays also a significant role, especially when both CPU and GPU are used for rendering.

- GUI Responsiveness. In case your machine is built with more than one graphic card it is recommended to use one of them (any card) for display and use the other (an Nvidia CUDA-Enabled card) for rendering. In this way the whole User Interface responsiveness will be better. In case a sole card exists, you can decrease the card priority at Thea Render Devices Selection window to achieve a more responsive graphic system.
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: Do not see GPU in Rendering Window

Postby valerostudio » Wed May 13, 2015 2:09 pm

Simple little things like the details put into rendered thumbs in the SKM files for the Thea materials are all things that SHOULD be available to V-Ray users but is not.
Materials.JPG
0

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby valerostudio » Wed May 13, 2015 2:42 pm

Updating my drivers fixed the issue. WOW! Even faster Presto rendering! I've gotta say, so far very impressed!
1

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby Pixero » Wed May 13, 2015 3:18 pm

valerostudio wrote:Updating my drivers fixed the issue. WOW! Even faster Presto rendering! I've gotta say, so far very impressed!


Welcome to Thea! :D
0
User avatar
Pixero 
 

Re: Do not see GPU in Rendering Window

Postby valerostudio » Wed May 13, 2015 3:28 pm

Ok, so how I do export a proxy from Thea Studio? I imported a hi poly OBJ but cannot for the life me figure out how to export the .mod.thea file???
0

valerostudio 
 

Re: Do not see GPU in Rendering Window

Postby JQL » Wed May 13, 2015 3:39 pm

1 - Go to the model's tab next to tree view on the left
2 - Your model should be there.
3 - If it's not grouped you have to group it on the tree list. (select all parts and righclick on the list and there's a group option there)

4 - EDIT
Pixero wrote:You have to move the groups pivot also. Press p for pivot and move to origin and then press p again to exit pivot mode.


5 - back to the model's list rightclick the model wich is now grouped and build preview
6 - now drag the model's icon preview to any of the browser's libraries in the bottom. you shouldn't use material's folders for models... so open up the model's tab in the top of the browser...

That's it.

Be careful not to move the original textures bitmaps around on your pc, or your models will render black...
0
Last edited by JQL on Wed May 13, 2015 4:28 pm, edited 1 time in total.
User avatar
JQL 
Premium Member
Premium Member
 

Re: Do not see GPU in Rendering Window

Postby Pixero » Wed May 13, 2015 3:59 pm

You have to move the groups pivot also. Press p for pivot and move to origin and then press p again to exit pivot mode.
1
User avatar
Pixero 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Thea

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: