[Plugin] LordOfTheToolbars - v2.2a - 28 Jun 22

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby AISmebel » Mon Jan 31, 2022 3:36 pm

fredo6 wrote:If you do not see the Vignette Stripe at start up, it maybe be stuck off-screen (I guess you have multiple monitors).

Could you go to the menu Tools > Fredo6 Collection > LordOfTheToolbars > Reset the Vignette Stripe position.


I made a screen recording with another program.
https://youtu.be/e6jSXIc9Dvo

Reset the Vignette Stripe position did not help me :(
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby fredo6 » Mon Jan 31, 2022 4:04 pm

Could you display the Vignette Stripe? (go to menu Tools > Fredo6 Collection > LordOfTheToolbars > Toggle Visibility of the Vignette Stripe)
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby AISmebel » Tue Feb 01, 2022 8:23 am

fredo6 wrote:Could you display the Vignette Stripe? (go to menu Tools > Fredo6 Collection > LordOfTheToolbars > Toggle Visibility of the Vignette Stripe)


https://youtu.be/BJ-jEZQvnrA

Hello. The plugin itself works correctly. It just doesn't load icons.
Yesterday I installed SketchUp 2022. I installed fresh LordOfTheToolbars for it. Problem still exists. So it's not in the plugin itself and not in SU. Maybe the problem is on my PC. Could this happen?
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby fredo6 » Tue Feb 01, 2022 8:36 am

You seem to have 2 problems
  1. The Vignette Stripe does not display
  2. The custom toolbars are not showing at startup, but later on

I don't have an explanation for that. I will probably need to send you a special version with traces to find out what is the problem.

In the meantime, could you
  • Open the Ruby console
  • Close Sketchup with the Ruby console opened
  • restart Sketchup
  • Check if some errors appear in the Ruby console
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby AISmebel » Tue Feb 01, 2022 8:57 am

fredo6 wrote:You seem to have 2 problems
  1. The Vignette Stripe does not display
  2. The custom toolbars are not showing at startup, but later on

I don't have an explanation for that. I will probably need to send you a special version with traces to find out what is the problem.

In the meantime, could you
  • Open the Ruby console
  • Close Sketchup with the Ruby console opened
  • restart Sketchup
  • Check if some errors appear in the Ruby console


"Add help menu!"
"create new"
"created"
#<Sketchup::Menu:0x0000023c232015f0>

This inscription appeared a minute after the launch of SU. And after I opened the console on my own.
Ruby console didn't open automatically!
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby fredo6 » Tue Feb 01, 2022 9:48 am

Is this something happening only in SU2022.?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby AISmebel » Tue Feb 01, 2022 11:19 am

fredo6 wrote:Is this something happening only in SU2022.?

The problem first appeared on SU 2020. A week later I installed SU 2022. And migrated all the plugins to SU 2022, uninstalled LordOfTheToolbars and reinstalled it with the latest version of the plugin. SU 2022 and SU 2020 have the same problem.
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby fredo6 » Tue Feb 01, 2022 12:06 pm

@AISmebel

I sent you a modified version of LOTT by Private message. This version includes traces at startup, so that I can find out what is going on.
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby rv1974 » Tue Feb 01, 2022 1:16 pm

Somehow I completely missed :) the the feature of custom toolbars (I thought the palettes were the only option for icons).. Anyway I built a custom toolbar of 50 icons and experienced very long loading times (approx 1+ sec for icon) - so it took 1 minute to load this toolbar.
Palettes loading times are much better.
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby AISmebel » Tue Feb 01, 2022 3:15 pm

rv1974 wrote:Somehow I completely missed :) the the feature of custom toolbars (I thought the palettes were the only option for icons).. Anyway I built a custom toolbar of 50 icons and experienced very long loading times (approx 1+ sec for icon) - so it took 1 minute to load this toolbar.
Palettes loading times are much better.

You're right. Long loading panels are a little annoying)))
But this version of the panels suits me better.
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8a - 31 Jan 22

Postby fredo6 » Tue Feb 01, 2022 3:27 pm

rv1974 wrote:Somehow I completely missed :) the the feature of custom toolbars (I thought the palettes were the only option for icons).. Anyway I built a custom toolbar of 50 icons and experienced very long loading times (approx 1+ sec for icon) - so it took 1 minute to load this toolbar.
Palettes loading times are much better.

This is a known problem in Sketchup, which has already been logged to Trimble. Displaying a custom toolbar outside of the startup sequence takes long on Windows. I have the same issue on my laptop. There is no workaround currently.
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Wed Feb 02, 2022 9:32 pm

NEW RELEASE: LordOfTheToolbars v1.8d - 02 Feb 22

Requirements
  • LibFredo6: v12.4a or above
  • Sketchup version: SU2017 and above

LordOfTheToolbars 1.8d includes
  • Bug fixing for palette and personal commands shortcuts (which could make palette popup when typing in tray dialogs)

-----------------------------------------

Home Page of LordOfTheToolbars for information and Download.

Main post of this LordOfTheToolbars thread.
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby AISmebel » Fri Feb 04, 2022 8:00 am

Hello. Forgive me for torturing you, but in addition to the old error, I found another new error. I can't press the "menu" button. Can't create new icons and can't edit old ones((

Error: #<RangeError: invalid codepoint 0xD83D in UTF-8>
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5383:in `all_menus'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5383:in `menu_mapping'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5459:in `menu_structured_list'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarspersodialog.rbe:1056:in `menu_compute_list'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarspersodialog.rbe:480:in `dialog_format_menu_list'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarspersodialog.rbe:411:in `dialog_format_properties'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarspersodialog.rbe:329:in `dialog_prepare_html'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarspersodialog.rbe:263:in `dialog_load_html'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarspersodialog.rbe:181:in `dialog_invoke'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsmanager.rbe:4959:in `perso_dialog_invoke'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsmasterdialog.rbe:4453:in `perso_new_command'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsmasterdialog.rbe:2465:in `dialog_callback_exec'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsmasterdialog.rbe:2322:in `dialog_callback'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2385:in `call'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2385:in `master_callback'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2173:in `j_action'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2132:in `j_callback'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2118:in `block in j_dispatch'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2110:in `each'
c:/programdata/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2110:in `j_dispatch'

0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Fri Feb 04, 2022 9:21 am

This UTF8 error is puzzling.

I don't know if it is related to your Cyrillic environment.

Also, which version of Windows do you run?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby AISmebel » Fri Feb 04, 2022 10:19 am

fredo6 wrote:This UTF8 error is puzzling.

I don't know if it is related to your Cyrillic environment.

After all, there were no problems before (((

Also, which version of Windows do you run?

Windows 10 Pro v.20H2
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Fri Feb 04, 2022 10:30 am

AISmebel wrote:After all, there were no problems before (((

What was your environment 'before' when it worked?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby rv1974 » Fri Feb 04, 2022 10:40 am

Fredo if you already implemented double space-bar for Repeat last.. Is it theoretically possible to implement 2-letter shortcuts via plugin (LOTT)?
Like in Revit, for example PB for Profile Builder? I always wanted this feature in SU
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby AISmebel » Fri Feb 04, 2022 11:16 am

fredo6 wrote:
AISmebel wrote:After all, there were no problems before (((

What was your environment 'before' when it worked?

Exactly the same. Didn't do Windows updates.
Again, everything stopped working after a bug in SketchUp.
I will continue to use your plugin anyway :)
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Fri Feb 04, 2022 11:45 am

AISmebel wrote:Again, everything stopped working after a bug in SketchUp.

But what was this bug?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby AISmebel » Fri Feb 04, 2022 11:59 am

fredo6 wrote:
AISmebel wrote:Again, everything stopped working after a bug in SketchUp.

But what was this bug?

I don’t remember what error caused SketchUp to close. But that was in SU 2020. Then I installed SU 2022 and your plugin still doesn't work :(
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Fri Feb 04, 2022 12:07 pm

AISmebel wrote:I don’t remember what error caused SketchUp to close. But that was in SU 2020. Then I installed SU 2022 and your plugin still doesn't work :(

Would you mind to do a Repair of SU2022 to see if this fixes the problem.
Same for SU2020 if you still have it on your computer.
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby AISmebel » Fri Feb 04, 2022 12:16 pm

fredo6 wrote:
AISmebel wrote:I don’t remember what error caused SketchUp to close. But that was in SU 2020. Then I installed SU 2022 and your plugin still doesn't work :(

Would you mind to do a Repair of SU2022 to see if this fixes the problem.
Same for SU2020 if you still have it on your computer.

Does your plugin share a file that is referenced by SU 2020 and SU 2022?
Maybe a settings file? Or something in the registry? Perhaps there was an error and this file needs to be updated.
SU 2022 has already done recovery. It didn't help me.
0

AISmebel 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Fri Feb 04, 2022 1:48 pm

The error is in Sketchup: some menu texts are wrongly encoded (or are read as such). I don't think this is directly related to LOTT.

Another user has a similar problem, running a French version of Sketchup 2021, but only on one computer.
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby alexpacio2013 » Tue Feb 22, 2022 4:12 pm

Hi, I use the Lord of the toolbar program with satisfaction But since yesterday I have this error message which in any case does not prevent me from continuing to work. the error presents us at the Start of SketchUp, I would like to know what it is from and how to solve it, given the great usefulness of this program for me who are disabled.


some extensions are referenced in palettes but not loaded - unknown command sketchup
0

alexpacio2013 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Tue Feb 22, 2022 4:49 pm

The latest version of LOTT tracks command icons of extensions which are referenced in palettes but are no longer present (for instance, when you uninstall them, or when you import configuration from another version of Sketchup. It displays a notification at startup if there are some, usually indicating the name of the command and extension.

It might be that there is a problem there. I'll have a look.

Fredo
2
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby alexpacio2013 » Tue Feb 22, 2022 10:33 pm

AcZCw6vyeZ.png
Without this plugin I can't work with skp, congratulations. how can I solve this problem? thanks, skp 2022 fredo lib updated.
0

alexpacio2013 
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby fredo6 » Tue Feb 22, 2022 11:12 pm

It may not be a problem actually. The notification automatically disappears after a few seconds.

Do you have issue with LOTT, in particular about 'ghost icons', that is icons in palettes that would have a rounded rectangle around and are disabled?
0
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v1.8d - 02 Feb 22

Postby alexpacio2013 » Thu Feb 24, 2022 2:13 pm

fredo6 wrote:It may not be a problem actually. The notification automatically disappears after a few seconds.

Do you have issue with LOTT, in particular about 'ghost icons', that is icons in palettes that would have a rounded rectangle around and are disabled?


I managed to solve the problem by uninstalling and deleting all the temporary files created by Fredo C: \ Users \ xxx \ AppData \ Local \ LIBFREDO6_DATA_Dir \ LOTT \ GHOST now I no longer have the error at startup
But now Fredo Corner no longer works, with a regular license. I deduce that the problem is caused by the combination of Lord of toolbars v12.5a with fredo Corner v2.5a.

I await updates
0

alexpacio2013 
 

Re: [Plugin] LordOfTheToolbars - v2.0a - 24 Feb 22

Postby fredo6 » Thu Feb 24, 2022 3:30 pm

NEW RELEASE: LordOfTheToolbars v2.0a - 24 Feb 22

Requirements
  • LibFredo6: v12.4a or above
  • Sketchup version: SU2017 and above

LordOfTheToolbars 2.0a includes
  • Adjustment for notification at startup of Sketchup

-----------------------------------------

Home Page of LordOfTheToolbars for information and Download.

Main post of this LordOfTheToolbars thread.
1
User avatar
fredo6 
Premium Member
Premium Member
 

Re: [Plugin] LordOfTheToolbars - v2.0a - 24 Feb 22

Postby Mariotalluto » Mon Feb 28, 2022 10:10 am

Thanks !
0
Last edited by Mariotalluto on Fri Apr 01, 2022 8:21 am, edited 1 time in total.

Mariotalluto 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: bangubay, DANOCH, reymond, Rga_79 and 8 guests