Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORKING

Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORKING

Postby pabloparraga » Wed Mar 04, 2015 6:34 pm

Hi everybody.
First of all, thanks for the great work keeping this blog alive.

I'm finding some troubles with Fredo Plugins. I'm running Sketchup Up 2015 Pro version, and I've installed Libfredo, FredoScale, Curviloft and RoundCorner (all of them, last updates).
First strange thing: I installed these plugins through Sketchucation Plugin Store manager, and i find these plugins installed as "plugins" and "extensions".
Second: These plugins (or extensions, or whatever they are) show on the toolbar, everything looks right, but they simply do not work. Clicking on them and it's like nothing is done.
I've tried to disable them, uninstall them, I've closed sketchup and opened it again, re-installed everything, and nothing.
I've disabled and uninstalled all these plugins / extensions, and even erased the files (and subfolders) from the plugins folder c:user:appdata:roaming:skechtup:sketchup2015:sketchup:plugins
but with no better results.

Anyone has got a clue about what could be happening?
Thanks a lot.
2

pabloparraga 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby TIG » Wed Mar 04, 2015 7:32 pm

That's "c:/users/yourusername/appdata/..."
I assume you user-name is in sensible characters ?
Some names with non-ASCII characters might cause issues...

BUT you say that the tools seems to load OK... so have you read the usage notes ?
Remember that you will need to select things to make such tools work further !
If you have the 'Ruby Console' open are there any error messages when you try to run the tools ?

FYI:
All 'add-on scripts' are actually 'Plugins', but some are written in a special way to become 'Extensions' - all that means is you can stop 'Extensions' loading as SketchUp starts.
They can be 'enabled' later if desired.
If you have the SketchUcation 'Plugins Manager', then you can do the same enable/load/disable with those AND any other 'vanilla' Plugins...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby pabloparraga » Wed Mar 04, 2015 11:18 pm

Hi TIG, and thanks a lot for your quick reply.
I've been using those great plugins from Fredo in previous versions of Sketchup, always without any problems.
But when I opened the Ruby Console, I got this message after trying to use the strechting tool from FredoScale:

Error: #<Errno::EACCES: Permission denied - C:/Users/PcCom/AppData/Local/LIBFREDO6_DATA_Dir/LibFredo6_all_defaults.dat>
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:145:in `initialize'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:145:in `open'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:145:in `write_to_file'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:128:in `store'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Plugin.rb:1104:in `usage_use'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Plugin.rb:1092:in `command_invoke'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Plugin.rb:1075:in `block (2 levels) in build_config_commands'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Traductor.rb:1112:in `call'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Traductor.rb:1112:in `block in add_command'
SketchUp:1:in `call'

And when I tried to use the RoundCorner plugin, I got this message at the Ruby Console:
Error: #<Errno::EACCES: Permission denied - C:/Users/PcCom/AppData/Local/LIBFREDO6_DATA_Dir/LibFredo6_all_defaults.dat>
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:145:in `initialize'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:145:in `open'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:145:in `write_to_file'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Registry.rb:128:in `store'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Plugin.rb:1104:in `usage_use'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Plugin.rb:1092:in `command_invoke'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Plugin.rb:1075:in `block (2 levels) in build_config_commands'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Traductor.rb:1112:in `call'
C:/Users/PcCom/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/Fredo6_!LibFredo6/Lib6Traductor.rb:1112:in `block in add_command'
SketchUp:1:in `call'

Any clue about the problem which is causing these plugins failure?
Thanks a lot in advance!
0

pabloparraga 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby fredo6 » Thu Mar 05, 2015 12:32 pm

It looks like you have an access restriction to the folder.

Could you check that?

Normally, the idea of having Plugins and Configuration files in the User\AppData directory root is that there should be no system security issues.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby TIG » Thu Mar 05, 2015 1:24 pm

To expand this issue a little... :?
The reported error arises with:
C:/Users/PcCom/AppData/Local/LIBFREDO6_DATA_Dir/LibFredo6_all_defaults.dat
Which can't be written.
So check the following.
You have permissions set to FULL for your all those listed to the folder:
C:/Users/PcCom/AppData/Local
Select its icon, Right-Click > Context-Menu > Properties > Security > Edit
Also check that there is a subfolder named LIBFREDO6_DATA_Dir and that that also has the FULL permissions.
It the ../Local folder was restricted perhaps the subfolder couldn't be made.
If there is a file in there named LibFredo6_all_defaults.dat then check it has FULL permissions too...
It the ../Local/LIBFREDO6_DATA_Dir subfolder was restricted perhaps the dat-file couldn't be made, or at least written to.
In that subfolder there should also be a subfolder named DefaultParameters containing one or more .def files... Check those permissions are FULL too...

After fixing these issues try starting SketchUp again and testing the tools...
Please report back...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby pabloparraga » Fri Mar 06, 2015 11:43 pm

Hi guys. And thanks a lot for your replies.
I've tried checking those folders, and it seems the users in my PC (SYSTEM; PCCom-PC; Administrators (PCCom-PC\Administrators) have all the permissions (except last one of the list (special permissions) which cannot be ticked as it's greyed.
This happens in all the folders-subfolders you've mentioned.
The last one (Default parameters, inside LIBFREDO6_DATA_Dir) has nothing inside.
I have no idea about what can be causing this problem...
Thanks for your time.
0

pabloparraga 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby pabloparraga » Tue Mar 10, 2015 8:18 am

Hi guys... Since no news about this issue, I guess there's no solution for my problem... Anyway I would like to thank you again for the time spent trying to give me some clues about the origin of the failure. I'm sure it should be something easy to rearrange, but i don't know what to erase/uninstall and to reintall/setup it again... Should I try to erase by hand the LIBFREDO folders and subfolders in AppData root?
Any more clues will be really welcome!!!
Thanks again and have a good day.
0

pabloparraga 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby fredo6 » Tue Mar 10, 2015 12:39 pm

pabloparraga wrote:Hi guys... Since no news about this issue, I guess there's no solution for my problem... Anyway I would like to thank you again for the time spent trying to give me some clues about the origin of the failure. I'm sure it should be something easy to rearrange, but i don't know what to erase/uninstall and to reintall/setup it again... Should I try to erase by hand the LIBFREDO folders and subfolders in AppData root?
Any more clues will be really welcome!!!
Thanks again and have a good day.

Maybe try to clean up the Fredo6 related files and directory under the APPDATA directory and try again. These files only contains default parameters and settings that you can anyway reconstruct when you use the plugins.

Fredo
2
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby pabloparraga » Mon Mar 16, 2015 8:11 am

Hi Fredo, and thanks for your reply.
I don't understand what should I do. When you say "clean up" you mean deleting the LIBFREDO6 folder and its subfolders?
And then, what should I do? download LIBFREDO again?
Thanks for your help...
0

pabloparraga 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby TIG » Mon Mar 16, 2015 11:47 am

pabloparraga wrote:Hi Fredo, and thanks for your reply.
I don't understand what should I do. When you say "clean up" you mean deleting the LIBFREDO6 folder and its subfolders?
And then, what should I do? download LIBFREDO again?
Thanks for your help...
No.
Fredo means delete the folder C:/Users/PcCom/AppData/Local/LIBFREDO6_DATA_Dir and its contents.
If it's missing then Fredo's tools recreate the folder and its contents when they next run - if they themselves are installed properly...
Try that and report back...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby pabloparraga » Mon Mar 16, 2015 12:23 pm

Hi guys!!!
I don't know why, but just doing what FREDO and you TIG said (closing sketchup, deleting LIBFREDO& folder and it's subfolders) and reopening sketchup again, everything runs smoothly again!!!
I really thank the time spent trying to find a solution to my problem guys. THANKS A LOT.
2

pabloparraga 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby edouardsanko » Sat Nov 25, 2017 5:34 pm

Hi Guys,

First, let me preface this by saying I have enjoyed using your tools prior to this version of SkUp, and have been wonderful! Thank you for your contributions.

I am having the same issue with roundcorners (which is what i am currently trying to use) except im on OSX el capitan. I am not sure how to solve this issue. I have the 3 icons loaded, but no actual "adjustment toolbar", and therefore nothing i can actually use...



Has this happened before? Would you be able to give me a hand?

Error: #<NoMethodError: undefined method `no_bandeau' for #<Traductor::Palette:0x007fcf93af4488>>
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/roundcorner_tool.rbs:1050:in `pal_sepa_bandeau'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/roundcorner_tool.rbs:1074:in `palette_init'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/roundcorner_tool.rbs:208:in `initialize'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/roundcorner_tool.rbs:129:in `new'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/roundcorner_tool.rbs:129:in `launch'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/roundcorner_tool.rbs:120:in `action__mapping'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbs:123:in `call'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbs:123:in `launch_action'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbs:221:in `launch_action'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/bootstrap_roundcorner.rbs:81:in `launch_action'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_roundcorner/bootstrap_roundcorner.rbs:96:in `block in startup'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbs:1208:in `call'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbs:1208:in `command_invoke'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbs:1190:in `block (2 levels) in build_config_commands'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6traductor.rbs:1339:in `call'
/users/xxx/library/application support/sketchup 2015/sketchup/plugins/fredo6_!libfredo6/lib6traductor.rbs:1339:in `block in add_command'
SketchUp:1:in `call'


Hoping you had a happy Thanksgiving (even though you are {probably} in France)!
0

edouardsanko 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby fredo6 » Mon Nov 27, 2017 11:03 am

@edouardsanko,

Your LibFredo6 version is not up to date. I suggest you refresh it, as well as all my other plugins.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby edouardsanko » Mon Nov 27, 2017 1:03 pm

Thank you so much for your prompt reply Fredo!

I went through all these motions several times actually: downloading, and installing Libfredo6, and Roundcorner (all newest versions, etc...) and was still getting the same problem...

My error was in how I was improperly attempting to proceed with updating by simply installing the latest plugin.
This was not overriding (any of) the previous version(s).

I finally just used the sketucation plugins uninstaller feature: uninstall roundcorner and libfredo6, quit, relaunch, reinstall Libfredo6, reinstall Roundcorner.

All seems to run normally and excellently now!

Thank you again.

edouard
0

edouardsanko 
 

Re: Libfredo, Fredoscale, Roundcorner and Curviloft NOT WORK

Postby SurfingAlien » Sun Feb 10, 2019 10:00 am

TIG wrote:
pabloparraga wrote:Hi Fredo, and thanks for your reply.
I don't understand what should I do. When you say "clean up" you mean deleting the LIBFREDO6 folder and its subfolders?
And then, what should I do? download LIBFREDO again?
Thanks for your help...
No.
Fredo means delete the folder C:/Users/PcCom/AppData/Local/LIBFREDO6_DATA_Dir and its contents.
If it's missing then Fredo's tools recreate the folder and its contents when they next run - if they themselves are installed properly...
Try that and report back...


just to confirm that doing this actually solved a similar issue I was having with both Fredo6's Tools on Surface and Round Corners (but not his other plugins) - SU pro 2018 on win10. thanks folks!
0

SurfingAlien 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Plugins

Who is online

Users browsing this forum: howardhong, Jakcy, kidus firew, krisrgarrido and 14 guests

Visit our sponsors: