Plugins Folder Security Permissions...

Plugins Folder Security Permissions...

Postby TIG » Fri Jan 24, 2014 12:12 pm

If you get SketchUp startup error-message relating to plugins that are not loading properly, like:
[../Plugins/]xxx_plugins/xxx_pluginloader.rb etc it means it simply can't find it - it indictaes it hasn't been installed properly...
Or messages actually preventing you from adding/managing files/subfolders to the Plugins folder...

This 'Security Permissions' problem has been discussed endlessly in other threads...
But this sticky is now linked in future responses...


Windows:

If you have limited Security permissions to your Plugins folder, Windows can let you think it has installed your files properly, but it has actually put them [or the subfolders needed by them] into a 'VirtualStore'...
If the Plugins 'Windows Explorer' window has a link/button in its top-bars named something like 'Compatibility Files...', then that is a sure sign of this - clicking on it opens the VirtualStore revealing what has not been installed properly...
Being an Admin is no guarantee that you will have adequate permissions - by default Windows limits the Security setting of everyone, for all files and folders within the 'Program Files' tree...

If you get a message from the SketchUcation 'Plugins Manager' itself saying things you have no Plugins folders to manage in the $LOAD_PATH, this is because of the same issue.
It will not let you 'manage' plugins in folders for which you have inadequate Security permissions - if it didn't stop you, then you would think you had disabled a plugin only to find that you hadn't when SketchUp restarted, because you did not have permission to change plugins...

Here are the steps you need to fix this...

As an Admin [if you are not one give yourself that ability under the Users Control-Panel...]

First - in the very unlikely event that you have a custom icon assigned to the Plugins folder remove it - oddly this can subtly change even its FULL permissions just a little, and has been known to cause issues...

Select the Plugins folder's icon, in the SketchUp folder.

Right-click > Context-menu > Properties > Customize > Change Icon > Restore Defaults
Apply/OK


Now to fix your permissions...
Select the Plugins folder's icon, in the SketchUp folder.

Right-click > Context-menu > Properties > Security > Edit...

Set the permissions for every user/group in the list to FULL read/write.

Apply/OK

These changes should automatically trickle down to affect the contents too...

Next set SketchUp to always run as admin...
Select the SketchUp.exe icon, in the main SketchUp folder.

Right-click > Context-menu > Properties > Compatibility

In the 'Privilege Level' pane tick the check-box 'Run this program as an administrator'

Apply/OK

Now...
If you have previously properly relocated the missing Plugins folder's files/subfolders-with-files-intact from the VirtualStore... OR deleted them and then reinstalled the plugin[s]... then the SketchUp startup error-message should be history.

After the SketchUp restart the SketchUcation 'Plugins Manager' should also work and list the contents of the main Plugins folder, which you will now be able to disable/enable, with the changes remembered across sessions...

Now auto-installing plugins/extensions should put every thing in the correct places - and hopefully leave the VirtualStore empty !

The future...
Hopefully, SketchUp versions >v2013 will address this permissions issue and locate the Plugins folder in the User's AppData tree, where they will automatically have FULL permissions...


MAC

Most MAC users will usually already have FULL access to their Plugins folder, because it is in the User's Lib tree... BUT for SketchUp versions <v2013 they can also experience these limited permissions issues - much as described for PCs - because in those versions the default MAC Plugins folder was in the automatically restricted main HD Lib path...
This can be fixed in a similar way...
Select the 'Plugins' folder's icon [press Option-key in the 'Finder' to see these Libs listed].
Use the context-menu > 'Get Info'...
Its 'Sharing and Permissions' pane should show FULL read/write for you [and others is you wish] - but if not you should reset - you might have to enter the admin password if it's 'Locked'...
Note that unlike Windows - where the changes to the permissions of a container [folder] automatically trickle down to affect its contents - on a MAC you must select the 'cog' dropdown option - 'Apply to enclosed items...'
10
TIG
User avatar
TIG 
Global Moderator
 

Re: Plugins Folder Security Permissions...

Postby TIG » Tue Feb 25, 2014 11:23 am

This is the pretty version with pictures [by Rich]
http://sketchucation.com/resources/tuto ... n-sketchup
1
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Plugins

cron

Who is online

Users browsing this forum: arquijavier, jacovwyk101, MJD, thaispinheiro33, thuanmai and 23 guests

Visit our sponsors: