[Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby SpookyChick1013 » Tue Jan 24, 2017 4:41 am

Ok, having an interesting problem with Thrupaint. Is there somewhere I can get a copy of 1.2a? It worked.

Since I updated to the new version as part of the whole Fredo Tools package, the menu palette refuses to show anything beyond this:
ThruPaintProblem.PNG



I have not yet found the problem with this and would love to just revert to 1.2a, but I no longer have the installer. Any help would be welcome.

Thanks,
Cathryn Shaw
0
https://kuromatsudriveyards.com

Fo-su to tomo ni aran koto o...

SpookyChick1013 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Tue Jan 24, 2017 7:52 am

Cathryn,

Could you open the Ruby console when you open ThruPaint.

It also looks like you have an old version of LibFredo6.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby SpookyChick1013 » Tue Jan 24, 2017 8:21 pm

...And here's the Error code from the console. Sorry for not including that yesterday Fredo. I'm still getting over the flu, and just didn't think of it. :puke:

Error: #<NoMethodError: undefined method `no_bandeau' for #<Traductor::Palette:0xd100e38>>
(eval):3989:in `palette_bandeau'
(eval):3917:in `init_palette'
(eval):354:in `activate'
(eval):186:in `select_tool'
(eval):186:in `execute_direct'
(eval):265:in `_execution'
(eval):265:in `call'


Also, Win7Pro, still using SU7.1. I may upgrade if I can get far enough ahead of bills to save up for it. 64-bit and Large Address would be nice. ;)

EDIT: Oh, and I just updated LibFredo to 7.4. Yesterday, even. :) I figured It might help.
0
https://kuromatsudriveyards.com

Fo-su to tomo ni aran koto o...

SpookyChick1013 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Tue Jan 24, 2017 9:51 pm

SpookyChick1013 wrote:EDIT: Oh, and I just updated LibFredo to 7.4. Yesterday, even. :) I figured It might help.

Then there is something wrong in the installation of LibFredo6 7.4.

Can you check the folder Fredo6_!LibFredo6, and see if you have only rbe and rbs files, and there is no .rb files left from previous versions.

Possibly, do a clean up and reinstall LibFredo6

Fredo
2
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby SpookyChick1013 » Tue Jan 24, 2017 10:50 pm

Hmmm. I'll check that and see if that's the issue.


Edit: Yeah, that was the problem. Thanks very much, Fredo. :) Sorry for not thinking of this solution myself :oops: :oops: :oops:

As always, your entire suite of plugins are the backbone of what we all do with SketchUp. Thanks once again, for the plugins and the assistance.

May the Source be with you,
;)
Cathryn
0
https://kuromatsudriveyards.com

Fo-su to tomo ni aran koto o...

SpookyChick1013 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Tue Jan 24, 2017 11:21 pm

SpookyChick1013 wrote:Edit: Yeah, that was the problem. Thanks very much, Fredo. :) Sorry for not thinking of this solution myself :oops: :oops: :oops:

For info, what was the problem?

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby SpookyChick1013 » Wed Jan 25, 2017 1:22 am

The problem was having 77 .rb files from the old libraries. :oops: I had for some reason never considered that they might remain in there, not being auto-magically overwritten and eventually cause a problem. I think it may have resulted from Windows offering to merge folders, and me not paying attention to what I was clicking on.
So, upon finding that yes, there were a bunch of .rb files in there, I sorted by file type, selected all .rb and cut; pasting into a storage folder elsewhere, just in case doing so screwed something up.

Seems to have solved the problem, nothing screwed up and ThruPaint works right again, showing the full palette.

Cathryn
0
https://kuromatsudriveyards.com

Fo-su to tomo ni aran koto o...

SpookyChick1013 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby Alehandroh » Sat Feb 11, 2017 8:12 pm

Hi there,why i cant download plugin?
0

Alehandroh 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby pilou » Sun Feb 12, 2017 1:45 am

Try this link (just register yourself - free)
http://sketchucation.com/pluginstore?pln=FredoTools
0
Frenchy Pilou
Is beautiful that please without concept!
Speedy Galerie
User avatar
pilou 
Top SketchUcator
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby solo » Sun Feb 19, 2017 7:33 pm

A silly question I'm sure the answer is here someplace but I'll ask anyway.

How do I stop Thru paint from opening every time I use SU material editor?

I have tried disabling it in extension manager but that does not stop it from still being enabled.
0
www.solos-art.com

I'm a social vegan, I avoid meet.
User avatar
solo 
Global Moderator
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby Rich O Brien » Sun Feb 19, 2017 7:35 pm

There's a setting in the ThruPaint parameters that toggles it on/off. By default it's off so at some point you turned it on.
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby solo » Sun Feb 19, 2017 7:38 pm

Rich O Brien wrote:There's a setting in the ThruPaint parameters that toggles it on/off. By default it's off so at some point you turned it on.



I unchecked that option but still pops up when I use SU material editor

*edit* F9 worked. Doh!
0
www.solos-art.com

I'm a social vegan, I avoid meet.
User avatar
solo 
Global Moderator
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby Rich O Brien » Sun Feb 19, 2017 10:02 pm

screen-grab_106.jpg


Is that on or off?
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby mwm5053 » Tue Apr 18, 2017 3:21 pm

A question. Would someone look at these settings and tell me why I can't seem to rotate or otherwise scale this texture? When I rotate or scale the texture with the gizmo nothing happens.
0
2011 iMac
SU 2015 Pro, 2017 Make
V2 Twilight
macOS Sierra 10.12.5

mwm5053 
Premium Member
Premium Member
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby mwm5053 » Tue Apr 18, 2017 3:34 pm

Dah I had the faces reversed didn't realize that and ThruPaint settings were set to front face.
0
2011 iMac
SU 2015 Pro, 2017 Make
V2 Twilight
macOS Sierra 10.12.5

mwm5053 
Premium Member
Premium Member
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby juju » Wed Apr 19, 2017 8:04 am

mwm5053 wrote:Dah I had the faces reversed didn't realize that and ThruPaint settings were set to front face.

Another D'oh book entry? ;)
1
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby tuna1957 » Sat May 13, 2017 8:30 pm

Been back at trying to get better with SubD and Quadface Tools and ran into this situation with Thru Paint. Modeled a pillow with above mentioned tools. The model passed the Quad Tools analyze function. Tried to texture the model with Thru Paint using the "paint quads" function. Piping textured fine, tried for the rest of the model and get error message there is problem with models quads. Don't know why it's doing this. Something I did wrong or am I asking Thru Paint to do something it really can't do ? Still in the learning stages with quad modeling. Attached a screen shot showing what happened. Thru Paint highlighted the row of quads in all four corners.
0

tuna1957 
Premium Member
Premium Member
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby dmorong » Thu Aug 10, 2017 8:33 pm

I am having problems with the texture mapping gizmo in Thrupaint. When I click on a surface the gizmo appears for a moment, but then goes away before I can make any changes with it. I have reinstalled both Fredo6 Tools and LibFredo.
Looking for any tips on getting the little gizmo to stick around long enough to be useful.
1
Macbook Pro 15" (Mid 2014)
2.5 Intel i7
Mac 10.12.6
Sketchup 17.2.2554

dmorong 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Thu Aug 10, 2017 10:24 pm

@dmorong

Difficult for me to reproduce, as I don't have a Mac and I cannot reproduce the problem on Windows.

Maybe a Mac user can help. But first time I hear about that problem.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby dmorong » Mon Aug 14, 2017 8:28 pm

I tried the plugin in a computer lab over the weekend with Late 2015 4K iMacs running 10.11 and had the same issue.
I am attaching a short screen capture showing what is happening. Sampling, painting into groups and mapping controls all work fine, but the single click on the surface to bring up the mapping adjustment tool results in just a flash of the gizmo and corresponding window, and then it goes away before any adjustments can be made.

Let me know if I can provide you with any other information on the problem.

David
0
Macbook Pro 15" (Mid 2014)
2.5 Intel i7
Mac 10.12.6
Sketchup 17.2.2554

dmorong 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Mon Aug 14, 2017 9:19 pm

dmorong wrote:Let me know if I can provide you with any other information on the problem.

Could you open the Ruby Console, when running ThruPaint, just in case there is an error message.

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby dmorong » Mon Aug 14, 2017 9:45 pm

Nothing shows up in the Ruby Console when running the Extension.

David
0
Macbook Pro 15" (Mid 2014)
2.5 Intel i7
Mac 10.12.6
Sketchup 17.2.2554

dmorong 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Mon Aug 14, 2017 10:39 pm

David,

When you hover over the painted surface, could you type Enter. This also goes into the Edition mode.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby dmorong » Tue Aug 15, 2017 11:16 pm

Yes, anytime you hover over the surface, as long as you see the small postit that indicates the mapping (Front Quadmesh, Natural, or Projected) you can hit enter and the adjustment gizmo will come up and stay so it can be manipulated. Thanks for pointing out that key command. That solves the problem

David
0
Macbook Pro 15" (Mid 2014)
2.5 Intel i7
Mac 10.12.6
Sketchup 17.2.2554

dmorong 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby pep75 » Tue Jan 16, 2018 9:19 pm

I was wondering if someone can tell me where the sliders are on the visual tool in ThruPaint? I used to scale(non uniform) textures in U and V direction seperately but cannot right now. What am I doing wrong?

Thanks in advance!
0
Last edited by pep75 on Wed Jan 17, 2018 10:51 am, edited 1 time in total.
User avatar
pep75 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby pbacot » Tue Jan 16, 2018 9:53 pm

I didn't realize it but that non-uniform scaling function does not work in the "natural" UV setting (it's "non-deforming")
1
MacOSX Mojave ShetchUp Pro v16...v19? Layout Twilight Pro v2 M2 Kerkythea PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby pep75 » Wed Jan 17, 2018 2:23 pm

Thanks Pbacot! :)
0
User avatar
pep75 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby fredo6 » Wed Jan 17, 2018 4:34 pm

pbacot wrote:I didn't realize it but that non-uniform scaling function does not work in the "natural" UV setting (it's "non-deforming")

This is correct. In Natural mode, the textures are never deformed, because the UV mapping is computed by propagation in all direction (so no real geometric reference to rely on, unlike the Projected or Quad modes)

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby pep75 » Wed Jan 17, 2018 8:38 pm

Thanks a lot Fredo!
0
User avatar
pep75 
 

Re: [Plugin] FredoTools::ThruPaint - v1.3a - 20 Oct 16

Postby rv1974 » Sun Mar 18, 2018 4:12 pm

Hi Fredo, recently I was fantasizing about extra feature for Pantthru. Please take a look at attached. The idea is to jitter the UVW's of multiple objects according to user input (in %% for each dimention). And it should work regardless the context (as ThruPaint does).
In attached picture UVW's of 3 instances of one component were jittered in U/V dimention.
0

rv1974 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: mielaymielay, ryaanmatthew, toku, X3 and 21 guests

Visit our sponsors: