[Plugin] QuadFaceTools

Re: [Plugin] QuadFaceTools

Postby thomthom » Sun Jul 31, 2016 9:40 pm

Just need an icon...
5
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Mon Aug 01, 2016 10:06 pm

Version 0.11.0 is out.

2016-08-01_23h07_36.png


2016-08-01_23h08_26.png
6
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby numerobis » Tue Aug 02, 2016 1:29 pm

:fro: :thumb:
0

numerobis 
 

Re: [Plugin] QuadFaceTools

Postby cotty » Tue Aug 02, 2016 3:53 pm

:thumb: and :thumb:
0
User avatar
cotty 
Top SketchUcator
 

Re: [Plugin] QuadFaceTools

Postby pbacot » Tue Aug 02, 2016 6:40 pm

Nice!
0
MacOSX Mojave ShetchUp Pro v19 Twilight Pro v2 M2 Kerkythea PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: [Plugin] QuadFaceTools

Postby ithil » Thu Aug 04, 2016 5:11 pm

Very cool!!!
Thank you! :thumb:
0
User avatar
ithil 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby plot-paris » Fri Aug 12, 2016 8:35 am

Working nicely! Very valuable tool for quick and clean quad face modelling.

Could you make it so, that the green / red color is removed when disabling Live Mesh Analysis?
That would show clearly, if the system is switched on or off.
0
User avatar
plot-paris 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Tue Aug 16, 2016 8:01 pm

plot-paris wrote:Could you make it so, that the green / red color is removed when disabling Live Mesh Analysis?
That would show clearly, if the system is switched on or off.

hm... yea, that's not a bad idea. All though - it would remove the materials completely. It would not restore any materials that might previously been there as it's not being tracked and isn't easily trackable either.

Logged in issue tracker: https://bitbucket.org/thomthom/quadface ... oggling-it
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby Carto » Fri Aug 19, 2016 6:13 am

Hello ThomThom,

I'm currently attempting to size a UV texture using the UV Mapping tool with standard measurements (i.e inches 12", 12") but the value is ignored when typed. Did I type the values correctly or miss something else? Thanks.

Regards
0

Carto 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Fri Aug 19, 2016 8:28 am

Hm... can you share a sample model? Maybe it's related to model units or something. (which version of QFT do you have?)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby Carto » Fri Aug 19, 2016 8:23 pm

Hello ThomThom,

See attached model. I have the latest version 0.11.0
0

Carto 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Mon Aug 22, 2016 2:35 pm

Oh, I see now. The input is accepting input as relative scale - not model units. The input currently represent how many times the texture tiles across the X and Y UV axes.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby Carto » Tue Aug 23, 2016 5:32 pm

Hello ThomThom,

Thank you for looking at this. I was just converting from metric to standard, but it would be convenient if you could enter the actual model units. Thanks again for a great plugin.

Regards
0

Carto 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Tue Aug 30, 2016 7:39 pm

Version 0.12.0

  • Made OBJ importer create groups from OBJ groups.
  • Made OBJ importer correct SketchUp's "auto-orientation" of faces which was some times confused by internal faces.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Tue Aug 30, 2016 7:40 pm

Version 0.12.0 was made to allow OBJs exported using Mineways read properly in SketchUp:

http://www.realtimerendering.com/erich/ ... /mineways/

minecraft.png
1
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby eneroth3 » Wed Aug 31, 2016 10:08 pm

This is my home in minecraft :D . This really works and it's amazing! Some manual labor was needed to clean up the edges between blocks but that's fine, the plugin does a great job!

hyde park corner.png


https://3dwarehouse.sketchup.com/model. ... 3d3de85f27
2
User avatar
eneroth3 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby kaas » Sun Oct 09, 2016 12:42 pm

Anyone uses OffsetLoop? Whats the best way to use it? I'm getting mostly crashes / bugreport Oops-loops with 0.12.
0

kaas 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Sun Oct 09, 2016 7:59 pm

Got a sample model? Screenshot?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby kaas » Mon Oct 10, 2016 12:23 pm

thomthom wrote:Got a sample model? Screenshot?

Just a simple box and there we go again. If nobody else has problems I guess its a clash with other plugins. I will try to do a clean install for all my plugins soon.
0

kaas 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Mon Oct 10, 2016 1:32 pm

Doesn't have to be a clash. The offset tool is a recent one that was more of an experiment. I had it hidden for a while but people insisted it should be visible by default. But it will have some problems still. I have an open issue to improve or rewrite it.

That being said - I wasn't able to reproduce your exact scenario. Can you share the model please?

Also, what version of the extension do you have?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby kaas » Mon Oct 10, 2016 1:54 pm

I'm using
QFC 0.12.0
TTlib 2.10.6

I attached a file. The shape doesn't really matter though - sometimes it crashes on me on a simple box...

Edit 10-10-2016: just cleaned my plugin directory. Installed TT_lib2, QFT, Selectiontoys and tested again. Same crashes so I would suspect no clashing plugins.
0

kaas 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Mon Oct 10, 2016 4:28 pm

Hmm.... I cannot reproduce on this one either. Can you do a video capture to show your steps?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby kaas » Mon Oct 10, 2016 4:55 pm

thomthom wrote:Hmm.... I cannot reproduce on this one either. Can you do a video capture to show your steps?


Here you go - shocking isn't it? I'm thinking I'm wasting your time. There must be something wrong at my end. Although it is strange; only TTlib2, QFT, Selection toys installed (all fresh from SketchUcation tools & TTlib2 from Extension warehouse). SU-pro 16.1.1449 64 bit.

Edit + pic: it also crashes after adding a few loops and at some point it doesn't detect the loop anymore (blue line) and...ooops
0

kaas 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Tue Oct 11, 2016 3:48 pm

Hmm... have you submitted the reports? Did you include your name/email other info?

Also, what version of Internet Explorer do you have installed? The error reporting dialog looks odd.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby kaas » Tue Oct 11, 2016 4:41 pm

thomthom wrote:Hmm... have you submitted the reports? Did you include your name/email other info?

Also, what version of Internet Explorer do you have installed? The error reporting dialog looks odd.


I have submitted only a very few (user name Max). Sometimes it caused an oops-loop and I didn't report those either.

I'm running win7 x64 on my desktop with IE11.0.9600.18449
0

kaas 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Wed Oct 12, 2016 10:05 am

I see the issue now. It's when you offset only one edge.
https://bitbucket.org/thomthom/quadface ... g-only-one

I also noticed another issue, if you pick an edge at the end of your selection the offset is missing an edge.
https://bitbucket.org/thomthom/quadface ... sing-edges
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby kaas » Wed Oct 12, 2016 10:15 am

thomthom wrote:I see the issue now. It's when you offset only one edge.
.. I also noticed another issue, if you pick an edge at the end of your selection the offset is missing an edge...


Both true. Glad you could reproduce the issue. I'm a bit confused nobody has noticed this before. The offset tool itself could be quite useful.
0

kaas 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Thu Oct 13, 2016 10:36 am

As it is now, consider the OffsetTool an alpha-version. I would not have exposed it yet had it not been for being persistently nagged to do so. ;)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby HornOxx » Wed Nov 30, 2016 7:50 pm

Hi All
I just nee a little help how to install the current QuadFace tools correctly, to get
access to this cool live mesh analysis feature.

I always get the error message (shown below) when I activate live mesh analysis.
I also installed the current tt Lib².
I´m trying to run Quadface tools within my SU 2015 Make which is my prefered Quad-version
with tools like SubD, Vertex tools etc...

I appreciate any help - Thanks
0
never trust a skinny cook
User avatar
HornOxx 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Sun Dec 04, 2016 8:13 pm

HornOxx wrote:I´m trying to run Quadface tools within my SU 2015 Make which is my prefered Quad-version
with tools like SubD, Vertex tools etc...

Ah, sorry - bad user feedback on my end. The error is due to the functionality being SU2016+ only.
3
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: ShahramAfshar4 and 39 guests

Visit our sponsors: