[Plugin] KML Tools (2.0.0-beta) — updated 31.05.2013

Re: [Plugin] KML Tools (1.4) — updated 10.09.2010

Postby lbatt3 » Wed Sep 21, 2011 11:42 pm

I'm new to SU, and this is completely awesome, exactly what I've been looking for.

BUT, installed it, and it worked great once to bring in a KML line (GPS "track" from Garmin opened in Google Earth and saved as KML). Also brings in KML points (GPS waypoints) no problem. But then I go to download another line KML and no luck at all. I tried removing and re-downloading/unzipping, still no luck.

I'm on Windows XP using FireFox, if that matters.
0

lbatt3 
 

Re: [Plugin] KML Tools (1.4) — updated 10.09.2010

Postby Aerilius » Thu Sep 22, 2011 5:48 pm

Hi,
can you give me a link to that file?

A possibility is that the lines are in a "network link" in the KML file. Then Google Earth loads them from the internet (so the lines are not in the file). The importer plugin cannot download network links.
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4) — updated 10.09.2010

Postby lbatt3 » Fri Sep 23, 2011 4:16 am

Aerilius wrote:Hi,
can you give me a link to that file?

A possibility is that the lines are in a "network link" in the KML file. Then Google Earth loads them from the internet (so the lines are not in the file). The importer plugin cannot download network links.



Here is a link to one of the KML files I had trouble with:

http://dl.dropbox.com/u/11217841/Garden.kml

I did find a fix - tracing the track as a regular line in GE, then exporting. These imported just fine. So I guess it's the original track files from GPS that the plugin has trouble with. GE is loading them from the MapSource software I have which holds the Garmin/GPS data. Would they still be a network link? just odd that it worked for the first one, then not after that.

Thanks again for your time creating this plugin. Can't tell you how valuable it will be in creating site layouts (we do horse farm planning).
0

lbatt3 
 

Re: [Plugin] KML Tools - Importer and Exporter

Postby burgemj » Fri Sep 23, 2011 10:30 pm

Pixero wrote:I have the same problem as lexmonteiro (above).
IE 8 Windows 7 64bit. SketchUp 8 Pro.


I also have the same problem as lexmonteiro with regards to the fetching elevation data and am running the same setup as Pixero. I believe lexmonteiro was running an older version of IE that solved his problem. Pixero and I are not, however. Has this issue been resolved and I'm just missing it somewhere?
0

burgemj 
 

Re: [Plugin] KML Tools (1.4) — updated 10.09.2010

Postby asteinberger » Mon Sep 26, 2011 6:19 pm

I'm having an issue which I don't think anyone else has mentioned yet. I'm trying to import extruded building footprints into Sketchup. The terrain on which they are supposed to sit is quite hilly, and what I've noticed is that when the kml files are imported, they seem to pitch in such a way that they are perpendicular to whatever slope they sit on.



The kml files themselves look fine, it's when they get imported into sketchup that the problem occurs. Any ideas???
0

asteinberger 
 

Re: [Plugin] KML Tools (1.4) — updated 10.09.2010

Postby Aerilius » Tue Sep 27, 2011 1:49 am

I found the reason and solved it. There was something not clear in the kml documentation. While not-extruded polygons relative to ground follow the terrain, extruded polygons don't.
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4) — updated 10.09.2010

Postby asteinberger » Tue Sep 27, 2011 7:11 pm

Aerilius wrote:I found the reason and solved it. There was something not clear in the kml documentation. While not-extruded polygons relative to ground follow the terrain, extruded polygons don't.


awesome! works perfectly now! I owe you a beer.
0

asteinberger 
 

Re: [Plugin] KML Tools (1.4d) — updated 1.10.2011

Postby huckrorick » Fri Oct 14, 2011 6:56 am

Thanks. This is just the tool I've been looking for. I only used it once so far but it worked beautifully (well, actually when I used it without first importing the location (just imported the kml) it was kind of screwy, but when I imported the location first it worked perfectly.
One thing that I thought might be useful to people: I didn't unzip the kmz. From Google Earth I just saved the polygons etc as kml, then imported that with you plugin.

thanks again,

Huck
0

huckrorick 
 

Re: [Plugin] KML Tools (1.4d) — updated 1.10.2011

Postby cyb » Thu Jan 26, 2012 3:55 pm

The import hangs when connecting to some website. Is it a neccessary process?
Could this part be eliminated?
0

cyb 
 

Re: [Plugin] KML Tools (1.4d) — updated 1.10.2011

Postby Aerilius » Thu Jan 26, 2012 8:48 pm

Hi,
SketchUp does not import an elevation with its Add Location feature, that's why the plugin needs to get this from the GeoNames organisation.
From where did you download the plugin? The current version on this website shouldn't have this issue anymore and should continue without elevation after some seconds. I would be curious to know if it's still not solved.
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4d) — updated 1.10.2011

Postby cyb » Fri Jan 27, 2012 3:08 am

Downloaded from this topic few days ago.
Just tested. Stuck at:

fetching Elevation data...
from api.geonames.org
0

cyb 
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby Aerilius » Sat Jan 28, 2012 4:13 pm

I think I fixed it. Thanks for reporting.
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby cyb » Mon Jan 30, 2012 4:47 am

It works. Thanks.
0

cyb 
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby JClements » Mon Jan 30, 2012 8:09 am

What is supposed to occur when the Export KML option is used?

I don't get a dialog of any sort or anything telling me if and where the KML is saved.

Running SU8Pro, Windows7.
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby TIG » Mon Jan 30, 2012 2:58 pm

You should first get a webdialog with various options and when you 'ok' that you get a dialog to name/save the file to a folder...
Are there error messages in the open Ruby Console when you run the tool ?
Does your kmlTools subfolder in Plugins look like this ?
Capture.PNG
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby JClements » Mon Jan 30, 2012 3:45 pm

I downloaded the current version of the script.

I had another rb file in the plugins folder. KML_Loader.

I removed it and I can now get a dialog to appeaer.


However, a dialog only appears if I select geometry of a non-group (see attached jpg).
kml_test_screen_capture.JPG
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby JClements » Mon Jan 30, 2012 4:33 pm

my test file.
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby TIG » Mon Jan 30, 2012 4:38 pm

That's not right!
I get the full webdialog and I don't need to select anything at all...
Have you got ALL of the files in the subfolder that I showed in my screenshot ?
Have you got any copies of these files [or other 'kml' files] in the Plugins folder by mistake ? - if so remove them... There should only be 'kmlTools.rb' in Plugins.
It's an Extension does it appear in the Preferences dialog ?
:?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby JClements » Tue Jan 31, 2012 4:52 am

I have the same configuration on my laptop and get the same result. And, yes, I do show KML Tools in my extensions listed and it is checked.

My KML Tools files:
Plugins.JPG


KmlTools_Folder.JPG
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby TIG » Tue Jan 31, 2012 10:03 am

Weird ?
I suggest you PM Aerilius... :?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby JClements » Tue Jan 31, 2012 10:44 pm

In case anyone is interest there is plugin for ARC GIS that allows contours to be exported to a KML file.

The KML can be imported into GEarth. And, using KML Tools, imported into SU. The GIS plugin has some nice features such as adding text labels or text with leaders to the KML file which KML Tools handles just fine. The text info comes from the elevation name assigned to a contour group (which is a nice "welded" polyline). With this particular KML no effort was made to optimize the segmentation of the polyline contours.

It took less than 5 minutes to generate the terrain mesh using the Sandbox Tool with my Cor7 PC.


I posted this here because the old ARCgis plugin on the SketchUp site (http://sketchup.google.com/intl/en/down ... ugins.html) no longer works with SU7 and SU8. There is a "multipatch" function/workflow in GIS but the files created are huge and usually crash SU when attempting to import or error out. With KML Tools, SU has now regained some of the ability to handle GIS output.

If anyone is interested, I will try to find out the specifics of the GIS plugin used to create this KML.
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.5) — updated 28.01.2012

Postby JClements » Wed Feb 01, 2012 10:20 pm

Follow Up:

I've had issues with the KMT Tool export functions. I finally, did a complete re-installation of SU8. Aside from the default plugin installation, only the KML Tools were installed.

I found that Groups were ignored, but Components were not ... provided they were preselected. However, the KML of a component export could not be imported nor opened in Google Earth (Pro).

If nothing is selected then the export dialog did not display.

The selection of loose geometry works, but when imported into Google Earth, edges could be misplaced. For example, a one leg of cube was tilted.

Cube KML created via KML_tools.jpg
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.6) — updated 02.02.2012

Postby Aerilius » Thu Feb 02, 2012 2:10 am

The cause of the problem one rare occasions has been fixed. Generally groups should be exported and the export dialog should show now always.
The export of ungrouped geometry is not intended. It is better to group an object so that the corresponding kml feature can be recognized.
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4.7) — updated 04.02.2012

Postby JClements » Thu Feb 09, 2012 4:41 am

Thanks for the update 1.4.7. Some problems still exist.

Please use the attached .skp and export to kml.

I think the following will ALWAYS FAIL to export correctly. Any geometry drawn off axis or rotated so that its edges are off axis will not export correctly.

What does work now is making a group or a component of any geometry, then exporting the group or component. However, they too will fail if subsequently rotated. Scaling the component after creating it does not appear to adversely affect the component when exported.


Regards, John

KML test 3.skp
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.8) — updated 09.02.2012

Postby Aerilius » Thu Feb 09, 2012 11:05 pm

Thanks for the test case. I fixed that components were exported with reversed tilt angle (Google Earth uses it in the opposite direction than SketchUp).

Ungrouped geometry is NOT intended to be used for export (as written above).
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4.8) — updated 09.02.2012

Postby JClements » Fri Feb 10, 2012 8:27 am

And thank you one more time.

John
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.8) — updated 09.02.2012

Postby justin.kromer » Wed Feb 15, 2012 7:04 pm

I've had success importing certain kml files. Others not so much. The error i'm receiving in the ruby console is as follows:

fetching elevation from url: http://api.geonames.org/astergdemJSON?f ... returnJson
kmlImport.rb: geonames returned 38
Error: #<NoMethodError: undefined method `+' for nil:NilClass>

Any input would be helpful. Thanks
0

justin.kromer 
 

Re: [Plugin] KML Tools (1.4.8) — updated 09.02.2012

Postby Aerilius » Fri Feb 17, 2012 1:06 am

Can you paste this in the Ruby Console before running the lugin again?
Code: Select all
$VERBOSE=true

Then the error message will tell a bit more useful. Thanks!
0

Aerilius 
PluginStore Author
PluginStore Author
 

Re: [Plugin] KML Tools (1.4.8) — updated 09.02.2012

Postby JClements » Sun Mar 18, 2012 8:52 pm

Another benefit of the export KML option is creating Tour Paths for GoogleEarth. SU makes it easier to create smooth paths, edit those paths, and append a path via the Weld script. After opening the KML path in GoogleEarth, if you discover you want to reverse the direction of the tour along the path, then you can use Fredo6's revert path script and then save it as a new kml file.
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] KML Tools (1.4.8) — updated 09.02.2012

Postby schoobie » Wed Mar 21, 2012 5:41 am

I have been importing the attached file to draw lines between the points I marked in GE Pro from a survey I did sometime ago.

But when I try to connect one point with the other, the pencil tool would never pick the end of any of the points. It picks something on the air and not sure what I am doing wrong. Please help.
0

schoobie 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: Andra24, vlachin and 8 guests

Visit our sponsors: