[Plugin Library] LibFredo6 - v10.9a - 02 Jul 20

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Bob James » Tue Apr 26, 2011 8:28 pm

Gus R wrote:Fredo,
Is there any way to keep "Check Plugins for Update" from opening at startup of SU?

I didn't know SU could do that. Where is the setting?
0
i7-4930K 3.4Ghz, 2x GTX780 6GB, 32GB DDR3-1600 ECC, OCZ Vertex 4 500GB, WD Black 3TB, 32TB NAS, 4x 27" Monitors, SpaceMouse Pro, X-keys XK-60
User avatar
Bob James 
Premium Member
Premium Member
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Defisto » Wed Apr 27, 2011 4:12 am

#---------------------------------------------------------------------------------
» [ Post in Spanish ]
#---------------------------------------------------------------------------------

Bueno yo baso las Traducciones en las Traducciones Oficiales de Importantes Software de Diseño y de Populares Software para el Modelado 3D., debido a que Quería mantener las Mismas Interpretaciones., y para Evitar que las Traducción se Centralizara en Cierta Área de America., por ese Motivo Me parce extraño que los Términos No sean los Mismos., debido a que las Interpretaciones al Español que use en las Traducciones son tal como se ven en los Software de Autodesk, Corel Corporation, y Otros Populares Software de Dibujo CAD y Modelado 3D., etc…

Además., también Investigué en Diferentes Foros dedicados al Modelado 3D., sobre los Términos mas Comunes., incluso Revise en Wikipedia una Gran cantidad de Términos., para asegurar que Todo fuera correcto,. Y puedo Justificar la Interpretación de cada Línea Traducida al Español de las 923 Líneas Actuales

Bueno., lo de los Caracteres Extraños., Yo había Notado algunos pocos en el Plugin “ToolsOnSurface” (En su Área de Información, en relación a los Acentos y Tildes) Gracias por el Dato., Yo no Intente cambiar la Codificación debido a que Fredo Dice: No Editar el Archivo con la Traducción Manualmente., pero ahora Mismo voy a Convertir la Codificación a UTF-8 y Luego voy a Actualizar el Post., y Gracias por la Consejo (de Nuevo) !! – Pero como el Señor Fredo Todo lo hace Perfecto., yo no me atreví a contradecirlo.

Pero antes voy a Probar este Problema a Fondo., y luego voy a Informar a Fredo de los Resultados., Ya que esto solo Pasa con “ToolsOnSurface” y en la “Área de Información” (Solamente) y esto me hace pensar que hay algo más detrás de todo esto... ႿÐ! - Gracias: Oxer !!
---------------------------------------------------------------------------------------------

» @Fredo:

En la Consola Ruby: Yo Obtengo lo Mismo que Oxer... ႿÐ!

---------------------------------------------------------------------------------------------


PS: Ogvua... ႿÐ!

#---------------------------------------------------------------------------------
» [ Post in English ]
#---------------------------------------------------------------------------------

Well I base the translations in the “Translations Official” of Important Software Popular for Design and 3D Modeling. because I wanted to keep the same interpretations., and to prevent or avoid that the translation will be centralized in one area of America., by That is why I sounds strange that the terms are not the same., because of that the “Spanish Interpretations” that I used in the Translations are as is seen in Autodesk softwares, Corel Corporation, and Others Popular Software of Drawing CAD and Modeling 3D., etc ..

Also., I investigated in various forums dedicated to 3D modeling the most common terms., including Wikipedia.org for Review a large number of terms., to ensure that all were correct. And I can justify the interpretation of each line translated to the Spanish of the 923 Current Lines

Good and the strange characters., I had noticed a few in the Plugin “ToolsOnSurface” (In Your Area Information in relation to the Accents and tildes) Thanks for the tip., I never try to change the encoding because Fredo Says: Do not edit the file with the translation manually !! - but now I'm going to convert the encoding to UTF-8 and then I will Update the Post., Thanks for the Tip (again) !! - But as Mr. Fred Everything he does is perfect. I did not dare contradict him.

But first let me test this issue to the Fund and then I will inform the results to Fredo., Since this only happens with "ToolsOnSurface" and the "Area Information " (Only) and this makes me think that there something else behind all this... ႿÐ!
---------------------------------------------------------------------------------------------

» @Fredo:

In the Ruby console: I Get the Same that Oxer... ႿÐ!

---------------------------------------------------------------------------------------------


PS: Ogvua... ႿÐ!
0
笑い男: I thought what I'd do was, I'd pretend I was one of those deaf-mutes... ႿÐ!

http://www.goear.com/listen/85c21f9/lit ... tt-matthew

笑い男: Pensé que lo que haría sería fingir ser uno de esos sordomudos... ႿÐ!

Defisto 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby ardthe214 » Wed Apr 27, 2011 4:35 am

Thanks a lot... :berserk:
0

ardthe214 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Jim » Sat Apr 30, 2011 8:12 pm

I see the plugin is aware of plugins that are not installed/enabled. That's a nice feature for discovering new plugins. Why not have a link to them also in the Info column to make them easy to find and install?

Thanks.

1096.png
0
Hi

Jim 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Sat Apr 30, 2011 9:33 pm

Jim wrote:I see the plugin is aware of plugins that are not installed/enabled. That's a nice feature for discovering new plugins. Why not have a link to them also in the Info column to make them easy to find and install?

Thanks.

Jim,

Excellent idea. This is now done for my plugins.
You can check it by displaying the dialog box again and rechecking.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby nickeh » Tue May 10, 2011 12:08 pm

I found that v3.7 broke support for wine, anyone else having these problems?

I reverted back to v3.6b witch works fine with round corners and curviloft in wine.

The problem with v3.7 is that sketchup crashes when it loads, some times i starts ok, but it opens a window with a ruby icon in it and nothing more.

I use Ubuntu 11.04, Wine-1.2.2, Sketchup 8.0.4811 installed via winetricks.

For those using linux it would be good to put a link on the first page to version 3.6b and write a short line that this is the latest version working with wine?
0

nickeh 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Tue May 10, 2011 12:19 pm

Nickeh,

This may come from the startup phase.
I would suggest that whenever you can open Sketchup, you go to Windows > LibFredo6 settings > Check Plugin for Update, and then enter 999 in the Next Check field (it means never display the Ruby reminder at startup).

I will try to investigate what can be specific to Wine / Linux for this startup sequence.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby antuan » Mon May 16, 2011 4:44 am

Hi,
I had Tools on surface, Fredo Scale and other Fredo plugins installed in SU 7.1 and all was working OK. Today I installed SU 8, downloaded last versions of same plugins and everything worked OK until I tried to open Default Parameters dialog. It simply didn't open for any of the plugins... I reinstall plugins, even reinstall SU... nothing, the Default Parameters doesn't open. Any idea to solve that?
Thank you in advance.
0

antuan 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Mon May 16, 2011 9:20 am

antuan wrote:Hi,
I had Tools on surface, Fredo Scale and other Fredo plugins installed in SU 7.1 and all was working OK. Today I installed SU 8, downloaded last versions of same plugins and everything worked OK until I tried to open Default Parameters dialog. It simply didn't open for any of the plugins... I reinstall plugins, even reinstall SU... nothing, the Default Parameters doesn't open. Any idea to solve that?
Thank you in advance.

Does it work for
- The Language Transaltion dialog boxes
- the Check Plugins for Update dialog box (in Windows > LibFredo6 settings)

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby antuan » Mon May 16, 2011 11:11 am

Fredo,
Yes both Translation and Check For Update dialog boxes work normally; By the way, if I install my old plugins (Libfredo6 3.4c) then the default preferences box opens normally, so the problem seems to be only in the new version.
Thanks for your fast replay.
0

antuan 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby antuan » Mon May 16, 2011 11:24 am

Fredo,
I add a bit more information: When trying to open the dialog box SU creates the DEFPARAM_Dir, but it keeps empty. If I copy inside of it the parameters definition file (i.e. ToolsOnSurface.def) from the SU7.1 installation, the changes take effect in SU 8. I don`t know if this helps you to isolate the problem.
Thank you again.
0

antuan 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby thomthom » Mon May 16, 2011 11:37 am

If you keep the Ruby Console open, do you get any messages?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby antuan » Mon May 16, 2011 10:52 pm

Thomthom,
Sorry for the delayed reply. No messages in the ruby console when trying to open the Default Parameters dialog box. Any one found this problem?
Thanks
0

antuan 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Tue May 17, 2011 7:53 am

Antuan

Can you open the Default Parameters dialog box for LibFredo6 and for my other plugins (if you have some installed)?

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby antuan » Tue May 17, 2011 9:40 am

Fredo,
No, I can´t. I have installed FredoScale, ToolsOnSurface and Round Corner. None of them opens the Default parameter dialog.(e.g. Tools-Fredo6 Collection-ToolsOnFace-Default Parameters... does nothing, same for FredoScale or Round Corner) And the same for LibFredo6 library, through Window-LibFredo6 Settings-Default Paramenters... nothing happens. But as I said before other dialog boxes open normally (Check for update or Language Translation), and if I copy for example FredoScale.def from the still existing SU 7 files tree to the SU8 DEFPARAM-DIR directory I see that is detected because the changes take effect (i.e. change of the toolbar icons, etc.). The problem is about the dialog box itself, it doesn´t open no matter how I try. I am missing something? Any way, with older versions of same plugins everything works, both in SU 7 or 8.
Thank you for your help.
0

antuan 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby mfarooqi » Sat May 21, 2011 12:37 pm

beautifull man... 10+/10
0

mfarooqi 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby rjjvirusx » Fri May 27, 2011 10:11 pm

Perfect~Thank you~!
0

rjjvirusx 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Goonster » Mon May 30, 2011 6:45 am

Downloaded and installed the latest version but it does not show up in SU. I copied both the LIBFREDO6_Dir_37 folder and the LibFredo6.rb into the plug ins folder as shown but it just won`t show. I thought the .rb file might need unblocking - which I did. But still no joy. I already have the Fredoscale plug in which works fine.
Any ideas?

I use Win7 Home Premium 64bit with SU8.
0

Goonster 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Mon May 30, 2011 7:16 am

Goonster wrote:Downloaded and installed the latest version but it does not show up in SU. I copied both the LIBFREDO6_Dir_37 folder and the LibFredo6.rb into the plug ins folder as shown but it just won`t show. I thought the .rb file might need unblocking - which I did. But still no joy. I already have the Fredoscale plug in which works fine.
Any ideas?

I use Win7 Home Premium 64bit with SU8.

LibFredo6 is not really a plugin but a library.
Since you have FredoScale working fine, from what you say, it means you have a version of LibFredo6 installed.
Can you check the menu Windows > LibFredo6 Settings... > About

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Goonster » Tue May 31, 2011 6:26 am

Sorted it. I downloaded LibFredo6 3.7b but forgot to download the actual plug in! Sorry. :oops:
0

Goonster 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby halroach » Mon Jun 06, 2011 8:57 am

Hi Fredo,

I have been getting the following errors when I try to check plugins for updates.
I click on the red ruby icon and nothing happens (the update window doesn't come up)
and I get the following in the ruby console:

Code: Select all
C:/Program Files/Google/Google SketchUp 8/Plugins/ruby/singleton.rb:84: warning: already initialized constant FirstInstanceCall
C:/Documents and Settings/All Users/Application Data/ASGVIS/VfS/Ruby/VfSObservers.rb:307: warning: don't put space before argument parentheses
C:/Program Files/Google/Google SketchUp 8/Plugins/ruby/singleton.rb:84: warning: already initialized constant FirstInstanceCall


The last thing I did, which may have caused this was install GhostComp 1.0 - but I have tried removing it and the error still comes up.
Any ideas?

edit: If I click on "check updates" through the menus, everything works... it's just through the ruby button that it gives errors.

Thanks!

edit2: Forgive me! I think I confused your update plugins ruby (which is part of libfredo) with a different ruby that has the same "ruby" icon which is called Autoloader.... so never mind! my bad!
everything is working fine!!
0
User avatar
halroach 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby tails » Mon Jun 06, 2011 3:00 pm

Apologies if this has been answered already, I'm getting this when I start sketchup. Is there a simple fix. Apple imac, SU7.
0

tails 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby TIG » Mon Jun 06, 2011 5:14 pm

tails wrote:Apologies if this has been answered already, I'm getting this when I start sketchup. Is there a simple fix. Apple imac, SU7.

There must currently be some permissions set that prevent you making folders/files in that location - either fix the permissions so you can [advisable]... OR make the folder that is needed... as clearly spelled out in the message :roll:
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Daniel S » Mon Jun 06, 2011 7:32 pm

I have problems with the update option too... Every time that I want to go to "Check Plugins for Update" nothing happens. If I have the ruby console open it says:

error.jpg

Code: Select all
Error: #<RangeError: 9947298230.424000 out of Time range>
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:677:in `at'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:677:in `tip_next_date'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:642:in `format_html_top'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:225:in `refresh_dialog_top'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:520:in `create_dialog_top'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:151:in `initialize'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:79:in `new'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Upgrade.rb:79:in `top_dialog'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Plugin.rb:195:in `populate_support_menu'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Traductor.rb:908:in `call'
C:/Program Files/Google/Google SketchUp 8/Plugins/LIBFREDO6_Dir_37/Lib6Traductor.rb:908:in `add_command'


Any idea what´s happening?

Daniel S
0

Daniel S 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Mon Jun 06, 2011 8:28 pm

Daniel,

two questions

1) How many days did you set the "next check" in the dialog box

2) Can you type the following command in the Ruby Console: Upgrade.duration_next_check

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Daniel S » Mon Jun 06, 2011 10:01 pm

Fredo6 wrote:1) How many days did you set the "next check" in the dialog box

I put 999 the first time because I wanted to do a manual check. But then the update option stop working.
I try deleting and reinstalling Libfredo6 but the problem was still there.
Now In default parameters "Next Check in (days)" says 15. But I´m not able to check.

Fredo6 wrote:2) Can you type the following command in the Ruby Console: Upgrade.duration_next_check


I tried and give different results. It says:

Code: Select all
Upgrade.duration_next_check
Error: #<NameError: (eval):157: uninitialized constant Upgrade>
(eval):157

Code: Select all
Upgrade.duration_next_check
Error: #<NameError: (eval):677: uninitialized constant Upgrade>
(eval):677

or:
Code: Select all
Upgrade.duration_next_check
Error: #<NameError: (eval):54: uninitialized constant Upgrade>
(eval):54
(eval):1: warning: Float 0.0 out of range


Daniel S
0

Daniel S 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Mon Jun 06, 2011 10:52 pm

Daniel,

Sorry I meant Traductor::Upgrade.duration_next_check

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Daniel S » Mon Jun 06, 2011 11:38 pm

When I put:
Traductor::Upgrade.duration_next_check
it says:

Code: Select all
Traductor::Upgrade.duration_next_check
99999.0


Daniel S
0

Daniel S 
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby fredo6 » Tue Jun 07, 2011 12:11 am

Daniel,

This is where is the problem: 99999 is too big for a number of days.
Can you change it in the default parameters or in the Upgrade dialog box
I'll put a check in a next release

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v3.7b - 22 Apr 11

Postby Daniel S » Tue Jun 07, 2011 12:40 am

Fredo6 wrote:This is where is the problem: 99999 is too big for a number of days.
Can you change it in the default parameters or in the Upgrade dialog box
I'll put a check in a next release
Fredo


I can´t change the 99999 because:
- The Upgrade dialog box don´t open
- In default Parameters I can change it but it doesn´t really change.
In the attach video I show what happens.

I tried reinstalling LibFredo6 but still no work.

Daniel S
0

Daniel S 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: stephm and 10 guests

Visit our sponsors: