[Plugin Library] LibFredo6 - v11.4f - 02 Dec 20

Re: [Plugin Library] LibFredo6 - v11.2c - 11 Oct 20

Postby fredo6 » Sun Oct 25, 2020 8:26 pm

loesshill wrote:I've installed several extensions plus Libfredo6 months ago, and they all worked well,(thank you).
Today they do not work. Please advise.

Maybe you can indicate which one and give more info on the issues. This would help....
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.2c - 11 Oct 20

Postby spablo » Mon Oct 26, 2020 8:23 pm

instale el plugin y no funciona
0

spablo 
 

Re: [Plugin Library] LibFredo6 - v11.2c - 11 Oct 20

Postby TIG » Wed Oct 28, 2020 12:46 pm

spablo wrote:instale el plugin y no funciona

LibFredo no hace nada por sí solo, ayuda a sus otras extensiones ...
¿Cómo no funcionó?
¿Reiniciaste SketchUp para sincronizar cosas?
Ayuda a Fredo, ¡no es un psíquico!


The LibFredo does nothing on its own - it helps his other Extensions...
How did it not work ?
Did you restart SketchUp to sync things ?
Give Fredo some help - he is not a psychic !
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v11.2c - 11 Oct 20

Postby cleatus269 » Fri Oct 30, 2020 4:15 pm

I am having issues with the animator. I have made animations in the past no problem. I try to make them now and i either get the hundreds of images OR nothing at ALL. I have uninstalled and reinstalled libfredo, FFFmpeg and it worked once, but now is not working.

Please advise.... thanks
0

cleatus269 
 

Re: [Plugin Library] LibFredo6 - v11.2c - 11 Oct 20

Postby manoamo » Wed Nov 18, 2020 10:29 am

I really want to use your tools but I can't install Liebefredo6 .. :roflmao:

Whenever I install Liebefredo6, this message pops up


Error Loading File Fredo6_!LibFredo6.rb
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/xxx/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `gsub'
c:/users/xxx/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `get_dir_from_ENV'
c:/users/xxx/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:425:in `su_appdata'
c:/users/xxx/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:443:in `dir_appdata'
c:/users/xxx/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:206:in `startup'
C:/Users/xxx/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:62:in `process'
C:/Users/xxx/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:69:in `<module:LibFredo6_Loader>'
C:/Users/xxx/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'



Please help...
Thank you so much
0

manoamo 
 

error loading

Postby manoamo » Thu Nov 19, 2020 11:21 am

Error Loading File Fredo6_!LibFredo6.rb
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/user/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `gsub'
c:/users/user/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `get_dir_from_ENV'
c:/users/user/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:425:in `su_appdata'
c:/users/user/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:443:in `dir_appdata'
c:/users/user/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:206:in `startup'
C:/Users/user/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:62:in `process'
C:/Users/user/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:69:in `<module:LibFredo6_Loader>'
C:/Users/user/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'


I'm having an issue installing and loading LibFred6... please help
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.3a - 19 Nov 20

Postby fredo6 » Fri Nov 20, 2020 8:45 am

NEW RELEASE: LibFredo6 v11.3a - 19 Nov 20

LibFredo6 11.3a is dedicated to
  • Bug fixing
  • Support of VRay 5 in Animator
  • Some cosmetic adjustments
  • Compatibility SU2021

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.3b - 21 Nov 20

Postby fredo6 » Sat Nov 21, 2020 4:11 pm

NEW RELEASE: LibFredo6 v11.3b - 21 Nov 20

LibFredo6 11.3b contains small adjustments over v11.3a

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.3b - 21 Nov 20

Postby roxcore » Mon Nov 23, 2020 12:33 pm

Hello LibFredo6!! Just installed the new versions of animator and the library plugin. I use Vray next to render and i notice that after te first image is rendered Animator doesn't start with the second image. It just keeps counting the seconds even after the render is finished. I also noticed that in the menu, the preset dimensions are gone. I only have the viewport option.

Greetings, Simon
0

roxcore 
 

Re: [Plugin Library] LibFredo6 - v11.3b - 21 Nov 20

Postby fredo6 » Mon Nov 23, 2020 1:38 pm

roxcore wrote:Hello LibFredo6!! Just installed the new versions of animator and the library plugin. I use Vray next to render and i notice that after te first image is rendered Animator doesn't start with the second image. It just keeps counting the seconds even after the render is finished. I also noticed that in the menu, the preset dimensions are gone. I only have the viewport option.

Could you open the Ruby Console before launching the video generation and check the traces and potential errors.
Can you also confirm the version of VRay you use. Thanks.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.3b - 21 Nov 20

Postby roxcore » Mon Nov 23, 2020 3:30 pm

Hello Fredo! Thank you for answering!! This is what te ruby console showed when opening Animator and starting the generation of the movie:

RENDERING INIT
Status natural = {}
Status thea = :not_supported
Status ambient_occlusion = :not_supported
Status sketchFX = :not_supported
Status twilight = :not_supported

VRAY4 Init
Status vray4 = nil
Status vray = :not_supported
:beg_time => 0
:end_time => 90.5
:frame_rate => 25
:speed_factor => 1.0
:reversed_play => nil
:transparent => false
:dimX => 1920
:dimY => 1080
:dim_mode => "custom"
:filter => {
} (:filter)
:root_dir => "C:/Users/Gebruiker/Desktop/PROJECTEN/CARPENTIER/7. MONTAGEFILM HOUTEN WAND PERGOLA/Animator Videos"
:movie_dir => "BASIS ANIMATOR 4 - 23-Nov-2020 15-23-52"
:movie_name => "Film 1"
:date_modified => 1606130042.267186
:break_aspect_ratio => true
:movie_formats => {
:mp4 => true
:mov => false
:img_seq => true
} (:movie_formats)
:rendering_method => :vray4
MOVIE PX = 1920 PY = 1080 transpa = false
FORMATTED===========================

VRAY Movie frame 1
Animation time = 0.00s
Path = Image0001.png
AFTER launching Rendering and Timer: status = true
VRAY Status check - status = 6
VRay rendering not finished yet elapsed = 1.99s
Error: #<NoMethodError: undefined method `state' for nil:NilClass>
c:/users/gebruiker/appdata/roaming/sketchup/sketchup 2019/sketchup/plugins/fredo6_!libfredo6/body_lib6videomanager.rbe:445:in `vray_status_check'
c:/users/gebruiker/appdata/roaming/sketchup/sketchup 2019/sketchup/plugins/fredo6_!libfredo6/body_lib6videomanager.rbe:553:in `block in vray4_status_check'
INTERRUPT true
VRAY STOP timer =
VRAY STOP timer =

My Version of Vray is: V-Ray for SketchUp 4.20.02

Greetings
0

roxcore 
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby fredo6 » Mon Nov 23, 2020 3:57 pm

NEW RELEASE: LibFredo6 v11.4a - 23 Nov 20

LibFredo6 11.4a fixes a problem introduced with v11.3a in the support of VRay 4.2 for Animator

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby roxcore » Mon Nov 23, 2020 4:07 pm

Everything works fine with the update!! Thank you so much!! Greetz
0

roxcore 
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby manoamo » Wed Nov 25, 2020 8:32 am

I'm having a " invalid byte sequence in UTF-8 error "
I watched your installation video 4 times, Searched about this error for days.
I found out that this might be a encoding problem, but I have no idea how to solve this problem.
please help .. Below is error log(?) when I restart SU after Libfredo6 installation.

Error Loading File Fredo6_!LibFredo6.rb
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `gsub'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `get_dir_from_ENV'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:425:in `su_appdata'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:443:in `dir_appdata'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:206:in `startup'
C:/Users/홍우빈/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:62:in `process'
C:/Users/홍우빈/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:69:in `<module:LibFredo6_Loader>'
C:/Users/홍우빈/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby fredo6 » Wed Nov 25, 2020 10:47 am

manoamo wrote:I'm having a " invalid byte sequence in UTF-8 error " .

It's definitely related to your Windows user name not in ascii.

Difficult to fix as there are so many situations.

If you agree, we could try to troubleshoot together the problem (I would send you some small lines of Ruby to test).

In the Ruby console, can you type (just copy / paste the statement and Enter)

ENV["LOCALAPPDATA"].encoding.inspect

Then tell me what you see as a response

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby manoamo » Thu Nov 26, 2020 9:08 am

Thank you so much for your kind help! Much appreciated!!

ENV["LOCALAPPDATA"].encoding.inspect
#<Encoding:CP949>

This is what I got !
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby fredo6 » Thu Nov 26, 2020 9:51 am

manoamo wrote:ENV["LOCALAPPDATA"].encoding.inspect
#<Encoding:CP949>

This is what I got !

Could you now execute the following commands in the Ruby console, one after the other

a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8")

a.encoding.inspect

Thanks
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby manoamo » Fri Nov 27, 2020 2:22 am

Thank you so much for your kind help!

ENV["LOCALAPPDATA"].encoding.inspect

#<Encoding:CP949>
a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8")
C:\Users\￈ᆱ﾿↓ᄎ￳\AppData\Local
a.encoding.inspect
#<Encoding:UTF-8>

This is what I got
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4a - 23 Nov 20

Postby fredo6 » Fri Nov 27, 2020 9:39 am

manoamo wrote:Thank you so much for your kind help!

ENV["LOCALAPPDATA"].encoding.inspect

#<Encoding:CP949>
a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8")
C:\Users\￈ᆱ﾿↓ᄎ￳\AppData\Local
a.encoding.inspect
#<Encoding:UTF-8>

This is what I got

Then, can you try the following commands

a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8").gsub(/\\/, "/")

a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8").gsub("\\", "/")


and then this command

LibFredo6.get_dir_from_ENV "LOCALAPPDATA"
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby fredo6 » Fri Nov 27, 2020 1:16 pm

NEW RELEASE: LibFredo6 v11.4d - 27 Nov 20

LibFredo6 11.4d fixes two issues for Animator (VRay5 rendering of apparation and rotation with variable speed)

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby manoamo » Fri Nov 27, 2020 1:26 pm

ENV["LOCALAPPDATA"].encoding.inspect
#<Encoding:CP949>
a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8")
C:\Users\￈ᆱ﾿↓ᄎ￳\AppData\Local
a.encoding.inspect
#<Encoding:UTF-8>
a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8").gsub(/\\/, "/")

Error: #<ArgumentError: invalid byte sequence in UTF-8>
<main>:in `gsub'
<main>:in `<main>'
SketchUp:1:in `eval'

a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8").gsub("\\", "/")
C:/Users/￈ᆱ﾿↓ᄎ￳/AppData/Local
LibFredo6.get_dir_from_ENV "LOCALAPPDATA"
Error: #<NameError: uninitialized constant LibFredo6>
<main>:in `<main>'
SketchUp:1:in `eval'


I followed every step that you told me!
but still same errors occur :cry:
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby fredo6 » Fri Nov 27, 2020 1:38 pm

@manoamo

Thank you. Very useful.

I think this is a bug in the core ruby engine.

I'll see what I can do in order to overcome the problem.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby fredo6 » Fri Nov 27, 2020 3:15 pm

@manoamo

Could you try

ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub(/\\/, "/")

Thanks

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby manoamo » Fri Nov 27, 2020 4:12 pm

I tried the last typing but I failed again
I typed the codes in this sequence

1. ENV["LOCALAPPDATA"].encoding.inspect
2. a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8")
3. a.encoding.inspect
4.
1) a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8").gsub(/\\/, "/")
2) a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8").gsub("\\", "/")
3) ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub(/\\/, "/")
5. LibFredo6.get_dir_from_ENV "LOCALAPPDATA"


Thanks
1

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby fredo6 » Fri Nov 27, 2020 4:19 pm

@manoamo

Could you tell me what is the error you get with this statement

ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub(/\\/, "/")
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby manoamo » Fri Nov 27, 2020 4:24 pm

This is my ruby console

ENV["LOCALAPPDATA"].encoding.inspect
#<Encoding:CP949>
a = ENV["LOCALAPPDATA"].dup.force_encoding("UTF-8")

C:\Users\￈ᆱ﾿↓ᄎ￳\AppData\Local
a.encoding.inspect

#<Encoding:UTF-8>
ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub(/\\/, "/")
C:/Users/■ルヘ↓レᄚ→ᄍネ/AppData/Local
LibFredo6.get_dir_from_ENV "LOCALAPPDATA"
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `gsub'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `get_dir_from_ENV'
<main>:in `<main>'
SketchUp:1:in `eval'

----------------------------------------

This is what I get after restart

Error Loading File Fredo6_!LibFredo6.rb
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `gsub'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:45:in `get_dir_from_ENV'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:425:in `su_appdata'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:443:in `dir_appdata'
c:/users/홍우빈/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:206:in `startup'
C:/Users/홍우빈/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:62:in `process'
C:/Users/홍우빈/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:69:in `<module:LibFredo6_Loader>'
C:/Users/홍우빈/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby fredo6 » Fri Nov 27, 2020 4:40 pm

Ok. Thanks I think we progress.

Can you try this statement (only this one)

File.directory? ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub(/\\/, "/")


if there is an error, can you try this one

File.directory? ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub("\\", "/")


Many thanks

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby manoamo » Fri Nov 27, 2020 4:45 pm

Good to hear!

These are what I got back


First,

File.directory? ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub(/\\/, "/")

true
-----------

Second,

File.directory? ENV["LOCALAPPDATA"].dup.encode("UTF-8").gsub("\\", "/")
true
0

manoamo 
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby fredo6 » Fri Nov 27, 2020 4:49 pm

OK. Thanks.

I will publish a fix and it should hopefully work for you.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Postby manoamo » Fri Nov 27, 2020 4:50 pm

Thank you so much for your kind help :cry:
0

manoamo 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: NaathA and 14 guests

Visit our sponsors: