[Plugin Library] LibFredo6 - v10.9a - 02 Jul 20

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby masloprojekt » Tue May 19, 2020 7:32 am

I think this update caused SUClock (which is brilliant btw) to stop working. Is it possible or should i look for a reason elsewhere? Thank You !

EDIT:

It looks like the time is counting correctly, but it doesn't display the watch.
0

masloprojekt 
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby signup » Tue May 19, 2020 2:33 pm

When drawing guide lines with draw tools in version 8.9b, they are divided automatically into segments like what you see in this gif



However, in the new version, there is no segment shown up in a guide line. So, is this feature deleted in the new version or is it bugged?

0

signup 
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby fredo6 » Tue May 19, 2020 2:55 pm

masloprojekt wrote:I think this update caused SUClock (which is brilliant btw) to stop working. Is it possible or should i look for a reason elsewhere? Thank You !

EDIT:

It looks like the time is counting correctly, but it doesn't display the watch.

I found the problem. Very strange because it should have been present since long...

Anyway, I will publish and update to SUClock (v4.0a).

Note however that SUClock 4.0a will only be available for SU 2017 and above.
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby fredo6 » Tue May 19, 2020 3:01 pm

signup wrote:When drawing guide lines with draw tools in version 8.9b, they are divided automatically into segments like what you see in this gif


However, in the new version, there is no segment shown up in a guide line. So, is this feature deleted in the new version or is it bugged?

The behaviour you mention with LibFredo6 8.9b (division of guide line) is weird. There has never been a feature to divide guide lines in DrawAlong.

IMPORTANT: You seems to be on SU2016. Please note that LibFredo6 v10.0 and above does not support SU2016 and previous versions of Sketchup. It should only be installed for SU2017 and above.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby signup » Tue May 19, 2020 4:40 pm

fredo6 wrote:
signup wrote:When drawing guide lines with draw tools in version 8.9b, they are divided automatically into segments like what you see in this gif


However, in the new version, there is no segment shown up in a guide line. So, is this feature deleted in the new version or is it bugged?

The behaviour you mention with LibFredo6 8.9b (division of guide line) is weird. There has never been a feature to divide guide lines in DrawAlong.

IMPORTANT: You seems to be on SU2016. Please note that LibFredo6 v10.0 and above does not support SU2016 and previous versions of Sketchup. It should only be installed for SU2017 and above.

Fredo



I've been using SU for 4 years and I often use this feature in any drawings of mine. It helps me divide lines equally and arrange everything quickly with divided segments.

Now, I'm using SU2019 along with new updates of LibFredo 6 which doesn't enable me to have those guiding lines and segments anymore. I hope you will figure it out and recover that feature.

Please watch my gifs carefully again.
0

signup 
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby fredo6 » Tue May 19, 2020 5:36 pm

I actually forgot about the feature '/', and its dual '*'.

I found the problem, and it will go into LibFredo6 v10.4c.

Thanks for signaling.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby signup » Tue May 19, 2020 5:48 pm

fredo6 wrote:I actually forgot about the feature '/', and its dual '*'.

I found the problem, and it will go into LibFredo6 v10.4c.

Thanks for signaling.

Fredo


Thanks for your help!
0

signup 
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby Dave R » Tue May 19, 2020 5:57 pm

signup wrote:Now, I'm using SU2019...


Please update your profile. It says you are still using SketchUp 2016 Make which is what made Fredo6 think that's what you are using.
1
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.4c - 19 May 20

Postby fredo6 » Tue May 19, 2020 6:19 pm

NEW RELEASE: LibFredo6 v10.4c - 19 May 20

LibFredo6 10.4c is a maintenance release, with bug fixing for FredoTools::DrawAlong

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
3
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.5a - 25 May 20

Postby fredo6 » Mon May 25, 2020 10:32 am

NEW RELEASE: LibFredo6 v10.5a - 25 May 20

LibFredo6 10.5a is a maintenance release, with bug fixing and cosmetic adjustments, most for Mac

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby fredo6 » Mon Jun 01, 2020 7:51 am

NEW RELEASE: LibFredo6 v10.6a - 01 Jun 20

LibFredo6 10.6a is a maintenance release, with bug fixing, adjustments for Mac and for FredoSpline v1.4a

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby cgarchitekt » Wed Jun 10, 2020 6:45 pm

To all dear FreoTools users,

I've a problem with FredoTools or LibFredo (i can't determine exactly what is causing the problem) because in my Sketchup 2018 installation the Fredo tools are not running. I get the Fredotools Icon in the program but when I click on it to select a tool only a window opens with the Javascript that comes with the LibFredo6.
The computer is only equipped with onboard Intel UHD 630 graphics, but the Sketchup 2018 version runs well and stable.

Can any of you out there tell me what the problem is or is it really the Intel UHD 630 graphics?

Thanks in advance for you appreciated help.
Horst
cgArchitekt
0

cgarchitekt 
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby Dave R » Wed Jun 10, 2020 10:12 pm

What version of SketchUp are you actually using? Your profile says you are using 2018 Free/Make which does not exist.

If you are using SketchUp 2018 Pro, did you install it correctly by right clicking on the downloaded installer and selecting Run as administrator?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby fredo6 » Thu Jun 11, 2020 6:01 am

cgarchitekt wrote:I've a problem with FredoTools or LibFredo (i can't determine exactly what is causing the problem) because in my Sketchup 2018 installation the Fredo tools are not running. I get the Fredotools Icon in the program but when I click on it to select a tool only a window opens with the Javascript that comes with the LibFredo6.

@cgarchitekt

Could you confirm you have installed the latest versions of LibFredo6 and FredoTools.

Could you also post or send me a screenshot of the "Javascript".

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby cgarchitekt » Fri Jun 12, 2020 1:10 pm

Dave R wrote:What version of SketchUp are you actually using? Your profile says you are using 2018 Free/Make which does not exist.

If you are using SketchUp 2018 Pro, did you install it correctly by right clicking on the downloaded installer and selecting Run as administrator?


Thanks for your answer.

I installed everything with the Extension Manager inside of the program. And it is shown correctly in the installed plugins. I've got no error message during installation process.
0

cgarchitekt 
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby Dave R » Fri Jun 12, 2020 1:44 pm

That doesn't answer the question about having installed SketchUp correctly. If you didn't install it correctly you could have issues such as you describe. It also doesn't answer the question about which version of SketchUp you are actually using.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby cgarchitekt » Fri Jun 12, 2020 4:47 pm

Dave R wrote:That doesn't answer the question about having installed SketchUp correctly. If you didn't install it correctly you could have issues such as you describe. It also doesn't answer the question about which version of SketchUp you are actually using.


everything is fine. Installed it completely new as administrator. Seems this was the problem.Thought an installation is not possible if you are not logged in as administrator. Apparently I was wrong.

Thank you all for your appreciated help to solve my problem.
Regards
cgArchitekt
0

cgarchitekt 
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby Dave R » Fri Jun 12, 2020 4:59 pm

Happy that fixed it. FWIW, you should be logged into Windows as your normal user but when you install programs, right click on the installer and choose Run as administrator. That is actually different from being the system admin anyway. If you don't use the Run as administrator option, Windows security features prevent some needed program stuff from being installed correctly and this results in various strange behaviors. Some of those behaviors don't become obvious right away.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.6a - 01 Jun 20

Postby TIG » Fri Jun 12, 2020 5:01 pm

As DaveR says [beat me to the post!]
SketchUp should always be installed on PC thus:

For a new installation...
Log into Windows as your normal user-account [whether or not this has admin=powers is irrelevant]/
Find the installer's exe file - usually in your Downloads folder...
Select that installer's exe file.
Right-click > Context-menu > "Run as administrator"
When prompted choose to "Install"...
Permissions etc are set up properly.

If it's already installed...
Close SketchUp.
Run as above
When prompted choose "Repair"...
Permissions etc are set up properly.

Never 'Run' an installer's exe file by double-clicking it - even if that user has admin powers it is not the same.
Running SketchUp as 'the admin' [i.e. NOT a normal user (who might also have some admin-powers)] will result in SketchUp behaving oddly - e.g. drag-n-drop will not work because SketchUp is operating at an elevated permissions level compared to Windows-Explorer...
1
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby fredo6 » Fri Jun 12, 2020 8:25 pm

NEW RELEASE: LibFredo6 v10.7a - 12 Jun 20

LibFredo6 10.7a is a maintenance release, with bug fixing, adjustments for Mac (dialogs) and better support of imperail units in VCB

_______________________________________________________________________________________

Requirements: SU2017 and above

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby vmddelrosario » Tue Jun 16, 2020 2:54 am

Tried installing libfredo6 v10.7a to no avail.. extension manager says the plugin is unsigned and sketchup keeps saying C:\Users\"user_name"\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins\Fredo6_!LibFredo6 is missing after I restart the software and even when the said directory actually exists.
0

vmddelrosario 
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby William_Wang » Tue Jun 16, 2020 11:01 am

fredo6 wrote:I actually forgot about the feature '/', and its dual '*'.

I found the problem, and it will go into LibFredo6 v10.4c.

Thanks for signaling.

Fredo

Intall LibFredo6 v10.7a but plugins not running
0

William_Wang 
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby fredo6 » Tue Jun 16, 2020 11:29 am

vmddelrosario wrote:Tried installing libfredo6 v10.7a to no avail.. extension manager says the plugin is unsigned and sketchup keeps saying C:\Users\"user_name"\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins\Fredo6_!LibFredo6 is missing after I restart the software and even when the said directory actually exists.

Is it the first time you install LibFredo6?

If so, this may be related to the installation of Sketchup, which you must do with "Run as Administrator".
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby fredo6 » Tue Jun 16, 2020 11:30 am

William_Wang wrote:Intall LibFredo6 v10.7a but plugins not running

Do you have a menu entry Window > LibFredo6 settings...?
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby Gus R » Tue Jun 16, 2020 7:58 pm

Not a critical issue but is there any way to tweak the font sizes for the interface windows? Seems like I was able to do that using standard Windows zoom keyboard commands. Here's some examples. Hard to read.
0
User avatar
Gus R 
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby fredo6 » Wed Jun 17, 2020 8:16 am

@GusR

Strange. It seems you don't have some fonts installed and default to Arial Narrow Black.

Did this happen with v10.7a only ?

What do you get for dialog boxes used by other plugins than mine?
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby Gus R » Wed Jun 17, 2020 4:24 pm

fredo6 wrote:@GusR

Strange. It seems you don't have some fonts installed and default to Arial Narrow Black.

Did this happen with v10.7a only ?

What do you get for dialog boxes used by other plugins than mine?


I have Arial Narrow. It's Windows 7 Pro if that matters. Was fine before v10.7a.

Other dialog boxes are fine.
0
User avatar
Gus R 
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby fredo6 » Wed Jun 17, 2020 5:55 pm

Best would be Tahoma or Helvetica.

With Windows 7, there may be many problems. This one is related to the change I made for some dialog boxes (like Check Plugins for Update) to rely on the recent API (HtmlDialog), because the old one (WebDialog) is being deprecated.

So, there is little I can do with this.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby Oxer » Fri Jun 19, 2020 4:46 pm

Hi Fredo,
I installed LibFredo 10.7a on SU2017 & macOS 10.13.6 and when I try to 'Check Fredo6 Plugins for Update', SketchUp crash.
The rest of functions work fine and the Tools too.
0
"The result is the end what is important is the process" by Oxer
http://www.oxervision.blogspot.com/
User avatar
Oxer 
 

Re: [Plugin Library] LibFredo6 - v10.7a - 12 Jun 20

Postby fredo6 » Fri Jun 19, 2020 6:15 pm

Oxer wrote:Hi Fredo,
I installed LibFredo 10.7a on SU2017 & macOS 10.13.6 and when I try to 'Check Fredo6 Plugins for Update', SketchUp crash.
The rest of functions work fine and the Tools too.

Thanks for advising. Actually I get it on Catalina too. I will investigate.

I converted some of the LibFredo6 dialogs to HtmlDialog (instead of WebDialog), which is the 'new' framework for web dialogs since SU2017 (and recommended). There are plenty of problems and this could be one more.
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: mshoaib8live, tang14 and 6 guests

Visit our sponsors: