[Plugin Library] LibFredo6 - v11.4d - 27 Nov 20

Re: [Plugin Library] LibFredo6 - v9.5k - 14 Mar 20

Postby babak » Sun Apr 19, 2020 7:15 pm

fedser wrote:@TIG
Hi
This action does not solve the problem. I always install SU with administrator rights. I tried to install it on another computer. Problem still exists. The "Portrait" plugin also has a problem with svg. The plugin itself is working properly. SU2019 doesn't have this problem. Maybe this problem is only with me, I wanted to know how it works on your SU2020?



Exactly same problem here with SU 2020. After reinstalling Windows 10 and upgrading Sketchup 2019 to 2020 on a new ssd on my asus notebook INTEL i7-6700 (windows 10 pro 1909), some Fredo6 plugins are missing svg icons.
I have the same w10 configuration on my Desktop computer AMD RYZEN 7 and everything is absolutely fine.
Tried upgrading nvidia drivers, downgrading them, reinstalling Sketchup.
Many thanks for your plugins anyway...
1

babak 
 

Re: [Plugin Library] LibFredo6 - v9.5k - 14 Mar 20

Postby fredo6 » Sun Apr 19, 2020 10:43 pm

The problem has to do with the default web browser on Windows.

For whatever reason, SU2020 seems to use an old version of IE which is not compatible with HTML 5 and does not support SVG.

Why is it OK on SU2019 and not on SU2020 is a mystery.

I don't know how to help on that. I'll try to get some info.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.0a - 20 Apr 20

Postby fredo6 » Mon Apr 20, 2020 2:40 pm

NEW RELEASE: LibFredo6 v10.0a - 20 Apr 20

LibFredo6 10.0a is the first release of LibFredo6 for SU2016+.

All subsequent versions of LibFredo6 will only be maintained for SU2016+. This is due to a recent change in Trimble policy for the releasing of signed extensions.

For users of Sketchup versions up to SU2015, I have archived the frozen version of LibFredo6 and my other plugin in this post.

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v9.5k - 14 Mar 20

Postby babak » Thu Apr 23, 2020 8:41 pm

fredo6 wrote:The problem has to do with the default web browser on Windows.

For whatever reason, SU2020 seems to use an old version of IE which is not compatible with HTML 5 and does not support SVG.

Why is it OK on SU2019 and not on SU2020 is a mystery.

I don't know how to help on that. I'll try to get some info.

Fredo


Problem solved, also I am not sure wether I identified the real cause...
I installed sketchup 2019 and I observed it installed Microsoft Visual C++ 2015-2019 which was not installed with sketchup 2020 probably.
Why is a question that I cannot answer but it may be worth exploring for those who are more competent than me.
I then launched sketchup 2020 and everything was fine. I uninstalled skp 2019 and Fredos's plugins aren't missing anything now.
Thank you!
0

babak 
 

Re: [Plugin Library] LibFredo6 - v10.0a - 20 Apr 20

Postby fredo6 » Thu Apr 23, 2020 8:44 pm

Sketchup uses an embedded web-browser which comes from Windows and maybe the VC++. So there is an external dependency.

Good to hear that it now works.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.0a - 20 Apr 20

Postby fedser » Fri Apr 24, 2020 2:22 pm

@babak
Just a mystery ... thanks for the solution
but ...
Indeed, if you install both SU2019 and SU2020 everything works fine. But if you remove SU2019, the problem reappears. The problem is not in VC++ 2015-2019 (v14.25.28508), I have this package installed earlier than SU2020.
0

fedser 
 

Re: [Plugin Library] LibFredo6 - v10.1a - 27 Apr 20

Postby fredo6 » Mon Apr 27, 2020 8:59 pm

NEW RELEASE: LibFredo6 v10.1a - 27 Apr 20

LibFredo6 10.1a is a maintenance release
  1. Fixes a bug in the interpolation of camera in parallel projections in Animator
  2. Provide 'eye' icons for Quick Launchers dialogs for Mac

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.1a - 27 Apr 20

Postby WaChT79 » Tue Apr 28, 2020 10:09 am

Fredo6 plugins don't work anymore.
Have a error message on the front page bij starting Sketchup 2020 on Window 10 pro since I load LibFredo6 - v10.1a.
No plugin are available anymore. I have downloading Sketchup 2020 and the Fredo6 plugin again with the same error message as shown below.
I ask for help, thanks.

Error Loading File C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6/top_LibFredo6.rbe
Failed to read RBE/RBS file.
Error Loading File Fredo6_!LibFredo6.rb
Error: #<NameError: uninitialized constant LibFredo6_Loader::LibFredo6>
C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:65:in `process'
C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:72:in `<module:LibFredo6_Loader>'
C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'
Error Loading File Fredo6_FredoSpline.rb
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/Fredo6_!LibFredo6.rb:81:in `-'
0

WaChT79 
 

Re: [Plugin Library] LibFredo6 - v10.1a - 27 Apr 20

Postby fredo6 » Tue Apr 28, 2020 12:13 pm

WaChT79 wrote:Fredo6 plugins don't work anymore.
Have a error message on the front page bij starting Sketchup 2020 on Window 10 pro since I load LibFredo6 - v10.1a.
No plugin are available anymore. I have downloading Sketchup 2020 and the Fredo6 plugin again with the same error message as shown below.

Very strange, because you get the infamous message "Failed to read RBE/RBS file.", which usually comes from a permissions problem arising from the incorrect installation of Sketchup itself (you must Run the installer's exe as Administrator).

Did you try to reinstall Sketchup?
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.1a - 27 Apr 20

Postby WaChT79 » Wed Apr 29, 2020 9:24 am

Very strange, because you get the infamous message "Failed to read RBE/RBS file.", which usually comes from a permissions problem arising from the incorrect installation of Sketchup itself (you must Run the installer's exe as Administrator).

Did you try to reinstall Sketchup?



I reinstall Sketchup 2020 pro again and also Fredo6 Lib with the same result.
0

WaChT79 
 

Re: [Plugin Library] LibFredo6 - v10.1a - 27 Apr 20

Postby TIG » Wed Apr 29, 2020 1:04 pm

For the avoidance of doubt...
SketchUp must be installed in a certain way, otherwise weird permission errors can appear unexpectedly.
You do not need to reinstall - just do a "Repair", as follows...
Here are the steps.

Login to Windows as your normal user-account.
Ensure that SketchUp/Layout are not running.
Find the SketchUp installer's exe file - usually in your Downloads folder ?
Select its icon, right-click > context-menu > "Run as administrator"
When prompted choose "Repair".
When it completes retry SketchUp an see what happens...

Installing in any other way causes issues - e.g. never 'Run' an installer's exe file by double-clicking it, or by logging in as the system administrator - BUT if your normal user-account has admin-powers that is OK, but you must always use "Run as administrator" !

There have been some reports of Fredo's preferences files getting messed up because of them getting incorrect permissions from a bad SketchUp installation, these aren't fixed by the main installer's exe "Repair".
You can delete that hidden folder and it gets recreated when a good SketchUp next runs...
So if your problems persist after you have done a "Repair", then you could try this...

Close SketchUp, find the following folder...
C:\Users\Hugo\AppData\Local\LIBFREDO6_DATA_Dir
Delete the folder and its contents...
Restart SketchUp...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.2a - 29 Apr 20

Postby fredo6 » Wed Apr 29, 2020 1:23 pm

NEW RELEASE: LibFredo6 v10.2a - 29 Apr 20

LibFredo6 10.2a is a maintenance release fixing various issues, for FredoSpline and generic

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.2a - 29 Apr 20

Postby WaChT79 » Wed Apr 29, 2020 3:42 pm

TIG,

Bad news, the error message is always there after doing:

I erase Sketchup from my computer, folders, projects and plugins,
I erase Sketchup also from my downloads,
I redownload Sketchup 2020 Pro from my Sketchup account,
I reinstall Sketchup 2020 Pro via the context-menu as Administrator,
It goes very well and without any problems,
After launching the error message appear on the first page.

Error Loading File C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/Hugo/AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.

As you can see I erased all plugins from Fredo6 without succes.
0

WaChT79 
 

Re: [Plugin Library] LibFredo6 - v10.2a - 29 Apr 20

Postby fredo6 » Wed Apr 29, 2020 3:54 pm

WaChT79 wrote:As you can see I erased all plugins from Fredo6 without succes.

As TIG said, this is not a problem with the plugins (mine or someone else's) but with the installation of Sketchup.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby fredo6 » Wed Apr 29, 2020 4:17 pm

NEW RELEASE: LibFredo6 v10.3a - 29 Apr 20

LibFredo6 10.3a is a maintenance release fixing various issues, for FredoSpline and generic, as well as some side-effects on Curviloft and Curvizard.

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby WaChT79 » Wed Apr 29, 2020 5:32 pm

Thanks for your help.
I will ask it Sketchup.
I am very happy with the plugins from Fredo6 and they give always plain satisfaction.
0

WaChT79 
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby TIG » Wed Apr 29, 2020 5:48 pm

Hugo / Pencil
I'll continue over at SketchUp.com, as it's clearly not an extension issue, because the shipped su_... ones are also failing - strongly indicating a permissions issue...
:shock:
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby craigcclick » Wed Apr 29, 2020 6:37 pm

Trying to install LibFredo6 - v10.3a for the first time, not having installed LibFred06 before. SU Pro/Mac/Mojave. Successfully downloaded, saying it'll open with SU, but I cannot find it anywhere; neither going directly to the Sk'ucation Plug-In Manager, SU/Extension Manager, or ~/Library/Application Support/SU2020/SU/Plugins. I've restarted, quit and restarted several times. Is it my issue or SU?
0

craigcclick 
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby Dave R » Wed Apr 29, 2020 6:47 pm

Craig, extensions aren't opened by SketchUp. They need to be installed. Go to Window>Extension Manager. At the bottom find Install Extension. Click on it, find the downloaded file and install it. Quit out of SketchUp and restart it to make sure it loads correctly. Better, go to Resources at the top of this page, download and install the Sketchucation Plugin Store. Then use it to install extensions from Sketchucation. That will automatically install them without cluttering your Downloads folder and it'll make it easier to keep track of updates.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby TIG » Wed Apr 29, 2020 6:56 pm

craigcclick wrote:Trying to install LibFredo6 - v10.3a for the first time, not having installed LibFred06 before. SU Pro/Mac/Mojave. Successfully downloaded, saying it'll open with SU, but I cannot find it anywhere; neither going directly to the Sk'ucation Plug-In Manager, SU/Extension Manager, or ~/Library/Application Support/SU2020/SU/Plugins. I've restarted, quit and restarted several times. Is it my issue or SU?

As Dave R says [beat me to the draw !]
...
It's your problem...
This all depends on your browser settings on how to deal with downloaded file-types.
It looks like you have set downloaded extension's RBZ files to be opened with SketchUp.
This is completely wrong.
All RBZ downloads should be set to save - usually these end up in your Downloads folder.
You then use the native Extension Manager > Install Extension button ... navigate to/choose the RBZ file and auto-install it.
All of the necessary files/folders are downloaded into the right places without you having to do anything further...
In the case of a 'Lib' you need to restart SketchUp to get everything in sync...
A 'Lib' does nothing on its own.
It's a collection of code that add functionality to other related extensions.
So to get any useful you need to download/install one of Fredo's other extensions, which will then use the appropriate parts of the Lib to do their magic...

If you download the SketchUcation Toolset's RBZ and install that as outlined above, then it creates a menu-entry / toolbar which opens a dialog which lets you browse through all of the [hundreds of] Plugins/Extensions housed at SketchUcation - e.g. Fredo's or mine... - and then one-click auto-install them, without worrying about manually getting the RBZ file at all !
It also has update reminders etc...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby fedser » Thu Apr 30, 2020 12:26 pm

I found a problem with svg in SU2020. Problems were found in the registry. SU2020 does not register entries in EMU IE (as previous versions) why this is not known to me. This prevents fredo6 and SU2020 plugins from using IE resources. In order not to have this problem we need to register SU2020. Here are the keys:
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"sketchup.exe"=dword:00002af8
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"sketchup.exe"=dword:00002af8
0

fedser 
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby fredo6 » Thu Apr 30, 2020 1:40 pm

fedser wrote:I found a problem with svg in SU2020. Problems were found in the registry. SU2020 does not register entries in EMU IE (as previous versions) why this is not known to me. This prevents fredo6 and SU2020 plugins from using IE resources. In order not to have this problem we need to register SU2020. Here are the keys:
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"sketchup.exe"=dword:00002af8
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"sketchup.exe"=dword:00002af8

At least this explains the problem of not loading SVG. Thanks.

It should be th role of the Sketchup installer to do the registration however.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby fedser » Thu Apr 30, 2020 3:34 pm

It should be th role of the Sketchup installer to do the registration however

yes, but the SU2020 installer does not. SU developers may have missed this or it was intended to be. I registered manually, all plugins work fine ...
0

fedser 
 

Re: [Plugin Library] LibFredo6 - v10.3a - 29 Apr 20

Postby Dave R » Thu Apr 30, 2020 3:40 pm

SU2020 does the registration correctly for me on three different computers. Are you certain you installed SketchUp correctly?
1
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v10.3b - 29 Apr 20

Postby fredo6 » Thu Apr 30, 2020 5:20 pm

NEW RELEASE: LibFredo6 v10.3b - 30 Apr 20

LibFredo6 10.3b is a maintenance release for cosmetic adjustments.

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.3b - 29 Apr 20

Postby fedser » Fri May 01, 2020 8:11 am

SU2020 does the registration correctly for me on three different computers. Are you certain you installed SketchUp correctly?

The problem only occurs with a clean installation. If you have installed SU19 or SU19 + SU20 together or are doing an update, then there will be no problem. Keys will already be registered. Maybe my installer is broken, but other users have the same problem. Now there is a solution ...
0

fedser 
 

Re: [Plugin Library] LibFredo6 - v10.4a - 16 May 20

Postby fredo6 » Sat May 16, 2020 9:08 pm

NEW RELEASE: LibFredo6 v10.4a - 16 May 20

LibFredo6 10.4a is a major maintenance release, with bug fixing and cosmetic adjustments, some for Mac OSX.

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.3b - 29 Apr 20

Postby TBoy » Sat May 16, 2020 9:09 pm

Fredo6, there is a tool in your plugin to show load times for plugins called 'Performances'.
Is it possible to track the load times for any plugin - not only yours?
0

TBoy 
 

Re: [Plugin Library] LibFredo6 - v10.3b - 29 Apr 20

Postby fredo6 » Sat May 16, 2020 9:17 pm

TBoy wrote:Fredo6, there is a tool in your plugin to show load times for plugins called 'Performances'.
Is it possible to track the load times for any plugin - not only yours?

General answer is No.

If you use my plugin AdditionalPluginFolders, which allows loading extensions from alternative directories (useful to share plugins between Sketchup versions), then you could see the load time for any plugin loaded, mine and others.

You just need to go to Window > LibFredo6 Settings... > View Trace Log files, and in the dialog box, scroll and expand the item AdditionalPluginFolders. Below an example from my machine. You see that WorkPlane (by TIG) took 26 ms to load.

Trace Log AdditionalPluginFolder.png
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v10.4b - 17 May 20

Postby fredo6 » Sun May 17, 2020 7:49 pm

NEW RELEASE: LibFredo6 v10.4b - 17 May 20

LibFredo6 10.4b is a maintenance release, with bug fixing and cosmetic adjustments, some for Mac OSX and support of FredoTools 4.0a

_______________________________________________________________________________________

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: Nathans, pcoelho71 and 15 guests

Visit our sponsors: