[Plugin] Tools On Surface - v2.4a - 01 Nov 18

Re: [Plugin] Tools On Surface - v1.6a - 06 May 10

Postby TIG » Sat May 08, 2010 9:00 am

Is in in its own folder like this
Capture.PNG
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby fredo6 » Sat May 08, 2010 9:57 pm

New version v1.6b, 8 May 10 available.

It allows to use the replication feature (by double-click) for shapes which are drawn perpendicular to edges.

See small video in main post http://forums.sketchucation.com/viewtopic.php?f=323&t=11212#p76625

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby bagatelo » Sun May 09, 2010 12:10 am

It would be interesting we could draw our own shapes and to save at an own library. Thanks for the great plugins. You are de best. (not the beast :lol: )
0
While the cat's away, the mice will play
User avatar
bagatelo 
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby ken » Mon May 10, 2010 1:18 am

Fredo6 wrote:New version v1.6b, 8 May 10 available.

It allows to use the replication feature (by double-click) for shapes which are drawn perpendicular to edges.

See small video in main post http://forums.sketchucation.com/viewtopic.php?f=323&t=11212#p76625

Fredo


Fredo

I have loaded v1.6b. My make group or component in the contents or edit menu is grayed out. When I change the name of ZLoader__OnSurface.rb to ZLoader__OnSurface.ken, not allowing this plugin to load on start up, the contents and edit menu to make group or components is back.

Nothing the in the ZLoader__OnSurface.rb indicates it has been upgrade to May 8.

And I have update all the other files as required.

Ken
0
Fight like your the third monkey on Noah's Ark gangway.
User avatar
ken 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby fredo6 » Mon May 10, 2010 6:33 am

Ken wrote:Nothing the in the ZLoader__OnSurface.rb indicates it has been upgrade to May 8.

And I have update all the other files as required.

Ken

Can you check the About menu of ToolsOnSurface. It should indicate the version and date.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby ken » Mon May 10, 2010 10:57 am

Fredo6 wrote:
Ken wrote:Nothing the in the ZLoader__OnSurface.rb indicates it has been upgrade to May 8.

And I have update all the other files as required.

Ken

Can you check the About menu of ToolsOnSurface. It should indicate the version and date.

Fredo


Here is the about menu for TOS

Thanks for the quick response

Ken
0
Fight like your the third monkey on Noah's Ark gangway.
User avatar
ken 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby fredo6 » Mon May 10, 2010 12:07 pm

Ken,

On which type of selected geometry do you observe the menu grayout?

If it is on San or on a single group or component, this may be a normal behavior in SU, which assumes you do not need to make a component or group from a single component or group.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby ken » Mon May 10, 2010 1:00 pm

Fredo6 wrote:Ken,

On which type of selected geometry do you observe the menu grayout?

If it is on San or on a single group or component, this may be a normal behavior in SU, which assumes you do not need to make a component or group from a single component or group.

Fredo


I was using a simple rectangle. Selected face and lines, not able to make group or component. Tried again with two rectangles, selected all, not able to group or make component. With ZLoader__OnSurface.rb not loaded, able to group rectangle or rectangles.

Note, the difference in the two screen shots, is ZLoader__OnSurface.rb being allowed to load or not allowed to load.

Ken
0
Fight like your the third monkey on Noah's Ark gangway.
User avatar
ken 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby thomthom » Mon May 10, 2010 1:32 pm

Ken can you enter this into the console:
l=[];ObjectSpace.each_object {|x| l.push x if x.class==UI::Command } ; l.length

Try with it unloaded before right click
Try with it unloaded after right click
Loaded before right click
Loaded after right click
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby ken » Mon May 10, 2010 3:12 pm

Tom


Attached is the required screen shots.

Top is always before right click, bottom is after right click.

Thanks to Fredo and Tom for their help.

Ken
0
Fight like your the third monkey on Noah's Ark gangway.
User avatar
ken 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby thomthom » Mon May 10, 2010 3:17 pm

hm... this appear to be caused by something else then. As the number has not reached 1000.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby fredo6 » Mon May 10, 2010 8:23 pm

Ken,

This bug is very strange.

Would you mind to make the same test with another of my scripts (say FredoScale or Roundcorner). This will help me to determine whether this is specific to ToolsOnSurface or this comes from the shared library LibFredo6. I can't reproduce the bug myself.

Also, on the pictures you posted, I noticed that the cursor is a large white arrow. Are you popping up the context menu from with the SU Selection tool or from within another tool?

Thanks again

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby dermotcoll » Tue May 11, 2010 9:10 am

Fredo / TIG

I was extracting to a different folder - just copied the files to the folder indicated by TIG and it works no problem. Thanks for a great plugin and super help for getting me going with it.
0
When you burn your arse - you gotta sit on the blisters!!
User avatar
dermotcoll 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby fredo6 » Tue May 11, 2010 10:11 am

dermotcoll wrote:Fredo / TIG

I was extracting to a different folder - just copied the files to the folder indicated by TIG and it works no problem. Thanks for a great plugin and super help for getting me going with it.

By the way, do you experience the same problems as Ken does (see his above message) about the menu gray out syndrom?

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6b - 08 May 10

Postby dermotcoll » Thu May 13, 2010 2:42 pm

Fredo

Not as yet but then again I am not as accomplished a modeller as these other guys and probably am not asking the plug in to do any thing too difficult. I use your Fredoscale plugin on a daily basis but rarely use the TOS one. I have tried to replicate the grey menu but have not been able to do so as yet. Sorry for the late reply.
0
When you burn your arse - you gotta sit on the blisters!!
User avatar
dermotcoll 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby fredo6 » Sat May 15, 2010 8:48 am

[Important Upgrade version 1.6c, 15 May 10]

I just realized that in v1.6b, I have introduced a ennoying bug in the inferencing of the tool LineOnSurface.

This is fixed in this new release 1.6c.

See main post for download: viewtopic.php?p=76625#p76625

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby chouaibcl65 » Sun May 16, 2010 12:18 am

thank youuuuuu
0

chouaibcl65 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby keea1111 » Tue May 18, 2010 8:18 pm

HI,

I am trying to get this to install on my new computer and it isn't coming up for me. I have dropped both rb file as well as the tools file into the plugins folder, open sketchup and am not finding it. Is there a companion plug in needed for this, or am I missing something else. thanks so much for the help..Keea
0
KEEA
User avatar
keea1111 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby massimo » Tue May 18, 2010 8:50 pm

Hi Keea, have you installed LibFredo as well? Btw have you read the PDF quickcard (2. installation and configuration)?
0
User avatar
massimo 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby mavie » Tue May 25, 2010 1:06 am

After reading his installation notes and carefully loading all the components for Fredo's great Tools on Surface plugin (about 4 times), I got my error messages down to just this one upon opening SketchUp after install:

Error Loading File Zloader_OnSurface.rb unititialized constant Traductor:Plugin

I reinstalled Zloader (the freshest version, I believe) and have the latest version of his plugin, but I would love to find out what I'm doing wrong. MacBookPro, Snow Leopard, and I cleaned out all the bits of Fredo's older versions, etc.

Thanks in advance for any advice,

Mave
0

mavie 
Premium Member
Premium Member
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby mavie » Tue May 25, 2010 8:41 pm

Okay, yes. Woke up fresh, tried another 2 installs and I'm good to go! Such a cool plugin. Merci bien Fredo!
0

mavie 
Premium Member
Premium Member
 

Please Help to install Tools On Surface - v1.6c - 15 May 10

Postby hgdn » Wed May 26, 2010 3:53 pm

Is anyone please pointing it out for me of what is not right as I have tried a lot of times to install but still not get it? I got files LIBFREDO6_Dir_34, FREDOSCALE_Dir_20, TOS_Dir_16 and 3 rb(s) LibFredo6.rb, ZLoader__FredoScale.rb, ZLoader__OnSurface.rb located in Program Files\Google\Google SketchUp 7-pro\Plugins.. . The Fredoscale is fine and working icons shown but Tools on Surface icon(s) is not and in Preferences I saw it there and I checked that box and restart computer but still not shown. Oh one more thing that I never had installed any of those files before (3 files) so is there any relation of old and new files installed that makes it does not work or any missing things I don't know??? please tell me as I am tired of trying so many times...Thanks! :fecstatic:
0

hgdn 
 

Re: Please Help to install Tools On Surface - v1.6c - 15 May

Postby fredo6 » Wed May 26, 2010 9:20 pm

hgdn wrote:Is anyone please pointing it out for me of what is not right as I have tried a lot of times to install but still not get it? I got files LIBFREDO6_Dir_34, FREDOSCALE_Dir_20, TOS_Dir_16 and 3 rb(s) LibFredo6.rb, ZLoader__FredoScale.rb, ZLoader__OnSurface.rb located in Program Files\Google\Google SketchUp 7-pro\Plugins.. . The Fredoscale is fine and working icons shown but Tools on Surface icon(s) is not and in Preferences I saw it there and I checked that box and restart computer but still not shown. Oh one more thing that I never had installed any of those files before (3 files) so is there any relation of old and new files installed that makes it does not work or any missing things I don't know??? please tell me as I am tired of trying so many times...Thanks! :fecstatic:

Your set up seems OK. You only need these 3 folders and 3 files at the level of the Skethcup Plugin directory.
However, I can't judge if you have other files that would conflict and if the contnet of these folder are right. Please check the documentation, as it gives the footprint.
Also, you do not need to "restart the computer" to enable the plugins. Just restart Sketchup.
Finally, can you check the menu Tools > Fredo6 Collection and see if you have Tools on Surface submenus.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: Finally, I got that Tools On Surface - v1.6c - 15 May

Postby hgdn » Thu May 27, 2010 5:43 am

Hello Fredo,

I am glad it okay now as I deleted/installed it again and it works fine now and I have no idea why! Your design plugin stuffs are truly amazing and provide more choices in different languages around the world...very eager to try it soon!
Thanks for spending time of looking over the problem! :lol:
0

hgdn 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby tmanoso » Sun May 30, 2010 12:12 am

Hey Fredo6,
i recently downloaded this and i cannot get it to work attached is the image of message box. :oops:
0

tmanoso 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby utiler » Tue Jun 01, 2010 3:02 am

Hi Fredo, Just having a bit of a problem with TOS. I'm trying to draw an arc on a curved vertical surface but it seems to be playing up a bit.... see attached short screen movie.

Any ideas?
Thanks in advance.

Andrew
0
purpose/expression/purpose/....
User avatar
utiler 
Top SketchUcator
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby zilvinasz » Mon Jun 21, 2010 11:49 am

:ecstatic: DUDEEE!!!! your just bringin Sketchup alive!!!
Thanks!!!
0

zilvinasz 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby rachmatrf » Tue Jun 22, 2010 8:32 am

YOU'RE THE MAN FREDO!! :berserk: :sketchstatic:
0

rachmatrf 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby Daniel S » Sat Jul 10, 2010 10:41 pm

There is a small problem with the polygon of 3 segments on the red axis working on 2D.
It creates the triangle but in the other direction. On a surface works right.
triangle red axis.gif

Daniel S
0

Daniel S 
 

Re: [Plugin] Tools On Surface - v1.6c - 15 May 10

Postby derweissi » Thu Jul 15, 2010 8:50 am

After installing this great Plugin - I unzipped it in the plugin folder - I only get following message when starting sketchup and can't use it now. Whats wrong ? Did i make a mistake?

Fehler beim Laden der Datei __loader.rb
uninitialized constant TraductorFehler beim Laden der Datei EraserOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei FreehandOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei FreeScale_Common.rb
uninitialized constant FreeScale::T6Fehler beim Laden der Datei FreeScale_Tool.rb
uninitialized constant FreeScale::SU_MAJOR_VERSIONFehler beim Laden der Datei LibOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei LineOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei LoaderOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei OffsetAlgoOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei OffsetOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei PaletteOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei PolylineOnSurface.rb
uninitialized constant SUToolsOnSurface::T6Fehler beim Laden der Datei ShapeOnSurface.rb
uninitialized constant SUToolsOnSurface::T6
0

derweissi 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

cron

Who is online

Users browsing this forum: katmur, lasgcx, nahchetay, Openspaces, pabrahao , planet1111, pratiktaishete, richdps123 and 5 guests

Visit our sponsors: