[Plugin] Tools On Surface - v2.3a - 06 Oct 17

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby nankyo » Wed Jan 21, 2009 4:26 pm

ohh, well, this is what is written there:

when I select face:

Error: #<NoMethodError: undefined method `+' for nil:NilClass>
C:/PROGRA~1/Google/GOOGLE~3/Plugins/MatchboxPlugin/Population.rb:174:in `+'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:617:in `compute_active_loops'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:569:in `construct_contour_loops'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:214:in `check_initial_selection'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:1425:in `activate'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:66:in `select_tool'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:66:in `launch_offset'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/LoaderOnSurface.rb:108:in `manage_command'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/LoaderOnSurface.rb:108:in `call'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/LibTraductor_20.rb:572:in `add_command'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/LibTraductor_20.rb:572:in `call'

--------------------------------------------------
and when I don't select..

Error: #<NoMethodError: undefined method `+' for nil:NilClass>
C:/PROGRA~1/Google/GOOGLE~3/Plugins/MatchboxPlugin/Population.rb:174:in `+'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:617:in `compute_active_loops'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:569:in `construct_contour_loops'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:282:in `virtual_selection'
C:/PROGRA~1/Google/GOOGLE~3/Plugins/TOS_Dir_13/OffsetOnSurface.rb:1656:in `onMouseMove'


I am using SU7 right now, but in 6 i was not function as well....

:bounce: :bounce:
thanks alot
Nankyo
0

nankyo 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby thomthom » Wed Jan 21, 2009 6:28 pm

nanyo: Try removing the MatchboxPlugin. I think I remember reading somewhere that I modified some of the base ruby classes which lead to errors in other plugins. From your errors it appears that it's coming from that plugin.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby nankyo » Wed Jan 21, 2009 10:59 pm

wowo so simple and work ) thanks alo alot
muchisima gracias !!!!
now I can offset, lets party :fro: :fro: :ecstatic: :ecstatic:

thanks thomthom,
next time i will try to read those messages...
Have fun.
0

nankyo 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby skylinerz » Wed Jan 28, 2009 9:31 am

HI, where can i donwnload this script? Sorry a newbie here. Thanks.
0

skylinerz 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby thomthom » Wed Jan 28, 2009 9:31 am

skylinerz wrote:HI, where can i donwnload this script? Sorry a newbie here. Thanks.

At the bottom of the original post. First page on this thread.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby acio » Fri Jan 30, 2009 9:09 am

Thank you so.
0

acio 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby simon le bon » Fri Mar 06, 2009 1:04 am

Hi!
I'm actually working with arc tool (on surface).
May be I have missed something. I would like to remove all the construction points in one operation when the drawing is finished but i don't know how to do..

;-)simon
0
User avatar
simon le bon 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Matt666 » Fri Mar 06, 2009 9:15 am

Just construction points? You can try native Su tool! GO to Edit menu / Delete guides.
You can also copy this code below in the ruby console... It will delete all construction points in the selection.
Code: Select all
Sketchup.active_model.selection.each{|e|e.erase! if e.class==Sketchup::ConstructionPoint}

;)
0
Frenglish at its best !
My scripts

Matt666 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Matt666 » Fri Mar 06, 2009 9:27 am

Hi Fredo!
I suppose you will move your menus in "Fredo collection" in your next TOS update, like freescale plugin ? :?:
That would be cool, and also your push pull plugin!
Sans titre 1.jpg
Excellent plugin, as always, sir! :D Thank you...
0
Frenglish at its best !
My scripts

Matt666 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby simon le bon » Fri Mar 06, 2009 2:47 pm

:-) Matt,
--/ Hope i'm not going too far from this thread /--
Matt666 wrote:Just construction points? You can try native Su tool! GO to Edit menu / Delete guides.
>> good tip: it is something I had forgotten.. > but the construction lines and points, they are all deleted from the overall model. Something we want not to be each time.
Matt666 wrote:You can also copy this code below () in the ruby console... It will delete all construction points in the selection.
This is just the good code: construction lines remain and every construction point inside selection are removed. Would you please make it as a .rb dear Matt? (I'm complet ignorant upon this ). It would be so greatfull!
:-)simon
0
User avatar
simon le bon 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Nathryc » Wed Mar 11, 2009 2:30 am

Thank you, Thank you, Thank you, Fredo!!!! (insert Happy Dance Here!)
At last I can do what I've been trying to do since I first found SketchUp (modeling planets for exterior sci-fi scenes)

This plug-in is MADE of 100% AWESOME!

Nathryc
0

Nathryc 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Roger » Wed Apr 15, 2009 5:54 am

You are the Gustave Eiffel and Pierre Bezier of SketchUp. Merci Beaucoup from the USA!

What will you do to top this achievement?
0

Roger 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Kus » Wed Apr 15, 2009 4:52 pm

Hi there I would like to make some drawings on a sphere. I downloaded the plugin but when I start up SU this comes up
Code: Select all
no such file to load -- /Library/Application Support/Google SketchUp 7/SketchUp/Plugins/BZ_Dir_12/bezierspline_main.rbError Loading File bezierspline.rb
no such file to load -- /Library/Application Support/Google SketchUp 7/SketchUp/Plugins/BZ_Dir_12/bezierspline_main.rb


I downloaded the plugin into /Library/Application Support/Google SketchUp 7/SketchUp/Plugins; and I didn't change the name of the folder, but it is named: ToolsOnSurface_131-1

what should I do??[/quote]
0

Kus 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby fredo6 » Thu Apr 16, 2009 11:07 am

Kus wrote:Hi there I would like to make some drawings on a sphere. I downloaded the plugin but when I start up SU this comes up.

I downloaded the plugin into /Library/Application Support/Google SketchUp 7/SketchUp/Plugins; and I didn't change the name of the folder, but it is named: ToolsOnSurface_131-1

what should I do??

Kus,

Seems you had a problem with the unzip operation.
For Tools on Surface you must have only 2 elements in the Sketchup Plugins folder:
- a small file: ZLoader_OnSurface.rb
- a folder: TOS_Dir_13, with other rb files in it (and some subfolders).

I suggest you check your files and redo the Unzip, with a Select All and then Extract, to make sure your preserve the folder hierarchy when unzipping.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby monkeybss » Mon Apr 27, 2009 7:06 am

Hi,
I seem to have a problem too. I can see the toolbar but the offset doesn't work (Su7,7.0.102470), the line-on surface does, but nothing else seems to work.
I'm not familiar with ruby, but it feels like some setting might be wrong (like a variable in Autocad).

Later..
Just being stupid, I forgot to load in "preferences". Works like a charm!
0
Last edited by monkeybss on Fri May 15, 2009 2:07 pm, edited 2 times in total.

monkeybss 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Steelyjoe_n » Fri May 08, 2009 2:31 pm

Hey, I've followed the quickcards installment guide but upon opening Sketchup it isn't running Tools On Surface, I'm not given any loading error or anything, it simply doesn't run, any help?
0

Steelyjoe_n 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Steelyjoe_n » Fri May 08, 2009 2:35 pm

Steelyjoe_n wrote:Hey, I've followed the quickcards installment guide but upon opening Sketchup it isn't running Tools On Surface, I'm not given any loading error or anything, it simply doesn't run, any help?


Nevermind
I forgot to check it in preferences, thank you for the program anyway :))
0

Steelyjoe_n 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby niarfe » Wed May 13, 2009 2:54 am

Fredo!!! I'm becoming your biggest fan!!!
thanks a lot!
0

niarfe 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Arthaxx » Sun May 31, 2009 5:11 pm

Thanks
0

Arthaxx 
 

[Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby hitman47127 » Fri Jun 05, 2009 7:30 pm

thanksssssssssss a lot, :ecstatic: :ecstatic: :ecstatic:
0

hitman47127 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Efrado » Mon Jul 13, 2009 1:24 am

Hi FREDO ,Thanks a lot for this Magnificent gift. Following the PDF I was traying to reproduce the "section pie" but I could not .How did you do? Thanks "
0

Efrado 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby fredo6 » Mon Jul 13, 2009 7:42 am

Efrado wrote:Hi FREDO ,Thanks a lot for this Magnificent gift. Following the PDF I was traying to reproduce the "section pie" but I could not .How did you do? Thanks "

Use the 'Ring' capability of the TOS shapes. In the VCB, you type an length, posititive or negative' followed by 'x', and you get the shape contour with the specificed offset. This is explained in the doc, in the Shapes section (page 9).
Hope this answers your question.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby Efrado » Mon Jul 13, 2009 1:52 pm

As always your Kindness is OUT OF DOUBT ----PRICELESS-----Thank You
0

Efrado 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby mrljfr1 » Sat Jul 18, 2009 12:50 pm

Thanks,what a great work!
0

mrljfr1 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby lorca » Sun Aug 30, 2009 5:29 pm

Am I doing something wrong? I place CadFather icons in the TOS v13 folder but I still get Fredo icons. I don't mind really but I wonder what is happening.
0

lorca 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby fredo6 » Sun Aug 30, 2009 5:37 pm

lorca wrote:Am I doing something wrong? I place CadFather icons in the TOS v13 folder but I still get Fredo icons. I don't mind really but I wonder what is happening.

The folder is named TOS_Dir_13. I guess this is what you mean.
I also assume that:
- you unzipped correctly the CadFather icons into the folder (can you check the right files are there)
- you restarted Sketchup
- if you use both SU6 and SU7, you did not mix up the file copy.

Otherwise, this looks strange. You can always delete all the png files in the folder and replace them by CadFather's files.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby lorca » Sun Aug 30, 2009 5:54 pm

Fredo6 wrote:
lorca wrote:Am I doing something wrong? I place CadFather icons in the TOS v13 folder but I still get Fredo icons. I don't mind really but I wonder what is happening.

The folder is named TOS_Dir_13. I guess this is what you mean.
I also assume that:
- you unzipped correctly the CadFather icons into the folder (can you check the right files are there)
- you restarted Sketchup
- if you use both SU6 and SU7, you did not mix up the file copy.

Otherwise, this looks strange. You can always delete all the png files in the folder and replace them by CadFather's files.

Fredo


I extracted the Cadfather icons into the TOS_Dir_13. I deleted your icons to be sure I restarted sketchup but I still get your icons.
0

lorca 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby fredo6 » Sun Aug 30, 2009 6:16 pm

lorca wrote:I extracted the Cadfather icons into the TOS_Dir_13. I deleted your icons to be sure I restarted sketchup but I still get your icons.

Maybe you still run TOS 1.2.
Can you check the file ZLoader__onSurface.rb to verify that it contains the correct reference to TOS_Dir_13 (alternately, reinstall the plugin, making sure you overwrite all files, including ZLoader__onSurface.rb).
Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby lorca » Sun Aug 30, 2009 8:01 pm

Fredo6 wrote:Maybe you still run TOS 1.2.
Can you check the file ZLoader__onSurface.rb to verify that it contains the correct reference to TOS_Dir_13 (alternately, reinstall the plugin, making sure you overwrite all files, including ZLoader__onSurface.rb).
Fredo


I remember that a week ago I installed Offset On Surface version 1.0. Then I installed TOS version 1.1(That one has the toolbar that I want to get rid of) I eliminated both plugins before installing v1.3 except for LibTraductor.rb. Btw, the new icons overwrote yours but there was still some old icons of yours leftover.
0

lorca 
 

Re: [Plugin] Tools On Surface - v1.3 (more shapes, inference)

Postby lorca » Mon Aug 31, 2009 4:58 am

Fredo, I noticed something else. I have SU v7 and I have this other plugin with a SU example. This example file is of SU v6.4 and to my surprise I can see CadFather icons there! But not in my SU v7.


UPDATE
-----------------
Fredo, I uninstalled all the plugins that I downloaded to see if there was a conflict. I reinstalled your plugin first with CadFather icons and voila it worked!! So, it seems that there was a conflict with another plugin. I will go ahead and reinstall one by one the rest of the plugins too see which one is the culprit. I'll let you know.

UPDATE #2
--------------
Fredo, the second plugin I reinstalled was your FredoScale 2.0g and now I get a warning message in SU:

undefined method `[]' for nil:NilClassError Loading File ZLoader__OnSurface.rb
undefined method `[]' for nil:NilClass
0

lorca 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: Gromozeka74 and 13 guests

Visit our sponsors: