[Plugin] LordOfTheToolbars - v1.5a - 17 Sep 21

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby PedroE » Sat Jul 10, 2021 2:35 pm

Error with custom icons, this appears when you try to put one. The accept button that is at the bottom of the window also disappears because the icon path is very long and increases the black box.
0

PedroE 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Sat Jul 10, 2021 5:48 pm

Which image file did you select? There seems to be a problem with this file.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby PedroE » Sun Jul 11, 2021 11:54 pm

I have loaded several png and the same thing happened
0

PedroE 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Mon Jul 12, 2021 12:00 am

Could you post here one of the PNG.

Also, what do you see in the Icon Selector dialog box (the panel normally shows the latest PNG loaded)?

LOTT - Icon selector.png
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby PedroE » Mon Jul 12, 2021 8:55 am

appear this way
0

PedroE 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Mon Jul 12, 2021 9:02 am

There may be special characters in the path to icon files.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Wed Jul 14, 2021 7:32 am

Fredo, would it be possible please to substitute the toolbar's title bars (so much screen space wasted) to a tiny vertical element like this:
1

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Wed Jul 14, 2021 4:19 pm

Some bugs:
(*) Episodically I have constant always-on-top phantom icons (of different tools used earlier). I can get rid of it by running Master Toobar Manager or simply restarting the program.
https://drive.google.com/file/d/1DiAjP9D0IDQeR059icj7HmwuY9xgOuU_/view?usp=sharing
(*) Icons get lost when pulling toolbar edge inwards:
https://drive.google.com/file/d/11QykXGIugJNmg6IAOv9IFcxI0MHtEbe7/view?usp=sharing
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Wed Jul 14, 2021 6:23 pm

Did you move icons from Palettes with the Shift key pressed?

I think I have seen that in rare occasion. I'll have a look and fix it.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Thu Jul 15, 2021 8:22 am

rv1974 wrote:Some bugs:
(*) Icons get lost when pulling toolbar edge inwards:
https://drive.google.com/file/d/11QykXGIugJNmg6IAOv9IFcxI0MHtEbe7/view?usp=sharing

It seems you have a Line-break between the icons of
- the LOTT Favorite Manager (with a red heart)
- and the first icon of JointPushPull.
Just right-click on one of the icons and select "Remove line-break before (or after).
Icons are not lost. Mouse wheel will make them show.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Thu Jul 15, 2021 10:10 am

exactly! thanks a ton.
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby jdgarvin » Fri Jul 16, 2021 4:02 pm

Here is the output from the > G6.monitor_print command:

Monitor 1: [0, 0, 1650, 1025] - [0, 0, 1650, 1050]
Monitor 2: [0, 1050, 1600, 875] - [0, 1050, 1600, 900]
UI Scale factor: 1.0
Virtual Screen: [1650, 1950]

MacBook Pro 16" 2019, 2.4 GHz 8-Core Intel Core i9, 32 GB RAM, Radeon Pro 5500M 8 GB.
0
Last edited by jdgarvin on Wed Jul 21, 2021 4:03 pm, edited 1 time in total.

jdgarvin 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Sat Jul 17, 2021 12:19 pm

@jdgarvin,

I don't have Big Sur on my Mac, and this works fine in Catalina on my laptop MacBook Pro.

Could you more explicit on the drag & drop 'disabled'. Where are you dragging from and to which target.

For multi-screen, could you open the Ruby console and type (or copy/paste) the following command:

G6.monitor_print
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby PedroE » Mon Jul 19, 2021 5:10 pm

Problems with the reaction of the popup windows through shortcuts, it seems that the focus of the main sketchup window is lost, then by selecting the main sketchup window with the left click it reacts again normally.
0

PedroE 
 

PROBLEM

Postby designerbursa » Fri Jul 30, 2021 10:39 am

When I go full screen, the status text bar at the bottom disappears.
0
User avatar
designerbursa 
 

Re: PROBLEM

Postby fredo6 » Fri Jul 30, 2021 11:50 am

designerbursa wrote:When I go full screen, the status text bar at the bottom disappears.

This should be fixed in the latest version of LOTT.

To make the status text bar reappear
  • Open the Ruby Console
  • type (or copy/paste) the following command: Sketchup.send_action 59393 and press Enter

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby ltchest » Thu Aug 19, 2021 4:38 am

Great plugin. Only trouble i have is that it never remembers the location of the toolbar. Every time i open sketchup i have to move the toolbar to the location that i want.
Also, it does not seem to recognise Vray.
0

ltchest 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Thu Aug 19, 2021 10:53 am

ltchest wrote:Great plugin. Only trouble i have is that it never remembers the location of the toolbar. Every time i open sketchup i have to move the toolbar to the location that i want.
Also, it does not seem to recognise Vray.

What do you mean by 'toolbar'?

- favorite palette?
LOTT Favorite palette.png


- Sketchup regular toolbar?
LOTT Sketchup toolbar.png


For VRay, which version do you have?
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby JustinTSE » Thu Aug 19, 2021 12:22 pm

At some point I closed the command stripe at the top of the page and I can't seem to get it back. I've updated LibFredo, unloaded and reloaded the extension, clicked all the buttons, etc.

In addition, when I click the quick command finder button it's not doing anything.

I'm on LibFredo 11.9C. I'm sure this is something simple that I'm missing

Thanks so much for your work on this!
0
User avatar
JustinTSE 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Thu Aug 19, 2021 1:09 pm

Justin,

Normally, the only way to discard the Vignette Stripe is to use the menu LordOfTheToolbars > Toggle Visibility of the Vignette Stripe, which is also a way to restore it. Is it what you did?

If ever it is off-screen, use menu LordOfTheToolbars > Reset Vignette Stripe Position.

For the Command Finder, it could also be off-screen or there is a bug.

I suggest you keep the Ruby console opened to see if there are errors showing.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Thu Aug 19, 2021 2:41 pm

Regarding this Vignette Stripe.. it causes lot of troubles - it tends to get lost (because I sporadically drag SU windows from one monitor to another and use the switch to jump to another PC with the same monitors). Recovering from preferences file and Show Vignette Stripe command don't help. Luckily LordOfTheToolbars > Reset Vignette Stripe Position works, but its not ideal solution.
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Thu Aug 19, 2021 4:24 pm

rv1974 wrote:Regarding this Vignette Stripe.. it causes lot of troubles - it tends to get lost (because I sporadically drag SU windows from one monitor to another and use the switch to jump to another PC with the same monitors). Recovering from preferences file and Show Vignette Stripe command don't help. Luckily LordOfTheToolbars > Reset Vignette Stripe Position works, but its not ideal solution.

When you move the Sketchup window, do you see the Vignette Stripe and the palettes moving along the Sketchup window?
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Thu Aug 19, 2021 7:05 pm

I'll check later, currently machines are busy with tons of renderings.
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby JustinTSE » Fri Aug 20, 2021 12:13 pm

fredo6 wrote:
If ever it is off-screen, use menu LordOfTheToolbars > Reset Vignette Stripe Position.



Perfect! This is what I needed.

I was looking for the menu in the wrong place - I suspected some sort of user error :fro:

Thanks!
0
User avatar
JustinTSE 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby JustinTSE » Fri Aug 20, 2021 12:41 pm

So...sorry to bug you again. Whenever I click the quick command finder button in the vignette stripe, nothing happens on the page. In the ruby console I get the following error.

Error: #<RangeError: invalid codepoint 0xD83C in UTF-8>
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5283:in `all_menus'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5283:in `menu_mapping'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5359:in `menu_structured_list'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsfinddialog.rbe:215:in `prepare_data'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsfinddialog.rbe:134:in `dialog_invoke'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsmanager.rbe:5266:in `minifind_invoke'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsvignettedialog.rbe:859:in `minifind_invoke'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsvignettedialog.rbe:590:in `dialog_callback_exec'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsvignettedialog.rbe:565:in `dialog_callback'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2297:in `call'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2297:in `master_callback'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2086:in `j_action'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2045:in `j_callback'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2031:in `block in j_dispatch'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2023:in `each'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:2023:in `j_dispatch'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6chromiumwdlg.rbe:1332:in `block in create_dialog'


I'm currently running LibFredo 11.9c and LordofTheToolbars 1.4d.

If I click the quick command finder in the toolbar on the screen, I get this error and it hides the vignette stripe

Error: #<RangeError: invalid codepoint 0xD83C in UTF-8>
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5283:in `all_menus'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5283:in `menu_mapping'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/body_lib6g6.rbe:5359:in `menu_structured_list'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsfinddialog.rbe:215:in `prepare_data'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsfinddialog.rbe:134:in `dialog_invoke'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/lordofthetoolbarsmanager.rbe:5266:in `minifind_invoke'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/bootstrap_lordofthetoolbars.rbe:351:in `launch'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/bootstrap_lordofthetoolbars.rbe:303:in `action__mapping'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:129:in `call'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:129:in `launch_action'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:227:in `launch_action'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/bootstrap_lordofthetoolbars.rbe:249:in `launch_action'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/bootstrap_lordofthetoolbars.rbe:285:in `block in declare_command'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:1382:in `command_invoke'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:1363:in `block (2 levels) in build_config_commands'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/fredo6_!libfredo6/lib6traductor.rbe:1377:in `block in add_command'
c:/users/justi/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/!!fredo6_lordofthetoolbars/controller_lordofthetoolbars.rbe:142:in `block in new'

Thanks!
0
User avatar
JustinTSE 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby fredo6 » Fri Aug 20, 2021 1:33 pm

@Justin,

Looks like there a plugin with an exotic menu entry (Chinese or so) and this is creating an error.

I'll see if I can either solve the problem or protect the code against this type of error.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Sat Aug 21, 2021 9:02 am

Well it appears that LOTT hates when SU window is dragged from one monitor to another.
*) The Vignette Palette (VP) completely disappears. 'Toggle VP visibility' and reset VP position' commands sometimes help sometimes don't. Pop up VP command works consistently well. Typically restarting SU restores UI order, but its kind of so-so solution.
*) If I have some locked favorite toolbar(s) and VP logically I'd expect them to be moved with SU window (=glued), now it's not happening.
*) the location of locked toolbars is messed when SU window come back to it's original place.
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby rv1974 » Wed Aug 25, 2021 12:08 pm

Another observation (in complex files): opened command search (CS) window causes micro lags in navigation and triple click (to select connected edges) work inconsistently. Everything gets back to normal after CS is closed.
0

rv1974 
 

Re: [Plugin] LordOfTheToolbars - v1.4d - 10 Jul 21

Postby ltchest » Mon Sep 13, 2021 1:37 am

Hello - I was referring to the vignette bar (pic attached / didnt realise what it was called before :). I am trying to keep this above the main toolbar space so it doesnt take up any screen space. BUT, every time i launch sketchup i have to move it back to where i want it. Is there a way to make this stay in position ? For VRAY, i am using 5.10.06. It does'nt make any difference where i position it on the screen, it always reverts back to the same place on my second monitor (which is not where i need it). I tried the option to lock it in position, but it makes no difference in my case.
thanks for looking into it !

fredo6 wrote:
ltchest wrote:Great plugin. Only trouble i have is that it never remembers the location of the toolbar. Every time i open sketchup i have to move the toolbar to the location that i want.
Also, it does not seem to recognise Vray.

What do you mean by 'toolbar'?

- favorite palette?
LOTT Favorite palette.png


- Sketchup regular toolbar?
LOTT Sketchup toolbar.png


For VRay, which version do you have?
0

ltchest 
 

Re: [Plugin] LordOfTheToolbars - v1.5a - 17 Sep 21

Postby fredo6 » Fri Sep 17, 2021 11:52 am

NEW RELEASE: LordOfTheToolbars v1.5a - 17 Sep 21

Requirements
  • LibFredo6: v12.0a or above
  • Sketchup version: SU2017 and above

LordOfTheToolbars 1.4a is a major release
  • Rework of the import to be more explicit on what will be changed in the configuration based on a Import Summary Dialog
  • Automatic synchronization of configuration between multiple instances of Sketchup (Windows)
  • Compact mode for palette, without titlebar (Windows only)
  • Double-space to recall the last command (option in Default Parmeters)
  • Double Click in a palette to close it
  • Bug fixing and adjustments

LOTT Palette compact.png


LOTT - Import summary.png


-----------------------------------------

Home Page of LordOfTheToolbars for information and Download.

Main post of this LordOfTheToolbars thread.
0
Last edited by fredo6 on Fri Sep 17, 2021 1:17 pm, edited 1 time in total.
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: No registered users and 19 guests

Visit our sponsors: