[Plugin Library] LibFredo6 - v7.7e - 19 Sep 17

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby Retnix » Mon Feb 27, 2017 10:34 am

fredo6 wrote:IMPORTANT: Please upgrade to LibFredo6 v7.5b or higher if you run FredoScale
Note also that v7.5b fixes bugs in LibFredo6 v7.5a (in Quick launchers) and is required to run Animator 1.5a


# Permission to use this software for any purpose and without fee is hereby granted
# Distribution of this software for any purpose is subject to:
# - the expressed, written consent of the author
# - the inclusion of the present copyright notice in all copies.




LibFredo6 is a shared library used by some of my plugins. It is NOT a standalone plugin. Plugins currently using LibFredo6 are:

You need to install it and respect the versions required by the Plugins, the higher, the better. The current version level of LibFredo6 is 7.5 (so 75 in integer form). I maintain backward compatibility so that plugins requiring an older version of LibFredo6 should work with a new version.

IMPORTANT: if you just install LibFredo6 without any of the plugins above, you will see no new toolbar in Sketchup but an entry "LibFredo6 Settings.." in the Windows menu.

I also suggest that you install AdditionalPluginFolders to have more control on errors when Sketchup loads plugins (or if you wish to put plugins in an alternate directory).

Note: As of version 7.2, LibFredo6 is encrypted.


LibFredo6 User Manual - English - v5.2.pdf


The translated manuals below are also available, but not yet updated for the new naming conventions.
LibFredo6 Manual Utilisateur - French - v4.0.pdf
(Thanks to Jean Franco for Translation)[/size]
LibFredo6 User Manual - Chinese-zh-cn v4.0.pdf
(Thanks to guanjin)


Note: If you drop the PDF doc files into the Plugins directory, you can access them from within Sketchup via the menu.

  • Sketchup versions: 6 and above (Free, Make and Pro)
  • Platform: Windows and Mac OSX
  • Language: English, French, Spanish (Spain and Latin America), Chinese, + partial Italian, Japanese, Korean, German (thanks to all kind translators). Thanks to Christophe Plassais for the French user manual. Thanks to guanjin for the Chinese user manual.
  • Menus: by default, it is installed in Window > LibFredo6 Settings…
  • Icon toolbar: NO Toolbar



There are now multiple ways to install scripts
- SCF Plugin Store (SU8, SU13, SU14 and SU15) - recommended method, including for installations in an alternate Plugins directory
- Unzip (all SU versions) from an archive file
- Extension Manager with RBZ files (SU8 and above)

If you run SU8, SU13, SU14 or SU15, the strongly recommended installation method is to Autoinstall with the SCF Plugin Store tool.

Otherwise, you can download the LibFredo6 rbz file from the Plugin Store page for LibFredo6.

For SU6 and SU7 users, download the rbz file from the plugin store page, and change its extension from .rbz to .zip
Then:
1) Open the zip archive
2) Select All (Ctrl A)
3) Extract into the Sketchup Plugin Directory
4) Answer YES to OVERWRITE all existing files if any
5) Make sure you get the correct footprint (one rb file and one folder)


Whatever way you install, you must end up with the following footprint:
LibFredo6 - footprint.png


The standard SU Plugins root directories are:
Windows SU8: C:\Program Files\Google\Google SketchUp 8\Plugins
Windows SU13: C:\Program Files\SketchUp\SketchUp 2013/Plugins
Windows SU14: C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp\Plugins
Windows SU15: C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins

Mac SU8: Macintosh HD/Library/Application Support/Google SketchUp 8/SketchUp/Plugins
Mac SU13: ~/Library/Application Support/SketchUp 2013/SketchUp/Plugins
Mac SU14: ~/Library/Application Support/SketchUp 2014/SketchUp/Plugins
Mac SU15: ~/Library/Application Support/SketchUp 2015/SketchUp/Plugins

CAUTION: NEVER rename or move files from their folders. If you are unsure of your unzip operation, do it in a neutral folder and check that you reconstruct the right footprint. Then transfer the folders and files to the SU Plugin Directory.

LibFredo6 can be installed in any directory, not just the Sketchup standard directory. Doing so will allow you to automatically share the same plugin version if you have several versions of Sketchup installed, and to avoid the security right restrictions for copying files to the system folders on Windows (like C:\program files). Just always make sure that my plugin folders (like Fredo_RoundCorner_24) are located in the same place as LibFredo6.rb.
See !AdditionalPluginFolders for more information.

Deleting old files and folders: Once you have installed, it is a good idea to clean up your Plugins directory. Use the dialogbox in the menu Windows > LibFredo6 Settings...> Purge Obsolete Files.
Purge Obsolete Files.png


Support of RETINA screens: as of LibFredo6 5.6, there is a limited support for Retina screens. The flag should be set in the Default Parameters dialog box of LibFredo6.
Retina and LibFredo6 5.png

When set, the size of the Button Palettes, Visual Progression bars and some custom tooltips will be enlarged by a factor 2. However, the font size won't be changed, as this is not under the control of the Sketchup API.


No video for the time being


LibFredo6 is now in charge of loading my plugins.
LibFredo6 takes care, among others, of enriching the plugins with a few capabilities:
  • Default parameters
  • Language translation via external files (please, read the doc if you wish to contribute)
  • Extra information and external links available in the “About…” box and menus
  • Check Plugins for Update, with live connection to the Web
  • Trace logging
  • Purge of older versions of plugin files
LibFredo6 installs a submenu “LibFredo6 Settings…” in the Sketchup Windows menu. It contains a command to specify the language preferences, as well as several utilities for plugin maintenance. You can also set a few default parameters (inference colors) and access the documentation (as a PDF).

Menu LibFredo6.jpg




LibFredo6 7.5b – 13 Feb 17: Fixes in Quick Launchers
Here is the Start post for LibFredo6 7.5b

LibFredo6 7.5a – 12 Feb 17: Release for Animator 1.5a + cosmetic changes and bug fixing
Here is the Start post for LibFredo6 7.5a

LibFredo6 7.4c – 16 Jan 17: corrections and support SUClock
Here is the Start post for LibFredo6 7.4c

LibFredo6 7.4a – 14 Jan 17: Bug fixes and small evolutions
Here is the Start post for LibFredo6 7.4a

LibFredo6 7.3b – 02 Jan 17: Release re-fixing major bugs in FredoScale for SU2017
Here is the Start post for LibFredo6 7.3b

LibFredo6 7.3a – 24 Dec 16: Release fixing major bugs in FredoScale for SU2017
Here is the Start post for LibFredo6 7.3a

LibFredo6 7.2h – 24 Nov 16: Release fixing major bugs in Animator
Here is the Start post for LibFredo6 7.2h

LibFredo6 7.2g – 20 Nov 16: Release fixing major bugs in Animator (Orbiting and Screw)
Here is the Start post for LibFredo6 7.2g

LibFredo6 7.2e – 15 Nov 16: Release fixing some issues signaled, impacting Curvizard and Curviloft (due to a bug in G6)
Here is the Start post for LibFredo6 7.2e

LibFredo6 7.2d – 31 Oct 16: Release fixing major issues preventing proper load of LibFredo6 for SU versions < 2014
Here is the Start post for LibFredo6 7.2d

LibFredo6 7.2a – 20 Oct 16: Release for Animator
Here is the Start post for LibFredo6 7.2a

LibFredo6 6.9b – 13 Nov 15: Maintenance release
Here is the Start post for LibFredo6 6.9b

LibFredo6 6.8c – 16 Jul 15: Fix a blocking bug in FredoTools::Convexify
Here is the Start post for LibFredo6 6.8c

LibFredo6 6.8b – 09 Jul 15: Major release for RoundCorner 3.0 and FredoTools 2.8 (ReportLabelArea and SolidVoume)
Here is the Start post for LibFredo6 6.8b

LibFredo6 6.7c – 23 Mar 15: remove noisy traces at startup of Sketchup (second trial)
Here is the Start post for LibFredo6 6.7a

LibFredo6 6.7b – 22 Mar 15: remove noisy traces at startup of Sketchup
Here is the Start post for LibFredo6 6.7a

LibFredo6 6.7a – 25 Feb 15: major release for FredoTools::AutoReverseFaces and FredoTools::Convexify in FredoTools 2.6
Here is the Start post for LibFredo6 6.7a

LibFredo6 6.6b – 18 Jan 15: Some bug fixing in some FredoTools plugins
Here is the Start post for LibFredo6 6.6b

LibFredo6 6.6a – 10 Jan 15: Release for FredoTools::ElementStats 1.0a (Statistics about entities in the model)
Here is the Start post for LibFredo6 6.6a

LibFredo6 6.5a – 30 Dec 14: Release for TopoShaper 2.0 (Terrain from Cloud of Points)
Here is the Start post for LibFredo6 6.5a

LibFredo6 6.4a – 17 Nov 14: Release for AngleInspector, part of FredoTools v2.4
Here is the Start post for LibFredo6 6.4a

LibFredo6 6.3a – 19 Oct 14: Release for support of non-ascci usernames in SU14
Here is the Start post for LibFredo6 6.3a

LibFredo6 6.2a – 12 Oct 14: Release for EdgeInspector 1.2 and various fixes, including installation with non-ascii usernames
Here is the Start post for LibFredo6 6.2a

LibFredo6 6.1b – 22 Sep 14: Republishing due to a possible issue with encoding of main rb file
Here is the Start post for LibFredo6 6.1b

LibFredo6 6.1a – 21 Sep 14: Release for VisuHole 1.0
Here is the Start post for LibFredo6 6.1a

LibFredo6 6.0b – 16 Jul 14: Release for the support of Section Planes in MoveAlong 1.2 and DrawAlong 1.1.
Here is the Start post for LibFredo6 6.0b

LibFredo6 6.0a – 18 Jun 14: Release for FredoTools 2.0a with MoveAlong 1.2 and DrawAlong 1.1, with fixes and new functions
Here is the Start post for LibFredo6 6.0a

LibFredo6 5.9b – 17 May 14: Release for FredoTools 1.9a with MoveAlong 1.1 and DrawAlong 1.0, with a fix for input of architectural units in VCB
Here is the Start post for LibFredo6 5.9b

LibFredo6 5.9a – 15 May 14: Release for FredoTools 1.9a with MoveAlong 1.1 and DrawAlong 1.0.
Here is the Start post for LibFredo6 5.9a

LibFredo6 5.8c – 17 Apr 14: Release for FredoTools 1.8c and MoveAlong 1.0c.
Here is the Start post for LibFredo6 5.8c

LibFredo6 5.7a – 15 Feb 14: Release for FredoTools 1.7 and EdgeInspector 1.1a.
Here is the Start post for LibFredo6 5.7a

LibFredo6 5.6a – 03 Feb 14: Release Curvizard 1.6 and other bug fixing.
Here is the Start post for LibFredo6 5.6a


LibFredo6 5.5g – 24 Jan 14: Release mainly for EdgeInspector 1.0 .
Here is the Start post for LibFredo6 5.5g

LibFredo6 5.4b – 08 Nov 13: Release mainly for TopoShaper 1.1 (for Altitude Editor) and future Sketchup compatibility - with some bug fixing.
Here is the Release post.

LibFredo6 5.3h – 29 Oct 13: Release mainly for JointPushPull 3.0 - Interactive Edition and future Sketchup compatibility - with some bug fixing.
Here is the Release post.

LibFredo6 5.3g – 27 Oct 13: Release mainly for JointPushPull 3.0 - Interactive Edition and future Sketchup compatibility

LibFredo6 5.2a – 30 Aug 13: Same as 5.1 but implements a change of name for the top file (Fredo6_!LibFredo6.rb instead of LibFredo6.rb). Here is the Release start post.

LibFredo6 5.1c – 22 Aug 13: Same as 5.1a but fixes a wrong publishing of 5.1b

LibFredo6 5.1b – 22 Aug 13: Same as 5.1a but fixes a bug preventing Check For Update to display

LibFredo6 5.1a – 22 Aug 13: Release introducing a new naming convention for files and folders (again), to comply with the Extension Warehouse.
Here is the Release start post.

LibFredo6 5.0c – 06 Jul 13: Major release introducing a new naming convention for files and folders.
Here is the Release start post.
Here are the corresponding archives, just in case:


LibFredo6 4.9c – 20 May 13: Technical release still related to issues on Mac platforms.
LibFredo6 4.9b – 19 May 13: Technical release related to issues on Mac platforms.
Here is the Release start post.


LibFredo6 4.9a – 18 May 13: Release for Curvizard 1.2 with various fixes.

LibFredo6 4.8a – 25 Apr 13: Release for TopoShaper.
Here is the Release start post.

LibFredo6 4.7c – 09 Apr 13: Minor update related to a bug in Sketchup versioning.

LibFredo6 4.7a – 03 Oct 12: Release for Curvizard 1.1

LibFredo6 4.6e – 03 Oct 12: Minor release to fix a problem in Check for Updates, due to change of URL scheme of the new Sketchucation web site. Version 4.6d had a problem.

LibFredo6 4.6d – 03 Oct 12: Minor release to fix a problem in Check for Updates, due to change of URL scheme of the new Sketchucation web site.

LibFredo6 4.6c – 11 Jul 12: Major release for Curvizard

LibFredo6 4.5a – 08 May 12:
LibFredo6 4.4m – 14 Apr 12: Small update for ThruPaint adjustments. Integration of the Chinese (thanks to guanjin) and two Spanish translations (thanks to Defisto and Oxer)

LibFredo6 4.4j – 11 Apr 12: Release for ThruPaint

LibFredo6 4.3c – 31 Jan 12: fixed a small issue with environment variables not properly set on some Mac configuration.

LibFredo6 4.3b – 22 Dec 11: fixed a bug in the display of numeric buttons in Palettes (invisible in Curviloft) and added the updated Spanish translation (many thanks to Defisto).

LibFredo6 4.3a – 19 Dec 11: This release is necessary for FredoTools 1.0.

LibFredo6 4.2a – 16 Sep 11: This release finally addresses the issues of security with Webdialogs on Safari 5.0.6 and higher, as well as a few other bug fixing.

LibFredo6 4.1a – 11 Sep 11: This release was supposed to solve the issues with Webdialogs on Safari 5.0.6 and higher, but did not really.

LibFredo6 4.0a – 23 Aug 11: major technical release. LibFredo6 is responsible for the loading of my plugins (no more use of ZLoader__xx.rb files). This should minimize errors at installation.
Version 4.0 also includes some utilities for plugin maintenance (Purge obsolete files, performance at load time, trace logging)
See Release Notes for details.

LibFredo6 3.7c – 07 Jun 11: minor maintenance release (issues in Check for Update). It also includes an update to Italian translation by COSEDIMARCO and Spanish translation by Defisto

LibFredo6 3.7b – 22 Apr 11: This includes a small fix to avoid double loading of LibFredo6 in all situations

LibFredo6 3.7a – 17 Apr 11: This release includes the Check Plugins for Update feature, as well as some fixes in the Web dialogs. It is also required for SUClock 1.1

LibFredo6 3.6b – 13 Jan 11: This release is mainly to support Curviloft 1.1 and fix a few issues with SU8. It also includes the support of a two-phase loading mechanism for some of my scripts.
Note: if you downloaded 3.6a, please upgrade to 3.6b or higher because there was a small bug in the Skinning for Curviloft.

LibFredo6 3.4c – 06 May 10: Stable version
0

Retnix 
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby OneDollarWilliam » Mon Feb 27, 2017 5:07 pm

Howdy! New Fredo user here, running SU2017. I loaded up Lib, Tools, and Scale, and didn't get any toolbars, so I restarted SU and I get this lovely block of errors:

Code: Select all
Error Loading File C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6/top_LibFredo6.rbe
Failed to read RBE/RBS file.
Error Loading File Fredo6_!LibFredo6.rb
Error: #<NameError: uninitialized constant LibFredo6_Loader::LibFredo6>
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:63:in `process'
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:70:in `<module:LibFredo6_Loader>'
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:28:in `<top (required)>'
Error Loading File Fredo6_FredoScale.rb
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `-'
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `<top (required)>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoScale.rb:25:in `<top (required)>'
Error Loading File Fredo6_FredoTools.rb
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `-'
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `<top (required)>'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/PROGRA~1/SketchUp/SKETCH~1/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoTools.rb:29:in `<top (required)>'


I don't know if it's related, but I've been getting errors loading the default plugins since the 16 -> 17 update:

Code: Select all
Error Loading File C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/atgw/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.


In trying to fix the problem with the default plugins I did a clean sweep of my SU files and cleaned the registry entries with Revo to no success. Any suggestions or advice would be appreciated.
0

OneDollarWilliam 
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby TIG » Tue Feb 28, 2017 12:52 pm

I assume you are installing these extensions from the latest RBZ archives using the Extension Manager or SketchUcation's ExtensionStore³ ?

Before Fredo replies can you look in the Extension Manager and see that the LibFredo6 is activated, and of course that the related tool[s] are also activated.

Then restart SketchUp...

The menu items and toolbars should be available for use.
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby bflmpsvz » Wed Mar 01, 2017 1:49 pm

bflmpsvz wrote:Hi,
how to uninstall the Fredo6_!LibFredo6 ?
When installed, SU says during loading:

Error Loading File Fredo6_!LibFredo6.rb
wrong number of arguments (1 for 0)

(Windows XP, SU 8.0.16846 , LibFredo6 4.8a - 25 Apr 13, unsuccessfully installed LibFredo6_v7.5b.rbz)


It seems to me that SU while loading tries to load all .rb files in Plugin directory, even when I changed its extensions...?
When I really deleted all .rb and directories related to Fredo6, then I installed new ones, all works fine.

(Windows XP, SU 8.0.16846 , LibFredo6 7.5b - 13 Feb 17, FredoScale 3.0a 14 Jan 17, MSIE 8)
But Animator_v1.5a does not work with this constellation :-(
0

bflmpsvz 
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby McFersson » Thu Mar 16, 2017 8:34 am

Where is button for downloading?
Can't see it)
0
User avatar
McFersson 
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby Dave R » Thu Mar 16, 2017 10:50 am

McFersson wrote:Where is button for downloading?
Can't see it)


You can't see this section when you scroll down a little in the first post?
Screenshot - 3_16_2017 , 4_50_07 AM.png
0
Inspecting mirrors is a job I could easily see myself doing.

If you are the smartest person in the room, you are in the wrong room.
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby mjursevs » Wed Apr 05, 2017 11:43 pm

At my wits end here - I've tried every iteration of installing, uninstalling LibFredo6 and other Fredo6 plugins. I'm trying to install Joint Push Pull Interactive.

When installing most Fredo6 plugins, they don't show up whatsoever. In trying to install every Fredo6 plugin, the ones that do show up reliably are Tools on Surface, Curvizard and Rounded Corners. All others say they've installed fine, but won't show up under Tools > Fredo6 Collection, or elsewhere. When starting Sketchup after installing the latest LibFredo6, I get this error message:

Error Loading File Fredo6_!LibFredo6.rb
Error: #<ArgumentError: invalid byte sequence in UTF-8>
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:783:in `match'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:783:in `block (2 levels) in load_from_config'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:782:in `each'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:782:in `block in load_from_config'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:780:in `foreach'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:780:in `load_from_config'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:1190:in `block in load_all_plugins'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:1190:in `each'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:1190:in `load_all_plugins'
c:/users/michael/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:228:in `startup'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:63:in `process'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:70:in `<module:LibFredo6_Loader>'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:28:in `<top (required)>'
Error Loading File Fredo6_FredoScale.rb
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `-'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `<top (required)>'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoScale.rb:25:in `<top (required)>'
Error Loading File Fredo6_JointPushPull.rb
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `-'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:79:in `<top (required)>'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/Michael/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_JointPushPull.rb:29:in `<top (required)>'


I've also tried Purging Obsolete Files under LibFredo6 options - no luck.

Please, any insights or advice would be greatly appreciated. I could really use Joint Push Pull for my office Sketchup use, but am having absolutely no luck getting it to show in my Tools area.
0

mjursevs 
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby Dave R » Mon Apr 10, 2017 11:59 am

How are you going about installing LibFredo6 and Joint Push/Pull? At this stage you would probably find it best to go to the Plugins folder and delete everything related to LibFredo6 and Joint Push/Pull and start over. Install the Sketchucation Extension Store and use it to automatically install the extensions.
0
Inspecting mirrors is a job I could easily see myself doing.

If you are the smartest person in the room, you are in the wrong room.
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby fernandocatalan » Tue May 02, 2017 3:39 am

como descargo en esta pagina no eh podido
0

fernandocatalan 
 

Re: [Plugin Library] LibFredo6 - v7.5b - 13 Feb 17

Postby Dave R » Tue May 02, 2017 10:13 am

fernandocatalan wrote:como descargo en esta pagina no eh podido


First post of this thread.
Screenshot - 5_2_2017 , 4_12_17 AM.png
0
Inspecting mirrors is a job I could easily see myself doing.

If you are the smartest person in the room, you are in the wrong room.
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby fredo6 » Thu May 25, 2017 1:48 pm

NEW RELEASE: LibFredo6 v7.6a - 25 May 17

LibFredo6 7.6a is a major release dedicated to Animator 1.6

See main post of this thread for Download of LibFredo6.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby lilywater » Mon May 29, 2017 5:44 pm

thank you for your offer!
0

lilywater 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby CharlyLee » Tue May 30, 2017 12:34 am

Awesome!!! Thanks
0

CharlyLee 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby gene123 » Tue Jun 06, 2017 4:15 am

thanks a lot
0

gene123 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby Tantema » Tue Jun 06, 2017 8:52 pm

Hi - I am running Sketchup 2016 and I seem to be having many of the same problems I see popping up here.
1) I installed LibFredo6 successfully after many deletions and redownloads. I say "successful" since I was finally able to open sketchup 3 times without this error message:

Error Loading File C:/Users/Gordon/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6/top_LibFredo6.rbe
Failed to read RBE/RBS file.
Error Loading File Fredo6_!LibFredo6.rb
Error: #<NameError: uninitialized constant LibFredo6_Loader::LibFredo6>
C:/Users/Gordon/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6.rb:63:in `process'
C:/Users/Gordon/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6.rb:70:in `<module:LibFredo6_Loader>'
C:/Users/Gordon/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6.rb:28:in `<top (required)>'

During that time I also installed Curviloft and while I was not receiving an error from the Library I was getting this message upon startup:
You must install LibFredo6 version 6.9 or higher to run Fredo6_Curviloft

At no point did LibFredo6 options appear in my Windows tab. None of the Fredo pluggins show up in my Warehouse list of extensions for me to activate. Now I am receiving the notification that I need to install the Library (and I have been trying to install v7.6a) as well as the Error listed above.
Deleting all Fredo related files and starting over does not seem to work as I've been doing it 3 - 4 time a day now for a week. Any help would be greatly appreciated since I would love to be able to take advantage of these tools. It makes trying to learn anything frustrating when 99% of tutorials on-line say "just engage this toolset and voila!" when simply downloading the toolset is what prevents the advancement.
0

Tantema 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby TIG » Tue Jun 06, 2017 10:12 pm

Assuming you have the latest LibFredo RBZ...

Please check that you have installed SketchUp properly...

Close SketchUp.

Find the SketchUp installer exe file [probably in your Downloads folder]
Select its icon.
Right-click > Context-menu > Run as administrator...

When offered choose 'Repair'.

Restart SketchUp - any improvement ?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby fredo6 » Tue Jun 06, 2017 11:35 pm

@tantema

This is not related to LibFredo6 specifically but to Sketchup and your user account in Windows. For some unknown reason, this gives this type of error (failed to read rbs/rbe), even for the plugins shipped by Sketchup like the sandbox).

You have a discussion there on the problem.

I am not sure the Sketchup teams has yet identified the cause of the problem, which happens in SU2016 and SU2017.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby KMA » Sat Jul 08, 2017 5:55 am

Dear form editor.
Greetings.

I have google sketch-up 2015 pro.

1) I have installed the plug-in from the presences section / extensions : install extension
after downloaded from the website

2) restarted the program for activating the plug-in

3) message pops-up as following "you have to visit the website to make the plug-in working"

and the normal website as follow

https://sketchucation.com/plugin/1173-roundcorner

which is the first step of installation
1.png
, which is pointless.

please to inform me what to do.

find the attachment photos
0

KMA 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby TIG » Sat Jul 08, 2017 1:22 pm

@KMA

Most of Fredo's extensions also need his Lib installing - that Lib has many shared supporting utilities.
Download the RBZ for his Lib from the PluginStore... and install that.
https://sketchucation.com/pluginstore?pln=LibFredo6
Restart Sketchup afterwards, to ensure that everything gets properly synced.
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby KMA » Sun Jul 09, 2017 10:52 am

Greetings:
KMA89
1.png


I have downloaded the round corner plug-in normally.

also I have google sketchup 2015 pro, as per the video, I do not have the same windows as in the video, the window tab is not showing the extension manager, only all I did is installing the extension from the preferences tab, so every time I start the program this message popsup as in 2nd picture.

please ant advises for this issue
0

KMA 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby fredo6 » Sun Jul 09, 2017 3:01 pm

That's what TIG was telling you.

To make RoundCorner work, you need to install the Library LibFredo6, which apparently you did not.

See this post for how to install LibFredo6>

Note that LibFredo6 is common to most of my plugins, and therefore you need to install it (and update it) once.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby Marcadam » Sun Jul 09, 2017 7:48 pm

Hi everyone : thank you Fredo for your great tools. I have tried to install them some time ago and watched Fredo's video a few times. I get plenty of error messages on start-up like
Error Loading File C:/Users/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6/top_LibFredo6.rbe
Failed to read RBE/RBS file.
Error Loading File Fredo6_!LibFredo6.rb
Error: #<NameError: uninitialized constant LibFredo6_Loader::LibFredo6>
C:/Users//AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:63:in `process'
C:/Users//AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:70:in `<module:LibFredo6_Loader>'
C:/Users//AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:28:in `<top (required)>
In his video, Fredo opens a menu called extensions under Preferences. This does not exist in my version of Sketchup Make 2017. I see that Fredo 6 Lib Tools are installed and enabled in the extensions manager, but they dont show up as menu. What am I doing wrong ? Thanks for any help - Marc
0

Marcadam 
 

Re: [Plugin Library] LibFredo6 - v7.6a - 25 May 17

Postby TIG » Sun Jul 09, 2017 8:00 pm

In v2017 the 'Extensions Manager' is now accessed from the SketchUp 'Window' menu - this is now common between PC and MAC.
That resultant dialog has a red button which is used to install extensions [much as previously]...

Let's assume you messed you when attempting an unnecessary manual installation...

Try again...
Remember that most of Fredo's tools also need his 'LibFredo' installing [first].

If errors persist you might have previously failed to install SketchUp correctly.
The only proper way to install SketchUp is to close it if its already running, then find its installer's exe file [probably in your downloads folder ?], select its icon, right-click > context-menu > "Run as administrator"
If SketchUp is already installed, when prompted choose 'Repair'...
If it's actually a fresh installation, then accept that option...

SketchUp should now be properly installed...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.7a - 09 Jul 17

Postby fredo6 » Sun Jul 09, 2017 11:40 pm

NEW RELEASE: LibFredo6 v7.7a - 09 Jul 17

LibFredo6 7.7a is a major release dedicated to the support of high-resolution and Retina screens and Retina.

Basically, the button palettes, progressions bars, the text font, the line thickness and the dimension of some visual marks are grown by the factor of resolution.

  • Sketchup < 2016: Font size cannot be changed and characters may thus still appear small. you have also to set up manually the scale factor
  • Sketchup 2016: you have to set up manually the scale factor (usually 2), because it cannot be detected by the API.
  • Sketchup >= 2017: the configuration is activated automatically. Still, you can manually disable the option.

The settings are in the LibFredo6 Default Parameters:
LibFredo6 77 - Support Param HiRes.png


Because most of plugins uses LibFredo6, the support of hi-res screens should apply to all my plugins. However, there may be changes required in each individual plugin, which will be rolled out progressively.

IMPORTANT:
  • HoverSelect is NOT supported for hi-res screens
  • Animator must be upgraded to v1.7a or above

Please report all issues and suggestions in this dedicated thread on the Sketchucation forum


See plugin home page of LibFredo6 for Download of LibFredo6.

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v7.7a - 09 Jul 17

Postby rv1974 » Tue Jul 11, 2017 12:37 pm

Almost 300000 downloads... Blockbuster! Is it only last version or cumulative?
0

rv1974 
 

Re: [Plugin Library] LibFredo6 - v7.7a - 09 Jul 17

Postby ajiprihastono » Wed Jul 12, 2017 1:03 am

Frodo,

I am using sketchup pro 2016, and I dont find extension manager menu in my windows bar. Can you guide me how to get it?
0

ajiprihastono 
 

Re: [Plugin Library] LibFredo6 - v7.7a - 09 Jul 17

Postby Dave R » Wed Jul 12, 2017 1:31 am

ajiprihastono wrote:Frodo,

I am using sketchup pro 2016, and I dont find extension manager menu in my windows bar. Can you guide me how to get it?


Look in Preferences>Extensions for Install Extension. Best to install the Sketchucation Extension Store from Resources at the top of the page and use it to install LibFredo6 and other extensions.
0
Inspecting mirrors is a job I could easily see myself doing.

If you are the smartest person in the room, you are in the wrong room.
User avatar
Dave R 
Global Moderator
 

Re: [Plugin Library] LibFredo6 - v7.7a - 09 Jul 17

Postby classicaircraft » Mon Jul 17, 2017 3:19 pm

Good day Fredo, I'm VERY new to SketchUp so please bear with me. I have watched the video wrt installing plug-ins/extensions and am happy that I'm doing it correctly. When I start SketchUp I get this error message for both v7.6 and 7.7:

Error Loading File Fredo6_!LibFredo6.rb
Error: #<NameError: uninitialized constant LibFredo6_Loader::LibFredo6>
C:/Users/Main/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6.rb:63:in `process'
C:/Users/Main/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6.rb:70:in `<module:LibFredo6_Loader>'
C:/Users/Main/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Fredo6_!LibFredo6.rb:28:in `<top (required)>'
"Aidez moi s'il vous plait"
Kind Regards,
Joe J
0

classicaircraft 
 

Re: [Plugin Library] LibFredo6 - v7.7a - 09 Jul 17

Postby fredo6 » Mon Jul 17, 2017 3:45 pm

Joe,

Looks like you have a wrong installation.

Could you please show the footprint (i.e. files and folders) in your Sketchup Plugin directories, that is:
C:/Users/Main/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin Library] LibFredo6 - v7.7c - 16 Aug 17

Postby fredo6 » Wed Aug 16, 2017 6:35 pm

NEW RELEASE: LibFredo6 v7.7c - 16 Aug 17

LibFredo6 7.7c is a minor release dedicated to
  • some adjustments for high-resolution and Retina screens and Retina.
  • The support of VRay in Animator.

----------------------------------------------------------------------------

See plugin home page of LibFredo6 for Download of LibFredo6.

Main Post of the LibFredo6 thread

Fredo
1
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: RaizenV3 and 7 guests

Visit our sponsors: