HELP! "Unable to edit light - no light asset was provided"

General discussion on V-Ray for SketchUp

HELP! "Unable to edit light - no light asset was provided"

Postby jpmorla » Tue Jun 03, 2014 9:35 am

Hello fellow SU and VRAY users! I have been using SU for many years now and started using VRAY since the beginning of this year. All has been good, aside from a few typical problems I have found many of us have experienced.

I am currently working with a large file. I have been rendering scenes from this file for many months an have never had a problem.

Recently, I noticed that I am not able to edit any of my VRAY lights. When I click on the edit light icon, a window pops up saying "Unable to edit light - no light asset was provided".



I have tried many things and searched for answers on the net but have not been able to solve this problem. Even if I add new lights, I still get this message for when I try to change its parameters. I discovered that if I delete all VRAY lights in the model, I am able to add new lights and edit them without problems. I have done this many times, painfully recreating every light one by one.

However, everytime I close the file the lights go into an apocalyptic doom. If I re-open the file, I get the death sentence "Unable to edit light - no light asset was provided" again!!!

Has this happened to anyone here? Anyone has any ideas?

I am working with SUPro and Vray 2.0 on a MAC with OS Mavericks.

H E L P P L E A S E !!!!
2

jpmorla 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby valerostudio » Tue Jun 03, 2014 3:05 pm

This is a bug when lights are made into or placed into components. Bug report this please.
4

valerostudio 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby dkendig » Tue Jun 03, 2014 3:22 pm

this is with the service release? Please make sure you are working with 2.00.24261
0
Devin Kendig
Developer
User avatar
dkendig 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby andybot » Tue Jun 03, 2014 8:25 pm

You know what, I've gotten this error randomly once or twice recently. It's fixed if I restart SU. If I run into it again, I'll see if I can submit a bug report. IIRC, it happens with a vray light within a component that I just loaded in from the component browser.
3
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby jpmorla » Wed Jun 04, 2014 6:25 am

dkendig wrote:this is with the service release? Please make sure you are working with 2.00.24261


Hi Devin, Thank your for your quick reply. I am indeed using build 2.00.24261. I did have Vray lights in components for months before the problem occurred for the first time. I exploded all components but it did not solve the issue. Only when I erase all lights and add them again (without components this time)am I able to open the light editor and change parameters. The file worked fine then, but after closing and opening the problem comes back again. Any suggestions?
0

jpmorla 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby valerostudio » Wed Jun 04, 2014 4:55 pm

I have 2.00_24622 because I have nightly access and I just got the error. And I will add this, when I deleted the component and added a brand new omni light, it gave me the same error. I should note that this light is nested withing another component, within a group, so it is buried in there a bit.
Light Comp Issue.JPG
0

valerostudio 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby TedVitale_CG » Thu Jun 05, 2014 10:08 pm

valerostudio wrote:I have 2.00_24622 because I have nightly access and I just got the error. And I will add this, when I deleted the component and added a brand new omni light, it gave me the same error. I should note that this light is nested withing another component, within a group, so it is buried in there a bit.
Light Comp Issue.JPG



If you're on nightly access expect these hiccups. The light issue was fixed, so you shouldn't have a problem now. Make sure you update your nightly to what ever is most current when you run into issues like this, or re-install the service release. Nighties are always provided to certain customers use at your own risk. If you run into new bugs in a current nightly, be sure to log the bug reports with the version you are using vsfwip@chaosgroup.com.
0
Ted Vitale
3D Artist|Trainer
Chaos Group USA
http://www.chaosgroup.com
User avatar
TedVitale_CG 
Vray Support
Vray Support
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby rwilkin1 » Thu Jun 26, 2014 3:22 am

(Re: SU/Vray 20. plugin) I had that issue with lights inside components once before and a restart of SU fixed it for me that time. I just had it happen again in a different model and here's another thing I just tried that worked for me & is quicker: EXPLODE one of the components, pick the light and go to edit that individual light. You should be able to get to the edit box now, but don't, now just deselect and UNDO the EXPLODE and you should be back in shape!
3

rwilkin1 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby jpmorla » Mon Jul 21, 2014 6:42 am

I am still having the same problem over and over again. Last month was with one file and now the problem is coming up with every file I open. Has anyone gotten to the bottom of this? Help please!
0

jpmorla 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby andybot » Mon Jul 21, 2014 3:51 pm

did you update to the current version of vfs?
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby jpmorla » Mon Jul 21, 2014 9:04 pm

andybot wrote:did you update to the current version of vfs?



Hi andybot, I am working with Sketchup Pro and Vray 2.00.24261(edu)on a MAC with OS Mavericks.
0

jpmorla 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby KTurtle » Thu Oct 02, 2014 10:29 pm

I have been modeling a three-story lobby. I have been embedding V-Ray lights into components so that I only have to create one elevator lobby ceiling that is then repeated on all three floors. I have had no issues with this until a few minutes ago when I got this same "Unable to Edit Light- No Light Asset Was Provided" error message. At first it was just on one new light; I was trying to copy one component that consisted of my can and spotlight, make it unique, change the lighting lumen level, and then use for a different area. I got this error message, but was still able to go to my previous components and tweak the lighting. Then it started spreading, and all of a sudden I get the error on all lights.
If anyone's heard a fix for this issue, please share. Keeping my fingers crossed that shutting down SU and re-starting will do the trick!...
0

KTurtle 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby TedVitale_CG » Mon Oct 06, 2014 3:33 pm

KTurtle wrote:I have been modeling a three-story lobby. I have been embedding V-Ray lights into components so that I only have to create one elevator lobby ceiling that is then repeated on all three floors. I have had no issues with this until a few minutes ago when I got this same "Unable to Edit Light- No Light Asset Was Provided" error message. At first it was just on one new light; I was trying to copy one component that consisted of my can and spotlight, make it unique, change the lighting lumen level, and then use for a different area. I got this error message, but was still able to go to my previous components and tweak the lighting. Then it started spreading, and all of a sudden I get the error on all lights.
If anyone's heard a fix for this issue, please share. Keeping my fingers crossed that shutting down SU and re-starting will do the trick!...



An update to the latest service release (SP2) should fix the problem. A fast fix is usually closing Sketchup and opening it back up.
0
Ted Vitale
3D Artist|Trainer
Chaos Group USA
http://www.chaosgroup.com
User avatar
TedVitale_CG 
Vray Support
Vray Support
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby chon » Tue Nov 18, 2014 9:14 am

Hello,

I've got the same problem on my config (config in my signature).

How can i know if i have the SP2 release ?
0
SU2019 pro 19.2.222 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby sketchuh » Tue Nov 18, 2014 11:12 am

it happened to me too. I placed a light in a component. and same error message popped up. my fix is I will create a new light outside the component. then cut it, then double click into the the component, then paste the light that I created outside the component. now the newly created light is inside the component. it worked for me. hope that makes sense.
0

sketchuh 
Premium Member
Premium Member
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby chon » Tue Nov 18, 2014 3:33 pm

Thank you Sketchuh ! ;)

I know that, but that is not a solution, it's a hint to get around a problem.

Another one : you make a copy of each of your VRaylights transformed in components on the first level of your file structure, change your settings on those ones and hide them when rendering. ;)

But the bug is not solved. :(
0
SU2019 pro 19.2.222 + VRay 4.00.02 (Next) on Win10-64Bits
User avatar
chon 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby omiKron » Thu Aug 27, 2015 8:39 am

Yes, it works after restarting SU, but when you have a model that loads 8GBs of your RAM, it's not the best sollution to restart, because it will load again very long time.

Another solving is to copy your IES inside another SU, test it, then copy it back to your model.
1
User avatar
omiKron 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby valerostudio » Fri Aug 28, 2015 6:23 pm

Nope, it is not solved and still does come back randomly. I think it might have something to do woth creating a light while within a group or component. I agree that just saying "restart" is not a good solution or answer. Let's hope that all of these bugs are gone with the next release that we so patiently wait for. Now I'm starting to sound like I did when I was using 1.49.01 and that's scary!
0

valerostudio 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby omiKron » Mon Aug 31, 2015 8:09 am

valerostudio wrote:Nope, it is not solved and still does come back randomly. I think it might have something to do woth creating a light while within a group or component. I agree that just saying "restart" is not a good solution or answer. Let's hope that all of these bugs are gone with the next release that we so patiently wait for. Now I'm starting to sound like I did when I was using 1.49.01 and that's scary!


For me it worked to cut/copy the IES model from the model which shows this bug into an empty skp, test it and copy it back.
0
User avatar
omiKron 
 

Re: HELP! "Unable to edit light - no light asset was provide

Postby christ0s » Wed Sep 19, 2018 8:04 am

I had the same problem. Rectangular vray light, inside component. I JUST RESTARTED SKETCHUP and the problem was fixed!
0

christ0s 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to V-Ray

Who is online

Users browsing this forum: marielramos and 9 guests

Visit our sponsors: