V-ray materials disappear??? why is that..

General discussion on V-Ray for SketchUp

V-ray materials disappear??? why is that..

Postby Jesperoh » Sat Feb 19, 2011 1:45 pm

Hi,

I am quite new to V-ray so you will have to excuse me if the fallowing problem is a simple user error...

When I am working on a model and I have added some v-ray materials it renders fine. But if I save the model, closes Sketchup and then start Sketchup again and reload the model the V-ray materials "disappear" from each subject in the model. It just renders the colour that the V-ray materials appear like in the model.

As some of you might have noticed my english is not exactly perfect. But I hope you guys understand my problem anyway..

Kind regards

Jesperoh
0

Jesperoh 
 

Re: V-ray materials disappear??? why is that..

Postby andybot » Sun Feb 20, 2011 2:41 am

make sure when you add materials that they also show up in the sketchup material editor. If they don't show up in sketchup, they won't be mapped correctly in your model. One way to make sure is to add you material map in the sketchup material editor "use texture image"

hope this helps!
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: V-ray materials disappear??? why is that..

Postby thomthom » Sun Feb 20, 2011 6:13 pm

Jesperoh wrote:Hi,

I am quite new to V-ray so you will have to excuse me if the fallowing problem is a simple user error...

When I am working on a model and I have added some v-ray materials it renders fine. But if I save the model, closes Sketchup and then start Sketchup again and reload the model the V-ray materials "disappear" from each subject in the model. It just renders the colour that the V-ray materials appear like in the model.

As some of you might have noticed my english is not exactly perfect. But I hope you guys understand my problem anyway..

Kind regards

Jesperoh


Are you by any chance using VfSU 1.05.30? This version had a bug where unless you opened the Option window before saving the model, any material changes would be lost.

(It's important to mention your software version numbers when asking questions as the answer could very likely depend on this fact.)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: V-ray materials disappear??? why is that..

Postby Jesperoh » Tue Feb 22, 2011 12:48 pm

Hi!

Thank you for your answers..

It is version 1.48.66 so that should not be the problem.

The V-ray materials are showing in the sketchup material editor.

I am having more problems with V-ray at the moment. Now Sketchup crashes if I try to render a model that has been closed down and then reloaded. So I decided to try and reinstall V-ray.. but now the installation crashes. Maybe I should just get another computer...

I do not think I will ever be best friend with V-ray. Can anyone recommend another piece of rendersoftware?


but thanks anyway.

Regards Jesper
0

Jesperoh 
 

Re: V-ray materials disappear??? why is that..

Postby thomthom » Tue Feb 22, 2011 12:53 pm

Jesperoh wrote:It is version 1.48.66 so that should not be the problem.

That's an outdated version - one of the early version which had many issues. Update to the latest and see if you still have the problem.
1
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: V-ray materials disappear??? why is that..

Postby troyhome » Tue Mar 22, 2011 7:04 pm

I've been having this same issue...thanks for the advise!
0
IOviz.com
SU Pro 2017 PC
Thea: latest
vray4SU latest
User avatar
troyhome 
 

Re: V-ray materials disappear??? why is that..

Postby tasss » Mon Nov 19, 2012 8:56 pm

Hi, I am using the newest demo version of vray (so it's not outdated) and happens the same - I mean - after following opening all the loaded materials disappear. I would be grateful for any response :)
0

tasss 
 

Re: V-ray materials disappear??? why is that..

Postby valerostudio » Wed Nov 28, 2012 7:36 pm

Its a bug. Its been around for a long time and we hope for a new release soon that addresses it.

For now, I think the way to avoid it is to save often, try not to drag material layers around too much, and be careful of loading old material files. If anyone else has things to be careful of, pass the word around.

I thought I heard a rumor about opening the options panel and closing it before saving and closing the file to fix it? Not sure?
0

valerostudio 
 

Re: V-ray materials disappear??? why is that..

Postby RedFoxy » Wed Feb 13, 2013 12:08 pm

Hi.

I have a similar problem with V-Ray version 1.49 for Mac. Materials don't exactly disappear, but after saving and opening a file again they lose their layers and/or bitmap textures and appear just as colours (all the numeric settings are saved though). For example a material for the outside landscape would be there, but lose its emissive layer... Does anyone have or had this problem and by any chance knows a solution to it? It really makes the work twice as long, since I have to upload all the materials from the beginning and then apply them one by one...
1
User avatar
RedFoxy 
 

Re: V-ray materials disappear??? why is that..

Postby thomthom » Wed Feb 13, 2013 2:00 pm

I minimize this by not modelling when VfSU is active. I keep VfSU disabled when I model.

I'm not 100% sure, but it appear to be that if you copy/paste or import geometry while vFSU 1.49 is loaded there's a risk of loosing the layers.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: V-ray materials disappear??? why is that..

Postby RedFoxy » Wed Feb 13, 2013 2:49 pm

thomthom wrote:I minimize this by not modelling when VfSU is active. I keep VfSU disabled when I model.

I'm not 100% sure, but it appear to be that if you copy/paste or import geometry while vFSU 1.49 is loaded there's a risk of loosing the layers.


Thank you thomthom. Will sure try that, hopefully it helps. It's a really annoying problem. :evil:
0
User avatar
RedFoxy 
 

Re: V-ray materials disappear??? why is that..

Postby thomthom » Wed Feb 13, 2013 2:54 pm

Yea, very annoying. Keep an eye out for the next update.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: V-ray materials disappear??? why is that..

Postby shelleygale » Sat Jul 27, 2013 9:43 pm

I'm having this problem as well and it's driving me mad. Glad to see there might be something I can do about it. Would you tell me how to disable Vray while working in SU? Thanks.
0
• iMac late 2013
• OS 10.8/5
• Processor: 3.5 GHz Intel COre i7
• Memory: 32 GB 1600 MHz DDR3
• Vray 2.0 and SU 2013

shelleygale 
Premium Member
Premium Member
 

Re: V-ray materials disappear??? why is that..

Postby thomthom » Sat Jul 27, 2013 11:38 pm

Preferences > Extensions > V-Ray for SketchUp

Disable it there. Then, to make it easier to load VfS when you need it, install my V-Ray Tools plugin.

Sendt from my Xperia Z Tabled using Tapatalk
1
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: V-ray materials disappear??? why is that..

Postby dkendig » Mon Jul 29, 2013 3:40 pm

We only support having 1 model open at a time in SketchUp on OSX, the majority of the material craziness is typically from having 2 models open simultaneously. The next release allows you to choose which model we attach to, which remedies this issue.
1
Devin Kendig
Developer
User avatar
dkendig 
 

Re: V-ray materials disappear??? why is that..

Postby monkers » Thu Sep 24, 2015 7:06 am

I'm Having the same problem with SU 15.3.331 x64 and Vray 2.00.25244

The texture maps it decides to leave out changes each time it starts doing this. Also it seems to corrupt the model file. Once it starts doing this i cant seem to import images directly into the model with out getting bug splats. I have tried both by drag and drop and via import. This is really frustrating the only way around this is constantly copying the model into new skp files but Its a very complicated model with 20 scenes and im starting to loose my patience.

I have also tried packing the scene and making a vray material collection to import back in once reopened. None of which seem to make a difference as the material collection wont override materials with the same name and when i click on each material and re import it they dont retain the UV data.

Any suggestions would be much appreciated as I am already 2 days late on delivery for this project.
0

monkers 
 

Re: V-ray materials disappear??? why is that..

Postby em3di » Wed Mar 20, 2019 1:47 am

I have a similar situation! :( :( :(

I'm working on a huge project with about 90 materials and I was working during a long time, adding new materials with the interactive render, and I notice my CPU usage was 95%, so I save the project and tried to make a final render. And when I tried to render nothing happens, so I close the project, wait for a little and reopen it. Then I tried to render again and it was no materials in the render then I also notice there were no materials on Vray material list too!!! :shock: :shock: :shock:





So since I can see the materials on SketchUp, can I add them to Vray material list?

if not, I have an autosave project with the latest materials used, can I export all of them at once to my recent project?

I'm using:

SketchUp Pro 2016 (version 16.1.1449 64bit)
V-Ray 3.40.02
Windows 7 64Bit
0
User avatar
em3di 
 

Re: V-ray materials disappear??? why is that..

Postby Flatchoum » Fri Jun 14, 2019 9:48 am

Hi,
I have a similar issue. All renderings turn white, after saving the file. Vray for Sketchup 3.40.01
and sketchup 2017 on Windows 7. Any ideas?
Thanks,
Greg
0
User avatar
Flatchoum 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to V-Ray

cron

Who is online

Users browsing this forum: No registered users and 3 guests

Visit our sponsors: