Dynamic Component Len values break if you inc. a subcompon.

Dynamic Component Len values break if you inc. a subcompon.

Postby NateCM » Fri Feb 12, 2016 3:07 am

Hi all, I've been experiencing a problem with Dynamic Components as follows...

I make a DC from un-grouped geometry. At this stage my Len Values are OK..

If I double click the DC and push pull a face, the Len value increases accordingly..

If I then include a sub-component (within the size constraints of the DC) all is still good..

I can still push pull the geometry within the DC and the Len Values still change..

THE PROBLEM..

If I now add a custom attribute to the sub component (something which doesn't change its geometry) but references one of the Parent DC's Len values. The Len values of the Original (parent) DC are broken..

If I push pull a face within the DC the Len Values no longer change but are fixed at the lenghts that were recorded just prior to referencing the parent DC.

I can still push pull the contained geometry BUT the DC's Len values no longer show correct sizes..

Any help would be welcomed.. I for one think this is a significant Bug...

Cheers Nathan..
0

NateCM 
 

Re: Dynamic Component Len values break if you inc. a subcomp

Postby Jim » Sat Feb 13, 2016 2:49 pm

Hi Nate - Can you post a small example model?
0
Hi

Jim 
Global Moderator
 

Re: Dynamic Component Len values break if you inc. a subcomp

Postby NateCM » Sun Feb 14, 2016 1:06 am

Here's a basic file with each stage showing the point where the Dynamic Component breaks it's Len Values..

Dynamic Component Error.skp


Thanks a heaps for looking at this Jim...

0

NateCM 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Dynamic Components

Who is online

Users browsing this forum: No registered users and 2 guests

Visit our sponsors: