Google Earth - texture mix-up

Google Earth - texture mix-up

Postby mirjman » Tue Mar 04, 2008 6:08 pm

Has anyone else experienced this:

when exporting multiple times to google earth, materials will switch from one model to another. I have not yet figured out the pattern for this. Sometimes the models will both display correctly, but upon closing and reopening GE the textures will be switched or blank

it also seems like the model will load many times faster by opening the .kmz file rather than opening GE with the models previously loaded
0

mirjman 
 

Re: Google Earth - texture mix-up

Postby Gaieus » Tue Mar 04, 2008 6:42 pm

I've been reading weird texture shifting problems in GE lately but never heard that they can even shift between models.
Well, I should (re)start playing with GE again.

Have you uploaded them to the warehouse or just saved as kmz? If you rename the kmz to zip, you can open it and the materials used in the model are there in a subfolder. You can check whether they are all the ones you assigned to the model itself.

BTW - a new version of GE has just been released (I haven't checked it out yet).
0
User avatar
Gaieus 
 

Re: Google Earth - texture mix-up

Postby modelhead » Tue Mar 04, 2008 9:43 pm

The textures on my "best of" models where mixed up. Some had been replaced some I had never seen before. I told Craig about it about two weeks ago. He said they where in the middle of fixing the problems. Yesterday I had a look and they had all been fixed.
0

modelhead 
 

Re: Google Earth - texture mix-up

Postby Gaieus » Tue Mar 04, 2008 9:49 pm

Good news at least. I wonder what caused it though.
0
User avatar
Gaieus 
 

Re: Google Earth - texture mix-up

Postby mirjman » Wed Mar 05, 2008 1:43 am

it seems like its a problem with the way SU exports texture files to GE, if you export twice and look in the kmzs they will both have a texture called "texture0.jpg" even though they are different exports and different textures. when you reload the program it confuses them ?

i'm having a hard time understanding the behavior- I renamed all the textures in the kmz files to make them unique then opened both in GE and it seems to work, but when I reopen GE with them preloaded, I get blank textures.
0

mirjman 
 

Re: Google Earth - texture mix-up

Postby Gaieus » Wed Mar 05, 2008 1:50 am

You can't just rename the textures in the kmz file (folder) without also editing the dae file (also a text file in xml format) and changing all the references to them I believe. It's just like renaming a file somewhere on an internet server while keeping the URL to it in its original form on a website.
0
User avatar
Gaieus 
 

Re: Google Earth - texture mix-up

Postby modelhead » Wed Mar 05, 2008 6:51 pm

One complaint I have is that even with a generally strong computer you cannot preload a lot of models. Once I get up around 10 MB of models preloaded GE can act pretty funny and the first thing it does is remove textures.
0

modelhead 
 

Re: Google Earth - texture mix-up

Postby Gaieus » Thu Mar 06, 2008 9:37 am

Yes but it's still better than removing geometry (or being unable to navigate) IMO.
Hopefully by the time GE gets really populated, both computers and bandwidth (for streaming) wil be better.
0
User avatar
Gaieus 
 

Re: Google Earth - texture mix-up

Postby modelhead » Thu Mar 06, 2008 5:45 pm

I do love GE...don't get me wrong...in fact I would like it to become my SU ground plane...I would like to build right there in context with all the SU tools available. My earlier(madd)thoughts on this......http://www.sketchucation.com/forums/scf/viewtopic.php?p=44341#p44341
0

modelhead 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Google Earth

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: