Help - how to avoid double faces in Collada export

General discussion related to SketchUp Pro and Make

Help - how to avoid double faces in Collada export

Postby andybot » Wed Apr 17, 2019 1:01 am

So I typically export .obj files into Blender, but I have a file with a lot of components, and I want the components to import as linked duplicates. Collada works great for this, but I can't seem to figure out how to avoid getting duplicate faces throughout my model. Any tips would be appreciated!

-Andy
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby Mike Amos » Wed Apr 17, 2019 9:25 am

Probably something you have done but are you using he cleanup plugin in sketchup prior to export. Not trying to put you down but I experience brain fade sometimes and miss steps like these.
0

Mike Amos 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby TIG » Wed Apr 17, 2019 10:53 am

'Two-sided faces' is an Export 'Option'... make sure it's NOT ticked.
Also check for proper face orientation by viewing in Monochrome, and reversing any back-faces you can see - [re]applying any materials/textures to the now front-face as necessary...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Wed Apr 17, 2019 3:50 pm

That's not it. It's a pretty simple model and 2 sided faces is unchecked. I'm curious if people with Blender experience can weigh in here - how do you transfer your models? Like I said, I typically use .obj format, but with obj (and 3ds, and fbx) components come in as unique instances, not linked.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Thu Apr 18, 2019 2:24 pm

So nobody else gets double geometry when they import Collada into Blender?
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby juju » Fri Apr 19, 2019 7:15 pm

andybot wrote:So nobody else gets double geometry when they import Collada into Blender?

2 for 1 special?
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Fri Apr 19, 2019 10:39 pm

:roflmao:
I dunno, people were saying on another thread that Collada format works great for Blender. Not happening for me.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby TIG » Sat Apr 20, 2019 1:37 pm

I don't see 'double geometry' from SketchUp DAE files imported into Blender.
What I do see is separate meshes created made for each material inside a 'container'.
And the fronts AND backs of those faces are assigned the same material as the front's - but in a well modeled form you should never be seeing any 'back-faces', so that isn't much of an issue ?
Because Blender uses meshes, then multiple copies of a SKP's component-instance get treated as separate objects - additionally split by mesh-by-material ??

Can you take a screenshot of some simple textured faces in a SKP and then exported to DAE-into-Blender - showing what you see... and how it impacts your work...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Mon Apr 22, 2019 5:47 pm

TIG, Thanks for asking further. Here is a fairly straightforward example of an apartment interior. I've included the original skp file, a Collada export, and the imported Blender file. I'm using SU2016 pro, but I encounter the same problem in SU2018 as well. I've unchecked "double-sided faces" in the export options. Can't think what else I could do differently.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby TIG » Mon Apr 22, 2019 10:45 pm

I'm no Blender expert.
I don't see 'double-faces'...
But if I set 'Back-face culling' be 'on', and tweak some other settings, then the 'z-fighting' stops ?
Is that your issue??
I believe it's Blender's settings, not SketchUp's export-options in play........
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Tue Apr 23, 2019 2:33 pm

So the issue for me is that obj export, also fbx, 3ds, etc. give me correct models without duplicate faces. However, they make each instance of a component unique in the model. Collada seems to be the only format that makes components linked duplicates (meaning that editing one edits all of the instances in the model, like the difference between components and groups in Sketchup.)

Yes, I can do workarounds just fine in Blender - what I typically do is "remove doubles" to collapse the duplicate vertices. But this is something I used to have to do with earlier versions of obj export (like in 2012 or so.) I would like Collada to export properly, and now I'm wondering if the checkbox for "Two sided faces" is not actually working correctly.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby Pixero » Tue Apr 23, 2019 4:35 pm

Maybe you could import the collada file into some other 3D app and see how it looks there?
0
User avatar
Pixero 
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Tue Apr 23, 2019 5:46 pm

Pixero wrote:Maybe you could import the collada file into some other 3D app and see how it looks there?


Yep, I tried that before with FreeCAD, I get double faces there too. I checked again, and same thing.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

Re: Help - how to avoid double faces in Collada export

Postby Lionelfred » Fri May 17, 2019 10:51 pm

You are not alone. I have terrible problems with this in blender. The result is that in Cycles render (but not in Eevee) you get horrible (I think) z-fighting (where two faces try to be visible at once) and also issues with (I think) flipped normals, which results in the texture of the surface of an object having have some normal textures but some of its triangular faces will show whiteish.

This page https://www.katsbits.com/tutorials/blender/sketchup-import-extras.php recognizes the problem and explains possible solutions, but don't hold your breath as they have only very partially solved my problems of double faces.

The only way I have found to resolve is quite laborious (how laborious depends on the complexity of the model, of course).

- If the problem is z-fighting (you see the texture on the face is greyed out), go round the back of the mesh (I do this in wireframe) and select and delete the face (delete > faces) that is behind. When you go back round the front and toggle out of edit mode, you can see that textures are visible and there's none of that z fighting going on (if that's what it is).

- If the problem is flipped normals (the texture is absent on that particular face), then before going round the back, flip the normal on the face at the front (in 2.8 i edit mode, mesh > normals > flip normals). Then go round the back, select the face at the back and delete it.

text834.png
0

Lionelfred 
 

Re: Help - how to avoid double faces in Collada export

Postby andybot » Tue May 21, 2019 2:27 pm

I usually use "remove doubles" to collapse the duplicate vertices. It's typically fine, and much quicker than deleting faces individually. The other big problem with Collada is losing smoothing groups. Obj. format export is my typical workflow, the only reason I need Collada is for linked duplicates.
0
my blog featuring recent projects
User avatar
andybot 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: aguisson and 3 guests

Visit our sponsors: