When I zoom in, model gets cut off

General discussion related to SketchUp Pro and Make

When I zoom in, model gets cut off

Postby keea1111 » Tue May 04, 2010 5:57 am

Hi,

Can someone help me figure out why sometimes, and seemeingly without cause, I become unable to get close to my model to work the details. When I zoom in, the model gets cut off, as if I'm opening up a wall, but in perspective I'm actually 8' or so away from my model. Now, it's very difficult to draw any detail. Anyone have any experience with this...much thanks, Keea
2
KEEA
User avatar
keea1111 
 

Re: When I zoom in, model gets cut off

Postby Slimdog » Tue May 04, 2010 6:26 am

I think its a common problem with sketchup I cant explain why but I am sure some one will. It may have some thing to do with your graphics card to. I usually just use the zoom extents button or you can right click and click zoom extents.

Cheers

S
-1

Slimdog 
 

Re: When I zoom in, model gets cut off

Postby Gaieus » Tue May 04, 2010 6:53 am

Hi Keea,

This is a known issue called "Clipping". See if any of the below solutions can help:
http://sketchup.google.com/support/bin/ ... swer=36261

(especially if you have imported CAD geometry far from the origin, really tiny or very huge model "distance" wise or some weird FOV set).
0
User avatar
Gaieus 
 

Re: When I zoom in, model gets cut off

Postby keea1111 » Tue May 04, 2010 8:29 pm

Hi,

You've identified the problem, but the things that were suggested didn't stop the camera clipping. Strange that I have two copies of the same model in my sketch up, one works fine, I can zoom in, and the other is clipping. Any other thoughts on this problem? thanks,

ps I'm moving to a mac next week from my PC, so hopefully this may solve the problem, but not sure...
-2
KEEA
User avatar
keea1111 
 

Re: When I zoom in, model gets cut off

Postby rickgraham » Tue May 04, 2010 9:34 pm

keea1111 wrote:
ps I'm moving to a mac next week from my PC, so hopefully this may solve the problem, but not sure...


It won't. Been there, doing that :roll:

Rick
-1

rickgraham 
 

Re: When I zoom in, model gets cut off

Postby Gaieus » Wed May 05, 2010 9:26 am

Are you really sure that in one of the copies there is no any stray geometry somewhere in outer space? Try to zoom to extents (Shift+Z) and select all (Ctlr+A). Or the FOV is exactly the same? (Switch to the Zoom tool (Z) and see what it says in the Measurement box).

Was anything imported in the models?
-1
User avatar
Gaieus 
 

Re: When I zoom in, model gets cut off

Postby thomthom » Wed May 05, 2010 9:50 am

Could be hidden geometry, on hidden layers etc.

It can also be guidelines or guide points, if they are far away they might cause the clipping, but Zoom Extent won't include them when zooming.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: When I zoom in, model gets cut off

Postby keea1111 » Wed May 05, 2010 2:36 pm

HI,

I can't detect any stray lines. I do have a section plane hanging out in space above the models. Very strange. I'll attach my model and would you mind looking at it. The FOV is 35 so that isn't the problem. Now I notice when I'm doing my lay out and changing my perspective of the model there, the camera clipping is extreme there and I can't get a close up shot. I did import some 2D trees. thanks for your time,
0
KEEA
User avatar
keea1111 
 

Re: When I zoom in, model gets cut off

Postby thomthom » Wed May 05, 2010 2:48 pm

Your model is faaar away from the origin. See how far away your model axis are.

And when you do hit Zoom Extent - it does zoom far out, you can see teh model as a dot, the model axis far away, and a rectangle also far away. All the things mentioned earlier in this thread.
1
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: When I zoom in, model gets cut off

Postby keea1111 » Wed May 05, 2010 11:37 pm

Hi,

I didn't realize you can't have this kind of distance in sketch up. The reason I do it this way, is so that my scenes don't show the other models, so when I send to LO, the background is clear. Do I really need my models so close together at the axis point? Are there any other solutions? The model that was clipping was the one that was not too far from the axis. Anyway, I appreciate the feedback and the learning curve. thanks, Keea

ps how do you all send your scenes to LO without having to spread the models out too far?
0
KEEA
User avatar
keea1111 
 

Re: When I zoom in, model gets cut off

Postby thomthom » Thu May 06, 2010 7:21 am

keea1111 wrote:The reason I do it this way, is so that my scenes don't show the other models, so when I send to LO, the background is clear.

You have multiple models in one file?
If so, use layers and scenes. Set up scenes where you hide/unhide layers to display what you want.

keea1111 wrote:Do I really need my models so close together at the axis point? Are there any other solutions?

Yes, SU handles large distances very poorly. Which is why when importing DWG or other files that one should ensure everything is close to origin.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: When I zoom in, model gets cut off

Postby keea1111 » Thu May 06, 2010 3:10 pm

HI Thom,

Thanks, that bit of advice makes sense. That helps a lot..thanks for your time here...I was doing the hiding and unhiding within some of my scenes, but never considered hiding other models...thanks and blessings,
0
KEEA
User avatar
keea1111 
 

Re: When I zoom in, model gets cut off

Postby jgb » Sat May 08, 2010 10:59 pm

I had this problem in spades, then a while back Catamountain made a remark in passing that gets around this clipping problem, but does not eliminate it.

The reason clipping happens is due to perspective. As you get in close (in proportion to the models dimensions) SU cannot resolve the angularity (like our eyes can) and clips what it cannot draw. Setting field-of-view helps, but only a little.

To solve this problem, turn OFF perspective view. You can then get real close and personal with the entity. There will be no clipping as you get closer, but it will clip as you zoom out from the entity, exactly the reverse.

Two cautions before you turn off perspective (Camera - perspective).
If the drawing is dimensionally big or complex, select the entity first, or some line nearby. That makes it easier to find when you turn off perspective.

Zoom OUT so that the entity is some distance away and centered in the screen. Then turn off perspective. The view will shift a bit, and then you can zoom in as close as you want. If you don't zoom out, SU may get very far out and you could lose sight of the entity.

After you are done examining and fixing the problems, turn perspective back on.
0
__________________
jgb
User avatar
jgb 
 

Re: When I zoom in, model gets cut off

Postby keea1111 » Thu Dec 16, 2010 12:22 am

This problem has cropped up again. Does anyone know a maximum distance your model can be from the sketch up work space before this clipping begins. It seems once it starts, you cannot go backward, but have to copy all of you drawings to a brand new sketchup template, redo scenes, layers, etc. Giant pain. If there were a way to 'clear' the clipping, that would be great. thanks,
0
KEEA
User avatar
keea1111 
 

Re: When I zoom in, model gets cut off

Postby thomthom » Thu Dec 16, 2010 8:17 am

If you ensure that you don't have small pieces of stray geoemtry far away you should be able to just move your model to the origin. There are plugins that will shift your model to be positioned near Origin for you.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: When I zoom in, model gets cut off

Postby annmar » Mon Apr 07, 2014 2:40 pm

hi the same thing had happened to me.. after a lot of searching i realized that there as a small line far away from the model. when you right click > zoom extend if the model does not fill the screen it means there is an entity floating in your workplane!!
0

annmar 
 

Re: When I zoom in, model gets cut off

Postby jgb » Mon Apr 07, 2014 4:33 pm

Also make sure "Show hidden geometry" is turned ON. :idea:
A hidden line or soft line way out there will drive you nuts if you can't see it.

If you still have difficulty finding that wayward entity, do a "Select All" (EDIT; Select All) then GROUP the entire selection and that wayward entity will be at a far end of the bounding box, highlighted in blue.
Delete it then explode the group.
1
__________________
jgb
User avatar
jgb 
 

Re: When I zoom in, model gets cut off

Postby syburn » Wed Oct 01, 2014 3:09 pm

I was also experiencing the same issue after importing a massive dwg and deleting like 100 layers. Almost had to resort to sending my SU file to this thread, but turned out to be hidden geometry. Thanks Thread.

Do you think better to work of a jpg file and avoid these issues. But Dwg is so nice cos you can click to the points and its accurate.
0
User avatar
syburn 
 

Re: When I zoom in, model gets cut off

Postby Zacchia » Wed Oct 01, 2014 4:58 pm

Hi
If you set camera to parallel view then it does not cut off I guess...
0

Zacchia 
 

Re: When I zoom in, model gets cut off

Postby jgb » Wed Oct 01, 2014 6:19 pm

Zacchia wrote:Hi
If you set camera to parallel view then it does not cut off I guess...

Not sure if Parallel View will prevent "cutting" (clipping), but as mentioned before, if you get "near field" clipping when zooming in, then zoom out a bit, and turn OFF perspective.
Then zoom back in as close as you want.

:idea: You may want to select an entity at/near what you are zooming into to guide you back in after perspective is turned off, because the whole object will jump back in view.

Note that when perspective is off, you will get "far field" clipping when you zoom out on a large object.
0
__________________
jgb
User avatar
jgb 
 

Re: When I zoom in, model gets cut off

Postby twoodby » Tue Nov 03, 2015 7:45 pm

I found this thread because I had the same problem. Here's the solution that I found:

Under the Camera tab, select the "Perspective" option. The clipping occurs when you are in "Parallel Projection"
1

twoodby 
 

Re: When I zoom in, model gets cut off

Postby PeteMcCrea » Mon Feb 08, 2016 2:29 pm

Sorry to drag up an old thread, but I wanted to let people know how I solved the issue.

The tip above for selecting everything then creating a block worked, as it showed that I had something outside the model about 10km above the space I was working in. I was then able to select the items I wanted and group them. Then a elect all, and de-select the model and a delete got rid of what ever I'd managed to locate on the edge of the earths atmosphere. This got rid of the clipping plane and restored my sanity!

So thanks to the guys above and your tips!
0

PeteMcCrea 
 

Re: When I zoom in, model gets cut off

Postby eidy.gg » Wed Jun 22, 2016 1:09 pm

keea1111 wrote:Hi,

Can someone help me figure out why sometimes, and seemingly without cause, I become unable to get close to my model to work the details. When I zoom in, the model gets cut off, as if I'm opening up a wall, but in perspective I'm actually 8' or so away from my model. Now, it's very difficult to draw any detail. Anyone have any experience with this...much thanks, Keea


Solution 1 (most effective):
Reduce the field of view even as low as in single digits until the clipping plane doesn't intrude. Yes, practically you'll be working in an almost paralleled projection mode (field of view = 0) but who cares if you can get the job done on every detail.

Solution 2 (relatively more messy but still very effective and possible to combine with solution 1 - also the only solution for missing faces on very small polygons after using follow path tool):
Select the object / group / component that cannot be properly edited due to the clipping planes activating and scale it up a round factor (2, 3, 4, 5 even 10 times) edit it and the scale it down. Even simpler work with components and place a copy of the desired one somewhere in the scene (or in another Sketchup instance entirely) then scale it up then open it then edit it and the delete it. All the editing will translate to all other instances which are impossible (in ignoring the solution 1) to edit in their actual size and are cumbersome to scale up and down individually.

Hope it helps ! That is if you didn't already find the answer ;)

All best!
0

eidy.gg 
 

Re: When I zoom in, model gets cut off

Postby jgb » Thu Jun 23, 2016 3:02 pm

Read my post a few up from this. Turn OFF perspective and you can get a few thousandths of an inch up close. Playing with FOV only creates distortions in your view and doesn't solve the clipping problem.
0
__________________
jgb
User avatar
jgb 
 

Re: When I zoom in, model gets cut off

Postby omtamal » Tue Aug 23, 2016 11:00 pm

Camera's boxes could be the problem as well, try to delete cameras ... it worked for me. :thumb:
0

omtamal 
 

Re: When I zoom in, model gets cut off

Postby zackya07 » Fri Oct 14, 2016 9:29 am

the easiest way is to open a new sketch up file and copy paste your work. :)
0

zackya07 
 

Re: When I zoom in, model gets cut off

Postby jgb » Fri Oct 14, 2016 10:03 pm

zackya07 wrote:the easiest way is to open a new sketch up file and copy paste your work. :)

The only reason this works is because the original drawing extents, if large, affect the zoom and near field clipping threshold.

Simply turning off perspective when zooming in close prevents near field clipping.
Turn it on again when backing out. Just a mouse-click.

Far easier than opening a new SU window, copying and pasting, then having to re-clip and export back the edited version to the original model.
1
__________________
jgb
User avatar
jgb 
 

Re: When I zoom in, model gets cut off

Postby haleh67 » Thu Dec 14, 2017 11:30 pm

twoodby wrote:I found this thread because I had the same problem. Here's the solution that I found:

Under the Camera tab, select the "Perspective" option. The clipping occurs when you are in "Parallel Projection"

thank youuuuuuuuuuuuuuuuuuuu my friend :thumb: :thumb: :D
0

haleh67 
 

Re: When I zoom in, model gets cut off

Postby ajgraphics » Wed Dec 05, 2018 11:59 pm

Hello Everyone.

I'm posting to this thread, Why, Yes you guessed it. I am having or was having this same issue. I read through all of your comments and of course, tried them all. I believe someone mentioned about the perspective which works for a few times. Then someone mentioned that an imported component may be the issue. Well, I found that the imported component was the main issue. It seems that particular component did not work well with perspective turned on. Once I deleted that component drawing worked fine.
0

ajgraphics 
 

Re: When I zoom in, model gets cut off

Postby slbaumgartner » Thu Dec 06, 2018 4:29 pm

If a component has geometry that is very large or is positioned far from the model origin, it will aggravate clipping issues. Always try a component in an empty file to see whether it has such issues (and also if it is excessively detailed for your needs, as that will bloat the model and hurt performance) before importing it into your real model.
0

slbaumgartner 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: Dric Chap and 11 guests

Visit our sponsors: