Imported .dwg and drape tool issue

Found a bug in SketchUp? Report it here

Imported .dwg and drape tool issue

Postby sfto1 » Fri Aug 30, 2019 11:47 pm

I have imported a site drawing into sketchup and it appears fine. I draped it on to a surface and numerous lines and "arcs" do not drape. I have run Cleanup and noticed some gaps in the linework that has been imported, but even still there are large segments of lines that do not drape.

I tried the same technique with SU 2017 and still missing linework.

Any thoughts beyond scaling up the line work, draping and sizing back down. I did attempt that and still large amounts of linework not draping.
0
User avatar
sfto1 
Premium Member
Premium Member
 

Re: Imported .dwg and drape tool issue

Postby Dave R » Sat Aug 31, 2019 12:16 am

Can you share the .dwg?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Imported .dwg and drape tool issue

Postby sfto1 » Sat Aug 31, 2019 12:31 am

Here is one of two files I attempted to drape today. This is the one that is far less complicated, but lines still were not draping fully. I do not have access to the other file at this time.
0
User avatar
sfto1 
Premium Member
Premium Member
 

Re: Imported .dwg and drape tool issue

Postby Dave R » Sat Aug 31, 2019 12:49 am

Weird. I copied only the section shown from the imported file and moved it closer to the origin. Then I draped it. I got all but a few edges in the area shown selected. Is that what you've been seeing?

Screenshot - 8_30_2019 , 6_47_57 PM.png
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Imported .dwg and drape tool issue

Postby sfto1 » Sat Aug 31, 2019 1:47 am

You were able to get more lines draped than I did.

I've been having this issue for some time. I'll have techs in our civil department send me the 2d site line work for me to build context for the buildings, and I wind up spending a significant amount of time trying to get faces to work. Sometimes it is simpler to just draw from the start, but that is not the best use of my time.

Thanks for looking into this. Any ideas of what might be the issue?
0
User avatar
sfto1 
Premium Member
Premium Member
 

Re: Imported .dwg and drape tool issue

Postby pbacot » Sat Aug 31, 2019 2:22 am

I gave it a shot and I guess you want to be able to get faces. I tried TT Edge Tools and tried closing gaps. Didn't help. Still I don't think I've seen such a clean looking drawing be so hard to make faces from.
0
MacOSX Mojave High Sierra SketchUp Pro v19 Twilight v2 Thea v2 PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: Imported .dwg and drape tool issue

Postby Dave R » Sat Aug 31, 2019 2:21 pm

I don't know why Drape seems to fail on this with just a few edges. Running it several times can add more edges in but it seems there's a point where it decides it's just not going to play anymore.

I went back to looking at this this morning. I put all the edges back on Layer 0 where they belong, and then used Didier Bur's Projections extension to project the lines onto the face of a rectangle. It did a much better job although a few of the edges (shown heavy) don't divide the surface. Tracing over a profile edge will fix those. Except where there are gaps an no matter what, you'd need to fix those.
Screenshot - 8_31_2019 , 8_20_07 AM.png


At least it's faster than fixing the model after Drape.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Imported .dwg and drape tool issue

Postby sfto1 » Sat Aug 31, 2019 4:46 pm

Thanks Dave,

This particular ACAD file is accurate and no gaps that I'm aware of. The gaps seem to happen during import. I will use cleanup and Didier's extension as well. Maybe this workflow will take the sting off of this.

Again Thanks!
0
User avatar
sfto1 
Premium Member
Premium Member
 

Re: Imported .dwg and drape tool issue

Postby Dave R » Sat Aug 31, 2019 4:54 pm

I found gaps on those edges that extend radially from the larger arcs at about 1:00 in my screen shot.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: Imported .dwg and drape tool issue

Postby sfto1 » Sat Aug 31, 2019 5:36 pm

I checked the .dwg file and when regenerated, the linework intersects in those locations, however, there are gaps when the circles/arcs are simplified graphically, even when using autocad. So, there is an issue importing these elements

I did try Didier's projections and Thom Thom's edge tools and still having a heck of a time getting faces formed. Even drawing new lines/edges is not helping.

Are there any tricks in prepping the .dwg prior to import that will help?
0
User avatar
sfto1 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Bug Reporting

Who is online

Users browsing this forum: No registered users and 3 guests

Visit our sponsors: