Demeter [blankslate]

Found a bug in SketchUp? Report it here

Demeter [blankslate]

Postby TIG » Sun Jan 20, 2008 2:44 pm

I have been testing out Demeter the UK 'energy-use' tool (current beta) since late November.

Since an intervening SUp update [that I think has changed the Ruby version (?)] I've noticed a clash between Demeter and at least two other scripts [I haven't checked exhaustively].

One is my somewhat esoteric Grow.rb and the other is my Mirror.rb which is quite widely used. They have both started to BugSplat. Getting to know why was difficult as any errors evaporate with the instantly closed window. However, I did find the cause eventually and with Mirror at least it does flash up an error message about "...Demeter .../blankslate ... instance_methods defaulting to true... from 1.8.1" ??? Whatever that means.
Both of my scripts use a method of temporarily grouping the selected geometry and then copying it etc... and finally exploding them and/or erasing the original etc which is where it was splatting. So this common theme seems to be the link with 'blankslate'?

Stopping Demeter from loading does stop these BugSplats so there must be a clash - I've no idea where it is in the Demeter script(s) - it seems to be changing the way something with SUp methods for groups works (group explode and erase are affected)... which have been flaky at the best of times... Mirror did sometimes BugSplat for a few users a while back but we couldn't figure out why as the same models never splatted for others with exactly the same SUp PC versions etc... BUT maybe there was another third-party script clash like this one that went undetected ?
I've reported all of this to Demeter, but if any of you are getting similar problems whilst having 'blankslate' loading then try disabling Demeter temporarily and see if that fixes the problem. Report it here and/or to Demeter too so they can figure out what to do...
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 


 

Return to SketchUp Bug Reporting

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: