Dimensions Changing

Found a bug in SketchUp? Report it here

Dimensions Changing

Postby SchreiberBike » Tue Jan 08, 2008 4:18 am

The jpg's below show how when I dimension an object and move the location of the dimensions' labels the dimension changes. That would be a minor annoyance, but I really want it to have the correct dimension with the labels close to the object.

dimension problem 1.JPG
dimension problem 3.JPG

This one is correct.
dimension problem 2.JPG

Skippy to follow.


Re: Dimensions Changing

Postby SchreiberBike » Tue Jan 08, 2008 4:27 am

Here's Skippy!


Re: Dimensions Changing

Postby tomsdesk » Tue Jan 08, 2008 6:00 am

John, I don't dim in SU but had a hunch: changed your units to 1/32 and solved the problem of changing values...seems SU was having trouble rounding off, but why it would matter where the string was located is beyond me? (Get that in autocad with an inaccurate draftsman...both shorts and the long total won't round in a way to give an equal sometimes.)


Re: Dimensions Changing

Postby Charlie__V » Tue Jan 08, 2008 4:48 pm

I agree with Tom, not sure why the location of the dimension matters.
However.....making the model actually measure 6-15/16" exactly solves this.
Using the tape measure shows it slightly off of ~6-15/16'
see attached.

Precision M1710/Win 7 Pro 64 bit/i-7 6920 Quad core 2.9 Ghz -3.8/16Gb ram/NVIDIA M5000M 8Gb


Re: Dimensions Changing

Postby SchreiberBike » Tue Jan 08, 2008 8:07 pm

You guys called it. But still no idea why SU changed the dimension based on where it was placed.

I had gotten used to the tape measure tool giving me the ~ symbol meaning that it is a rounded number rather than the exact. With precision set to 1/16" the dimensions were rounded to the 16th, but I didn't realize it.

I changed the precision to 1/64" and then the dimensions were more exact and I could see how the rounding had taken place and adjust things back to the 16th.

As a woodworker, I'm usually fooling myself to say that I'm working more precisely than a 16th. Plus I can think in 16ths, but I have to convert in my head to work in 32nds or 64ths.

If I were really smart, I'd change over to mm.


Re: Dimensions Changing

Postby Gaieus » Wed Jan 09, 2008 9:22 am

Well obviously I'm in metric...
My custom template is set to centimetres and I use three decimal (.000) precision. It usually is precise enough for me. That would be about 1/64" I guess but certainly it is easier for us just to add some decimals than keep counting in fractals.
User avatar

Re: Dimensions Changing

Postby Brad » Sat Jan 12, 2008 9:07 pm

Hi All,

This is indeed strange. I don't know why the dimension would change based on it's position either. It's not new to SketchUp 6, it happens in 5, 6M1, 6M2, 6M3 and 6M4.

I going to look into our database to see if a defect is written up. If not I'm going to write one.

Thanks for your help.


SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago

Ad Machine 


Return to SketchUp Bug Reporting

Who is online

Users browsing this forum: No registered users and 2 guests

Visit our sponsors: