error with generating report

Found a bug in SketchUp? Report it here

error with generating report

Postby pibuz » Wed Nov 28, 2018 11:58 am

Hi guys, i just installed SU2018, but somehow the report utility fails to load..

The ruby console throws this message

"Error: #<NoMethodError: undefined method `to_json' for #<Hash:0x0002a849deeb78>>
c:/users/filip/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/generatereport.rbe:359:in `pull_attribute_tree'
c:/users/filip/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/su_dynamiccomponents/ruby/generatereport.rbe:94:in `block in initialize'
SketchUp:1:in `call'"

Any ideas about how I can fix it?

Thanks in advance!
0

pibuz 
 

Re: error with generating report

Postby juju » Wed Nov 28, 2018 1:05 pm

pibuz wrote:Hi just installed SU2018

Did you install via right click > run as administrator? If not then do this and do a repair installation. Else just reinstall using this method.
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: error with generating report

Postby pibuz » Wed Nov 28, 2018 1:09 pm

I'll retry immediately, just to make sure...
0

pibuz 
 

Re: error with generating report

Postby pibuz » Wed Nov 28, 2018 1:20 pm

Nothing.

And now SketchUp freezes, and can't continue.

I'm astonished. The Laptop is completely new, and SketchUp refuses to work. I truly don't know what to do.....
0

pibuz 
 

Re: error with generating report

Postby juju » Wed Nov 28, 2018 1:29 pm

pibuz wrote:The Laptop is completely new

What are the specifications of the new machine? I assume it is a windows machine? Have you restarted inbetween?
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: error with generating report

Postby pibuz » Wed Nov 28, 2018 1:33 pm

The Machine is very powerful, it absolutely not an hardware problem. Moreover, I'm a very long time SU user, so really BASIC operations like installing and opening the program should be absurdly easy.

And yet, it doesn't work....I don't know why...

I tried uninstalling and reinstalling but this doesn't fix anything.......
0

pibuz 
 

Re: error with generating report

Postby juju » Wed Nov 28, 2018 1:42 pm

Yeah, I know you're a long time SU user pibuz (with some nice stuff as well), just trying to help.

Maybe try to get SketchUp to make good on their support & maintenance?

Hmmm. How's your internet connection / connectivity? I've had some strange error messages from SU when this is compromised. Whenever the internet connectivity is strong / fine there doesn't seem to be problem error messages. Also when it's off (no internet connected) I don't have error messages, just when connectivity is compromised. This not the case here either?
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: error with generating report

Postby pibuz » Wed Nov 28, 2018 2:31 pm

Connection also is excellent!

When trying to uninstall/re-install the first time I run the program it's ok, the second time it starts freezing......

maybe it's something related to the license check? Maybe a difficult check due to restrictions in outgoing signals of OUR firewall?
0

pibuz 
 

Re: error with generating report

Postby pibuz » Thu Nov 29, 2018 11:24 pm

...seems like I can't even open a sketchup file now....
I begin to think the issue here is the integrated video card drivers...... I'm running on a UHD graphics 630..... is there something I can do to fix this?

I can't work at all....
0

pibuz 
 

Re: error with generating report

Postby juju » Fri Nov 30, 2018 7:52 am

Please tell me the laptop has a dedicated GFX solution? You'll need to set preferences making SU / LO run only on dedicated GFX solution.
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: error with generating report

Postby pibuz » Fri Nov 30, 2018 9:02 am

Obviously yes: there's a GTX 1050 with 4GB dedicated.
Yesterday evening I kept on testing the issues: I can install and run SketchUp 2017, but I cannot launch Indigo renderer and enscape. Both freeze...... :?

EDIT: sorry Juju: what's "LO"?
0

pibuz 
 

Re: error with generating report

Postby juju » Fri Nov 30, 2018 9:08 am

SU = SketchUp
LO = LayOut
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: error with generating report

Postby pibuz » Fri Nov 30, 2018 9:11 am

Thanks! Strangely, layout shows no issues. At all.
0

pibuz 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Bug Reporting

Who is online

Users browsing this forum: No registered users and 3 guests

Visit our sponsors: