CFileException 0 in E:\~... saves as -0 problem

Found a bug in SketchUp? Report it here

CFileException 0 in E:\~... saves as -0 problem

Postby reauen » Mon Aug 28, 2017 10:49 am

Hi Forum,

I have a problem, perhaps its an easy fix, but its quite irritating.

When i save a sketchup model, and use the same name i get an error.
It saves the file under the same name but adds the tekst "-0"

a save becomes:

house.skp -> house-0.skp

Anny of you had the same problem?

Thanks in advance,
Greetings Reau,


Re: CFileException 0 in E:\~... saves as -0 problem

Postby Rich O Brien » Mon Aug 28, 2017 1:49 pm

It is because you are saving to a different drive location and the autobackup of the file is causing the error.

Use File > Save a Copy As...

If the original file is saved in C: drive and then you save the same file in E: the link to the .skb is broken. Or something close to that.

You get the same error message when you try to save to DropBox/Google Drive etc but that is due to the .skb not syncing due to the latency in saving to the cloud.

Are you on a networked drive?
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 

Re: CFileException 0 in E:\~... saves as -0 problem

Postby ashreves » Tue Apr 03, 2018 9:47 pm

I get this same error, but I'm not on a network drive, and I'm just hitting the save button (not saving to another location and this happens. I've got backup upon backup in the same folder, and usually adds to the 0 extension (0-0 / 0-0-0...).


Re: CFileException 0 in E:\~... saves as -0 problem

Postby jnicolettos » Mon Apr 09, 2018 7:08 pm

I am running Win 7, saving locally (same directory) and not running Drop box but am having the same problem. When I go to save a file I get the error message and a new file is saved using a -0 suffix added to the name. By playing around I found what seems to be a solution. I stopped using the auto backup by turning it off in the preference section. So, far that seem to have stopped the problem. Hope this helps others.


SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago

Ad Machine 


Return to SketchUp Bug Reporting

Who is online

Users browsing this forum: No registered users and 2 guests

Visit our sponsors: