Problems with speed and retaining custom changes.

General discussion related to SketchUp Pro and Make

Problems with speed and retaining custom changes.

Postby CalypsoArt » Wed Jun 13, 2018 3:53 pm

I recently built a new computer and loaded SU 2018 Pro. I was running the program on my 8 year old first gen i7 machine with no problems. The new machine boots in 15 seconds. SU takes at least a minute to load, to the point where I get the "Not responding" message. If I wait it will load.

My second problem is that SU does not remember my Tray customizations. I make new trays, but when I restart, they are lost and only the default tray returns.

I suspect these problems may be related to a failed Microsoft update which MS had to correct. (I loaded SU before the fix) The failure affected several later program updates not installing correctly. Rhino6 would not run after a version update and McNeel could not remote fix it until the Windows update was successfully installed.

I'm expect I'll need to reinstall SU. Tell me I can do it without having to reload all the plugins and rebuild my workspace?

The machine is:
Microsoft Windows 10 Pro
AMD Ryzen 7 1700X Eight-Core Processor, 3400 Mhz
BIOS American Megatrends Inc. 3803, 1/22/2018
BaseBoard ASUST Strix ROG iTX B350
Installed Physical Memory 16.0 GB
Video Card AMD FirePro V5900 (FireGL V)
Storage Samsung m.2 960 EVO 500gb SSD
0

CalypsoArt 
Premium Member
Premium Member
 

Re: Problems with speed and retaining custom changes.

Postby TIG » Wed Jun 13, 2018 4:32 pm

All kinds of weird issues can happen if SketchUp is not installed correctly.
Failure to remember previous trays or shortcuts is just one of many...

You probably do not need to uninstall and start again, instead try repairing it as follows...

Log-in as your normal Windows user account - it does NOT need to have admin-powers, but if it does no worries.
Ensure SketchUp is closed.
Find its installer exe file - probably in your Downloads folder ?
Select its icon, right-click > context-menu > "Run as administrator"
When prompted choose "Repair".
If SketchUp is NOT yet installed the correct prompt to accept is "Install".

When it's done see if changes to the trays etc are properly remembered...

Do not install it using the main administrator log-in, that can cause various other issues.
Do not install it by double-clicking the exe file's icon to 'Run' it - it is NOT the same as running it as outlined above.
Also do not set the installed SketchUp.exe file's properties to 'always run as administrator' - while this might sidestep some of the problems an incorrect installation throw up, it will break other things like drag-n-drop because Windows Explorer would then be running at a lower permissions level and so it is not allowed to affect the now higher-level SketchUp.
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problems with speed and retaining custom changes.

Postby CalypsoArt » Wed Jun 13, 2018 5:48 pm

Thanks for the info TIG. I did the repair, but no good. It still will not remember traysand speed is off. ("Repair" did not work for Rhino either.) I'm going check a few things, but I expect complete removal is and reinstall is necessary. I think I'm going to install plugins one by one instead of the bundle and see if there might be something there.

Edit: My second restart and it remembered the trays. The slow start might be related to plugins. Can I start switching off plugins and add them back one by one?
0

CalypsoArt 
Premium Member
Premium Member
 

Re: Problems with speed and retaining custom changes.

Postby TIG » Wed Jun 13, 2018 7:11 pm

Every plugin that loads takes some time.
Complex extensions - like renderers - take longest.
The SketchUcation Toolset [ https://sketchucation.com/pluginstore?p ... ationTools ] has a Plugins Manager - it allows you to disable selected plugins which you rarely use, and then enable them [temporarily if desired] when you actually need them. The additional 'Sets' options also let you have sets, which you can switch between...

It's pointless loading complex extensions - like renderers - every time SketchUp starts, unless you really need to use them immediately...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problems with speed and retaining custom changes.

Postby CalypsoArt » Thu Jun 28, 2018 3:39 pm

I removed and reloaded Sketchup. It still hangs and is horrendously slow to start up. Even before adding plugins. My Rhino and Autocad are much faster on this machine where SU hangs often. Could this be a problem with RYZEN and SU. Any suggestions?
0

CalypsoArt 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: ecovi and 9 guests

Visit our sponsors: