Layer0 behavior when turned off

General discussion related to SketchUp Pro and Make

Layer0 behavior when turned off

Postby Al Hart » Fri Nov 23, 2007 7:01 am

We had a user last week whose components weren't showing up when she exported them to our renderer. It turns out that the geometry in the components was draw in Layer0, but the component itself was in a different layer.

She had turned Layer0 off. However in SketchUp turning Layer0 off only turns it off for top level geometry, but not for geometry in groups or components. So the geometry in Layer0 in her components was visible in SketchUp, but not after we exported it.

Turning any other layer off turns it off for the top level and also inside of groups or components.

I can see why this was done (since most geometry is drawn in Layer0 before it is placed in a component.) However, you can imagine how this caught us by surprise when exporting geometry.

1. Has anyone else ever notice this behavior?

2. In the foreign versions (assuming we every get some for version 6) does Layer0 have the same name or a different name? (Right now are checking for Layer0 by name, but we may need to check for it in some different way if the name can change in translated versions.)
0
Al Hart
IRender nXt from Render Plus
User avatar
Al Hart 
PluginStore Author
PluginStore Author
 

Re: Layer0 behavior when turned off

Postby marne » Fri Nov 23, 2007 7:02 am

I noticed this too. I Always need to turn on layer0 if i like to render in Vray or Kerkythea.
As far as i noticed the strange behaviour of Layer0 seems to apply (?) to all other layers.
I inserted trees on layer xy and then put some of them in layer yz. When turning off layer xy the trees on layer yz disappear too. It took many nerves to find this out... But i didn't find a solution yet. Maybe we got a Layer wiz in this forum? :D

greetings marne
0

marne 
 

Re: Layer0 behavior when turned off

Postby eeva » Fri Nov 23, 2007 7:02 am

in the german version layer0 is named the same.
0
User avatar
eeva 
Global Moderator
 

Re: Layer0 behavior when turned off

Postby Al Hart » Fri Nov 23, 2007 7:03 am

If the trees are originally placed in layer XY, and then included in a group or component which is then placed in layer AB, then AB must be turned on in order to see anything in the component, and both XY and AB must be turned on to see the trees.

However if the original layer XY way Layer0, then items inside groups or components which were originally drawn in Layer0 will be visible even if Layer0 is no longer on. (Assuming that the layer for the component instance or group is on.)
0
Al Hart
IRender nXt from Render Plus
User avatar
Al Hart 
PluginStore Author
PluginStore Author
 

Re: Layer0 behavior when turned off

Postby Jean Lemire » Fri Nov 23, 2007 7:03 am

Hi Al, hi folks.

As far as I know, SU 6 do not exist in French yet.

In SU 5, Layer0 is called "Calque0" since "calque" is the choosen translation for "layer".
0
Jean (Johnny) Lemire from Richelieu, Quebec, Canada.
User avatar
Jean Lemire 
Global Moderator
 

Re: Layer0 behavior when turned off

Postby Al Hart » Fri Nov 23, 2007 7:04 am

Thanks,

We will make sure we get the name for Layer0 (Calque0) from the layer list itself.
0
Al Hart
IRender nXt from Render Plus
User avatar
Al Hart 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: david_h, Google Bot, mariay916 and 5 guests

Visit our sponsors: