[Plugin] TIG-layer_material_tools

[Plugin] TIG-layer_material_tools

Postby TIG » Fri Dec 05, 2014 6:10 pm

I have updated my own brand-new version of Didier's toolset, which:
Make Materials from Layers and Layers from Materials, and Set Materials from Layers and Layers from Materials.
Version 1.0 is now available from the PluginStore.

Download

2
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] TIG-layer_material_tools

Postby thelorax » Fri May 08, 2015 12:26 am

TIG,

I just wanted to thank you personally for this script. Trimble removed the (use color by layer materials) option from the 3ds export dialog, which breaks a method I've used for moving files between sketchup and max for years now. your script is the only way now to get the layer info into max. I don't know ruby, but I wrote a pretty sweet maxscript for exchanging files between sketchup and max. If you use max let me know.




thanks!

chris
0

thelorax 
 

Re: [Plugin] TIG-layer_material_tools

Postby Repsaj1975 » Thu Apr 18, 2019 9:56 am

Hi TIG,

This plugin worked fine in SketchUp2017 but in SketchUp2018 it isn't working anymore

Using it to import a dwg
Then making materials from layers
And finally set materials from layer names

Is there al solution?
0

Repsaj1975 
 

Re: [Plugin] TIG-layer_material_tools

Postby TIG » Thu Apr 18, 2019 3:41 pm

This is an old plugin.

Can you explain how it is 'not working' ?
Errors loading ?
Errors when running ?
If you run it with the Ruby Console open do you see error messages ? etc...

Please give full details...

It works fine for me...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] TIG-layer_material_tools

Postby JanaVS » Thu Sep 12, 2019 12:51 pm

TIG wrote:This is an old plugin.

Can you explain how it is 'not working' ?
Errors loading ?
Errors when running ?
If you run it with the Ruby Console open do you see error messages ? etc...

Please give full details...

It works fine for me...


Hello,

I uploaded 2 documents that show in detail how is this plugin working in 2017 version and not working in 2018 version. This is exact the same model that I tested on.

I practically do the same thing in both cases only the results are different.

If you have any idea how can I make this work, please let me know.

Thank you!
0

JanaVS 
 

Re: [Plugin] TIG-layer_material_tools

Postby TIG » Fri Sep 20, 2019 4:02 pm

It seems to report the changes the same in both versions ?
So can you check the materials actually get made in the 'failing' model.
Also can you check in it, what material should be associated with an object on a layer - and what Entity Info says it has...
What are your View / Style settings ?
Are there differences between these in the two SketchUp versions ?

Can you post an example SKP that I can test...

You didn't seem to run it with the Ruby Console open ?
Any error messages ?
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Plugins

Who is online

Users browsing this forum: cnzkemfudy, evelienbleumink, huylona1610, lhnam7 and 18 guests

Visit our sponsors: