[Plugin] BezierSpline - v2.1a - 01 Nov 18

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby RobbieDingemanse » Wed Feb 27, 2019 11:32 am

Hello Fredo6, is the bezier spline plugin not ready for SU19? Because I can install it, but when I try to use Polyline Arc corners, it doesn't show the pop-up window for the input.
0

RobbieDingemanse 
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby fredo6 » Wed Feb 27, 2019 12:50 pm

RobbieDingemanse wrote:Hello Fredo6, is the bezier spline plugin not ready for SU19? Because I can install it, but when I try to use Polyline Arc corners, it doesn't show the pop-up window for the input.

Can you open the Ruby console before you launch Polyline Arc Corner and check if there are errors.

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby Cenosha » Thu Mar 14, 2019 4:00 pm

fredo6 wrote:
RobbieDingemanse wrote:Hello Fredo6, is the bezier spline plugin not ready for SU19? Because I can install it, but when I try to use Polyline Arc corners, it doesn't show the pop-up window for the input.


Can you open the Ruby console before you launch Polyline Arc Corner and check if there are errors.

Thanks

Fredo


Fredo,

I am working together with Robbie, this is the error code we get in the Ruby Console

Error: #<NameError: uninitialized constant BZ__Arc::Traductor>
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/BZ__Arc.rb:67:in `bz_ask_extras'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2058:in `call'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2058:in `call_ask_extras'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2109:in `conversion_curve'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2411:in `block (2 levels) in compute_contextual_menu'


Richard
0

Cenosha 
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby Cenosha » Wed Mar 27, 2019 8:01 am

Cenosha wrote:
fredo6 wrote:
RobbieDingemanse wrote:Hello Fredo6, is the bezier spline plugin not ready for SU19? Because I can install it, but when I try to use Polyline Arc corners, it doesn't show the pop-up window for the input.


Can you open the Ruby console before you launch Polyline Arc Corner and check if there are errors.

Thanks

Fredo


Fredo,

I am working together with Robbie, this is the error code we get in the Ruby Console

Error: #<NameError: uninitialized constant BZ__Arc::Traductor>
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/BZ__Arc.rb:67:in `bz_ask_extras'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2058:in `call'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2058:in `call_ask_extras'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2109:in `conversion_curve'
/Users/cgs/Library/Application Support/SketchUp 2019/SketchUp/Plugins/bezierspline/bezierspline_main.rb:2411:in `block (2 levels) in compute_contextual_menu'


Richard



Fredo,

any idea how we can fix this ?
0

Cenosha 
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby TIG » Wed Mar 27, 2019 2:17 pm

Fredo has yet to reply, but the error message clearly points to line #67 in one of the loading files [../Plugins/bezierspline/BZ__Arc.rb], where it can't find the defined code for 'Traductor'.
When it's trying to run:
Traductor::DialogBox.new TTH_Title
This is a shared 'translation' module - it is an Extension created by LibFredo - which is an Extension set up by a separate installation.
So ensure that you also have its RBZ downloaded, installed and its Extension enabled in the Extensions Manager...
It's available from the PluginStore...
https://sketchucation.com/pluginstore?pln=LibFredo6
Restart SketchUp after it is installed/enabled to ensure that everything gets properly synced...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby fredo6 » Wed Mar 27, 2019 3:11 pm

@Cenosha

Normally, this should not happen with the latest version BezierSpline 2.1a.

Otherwise, just install LibFredo6, latest version, and this should work fine.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby Cenosha » Thu Mar 28, 2019 9:34 am

Guys,

With the LibFredo6 installed the problem is gone!

Thanks!
0

Cenosha 
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby nocoloDean » Thu Sep 19, 2019 3:29 am

1st and only post.
What an absolute ABORTION trying to get Bezierspline loaded into Sketchup 2014.

Still haven't managed. It says it's loaded in Sketchucation's plugin manager, but it's not showing up in Prefs/Extensions, nor is it showing up in the program.

What a mess. How hard can it be? Install > use.

fuckinmess.JPG
0

nocoloDean 
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby TIG » Thu Sep 19, 2019 4:43 pm

SketchUp version 2014 is old.
Support from SketchUp only extends back to v2017.
Some Extensions' authors allow backward compatible to v8, and reading this tool's guide it should be OK...

An oddity in your error message suggests that it's been NOT installed properly.

Usually the installation path is...
C:\Users\YOUR_USER_NAME\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp\Plugins
So how did you install this toolset exactly ?

How is it that SketchUp is trying to load it from here ?
C:\Documents and Settings\user\Application Data\SketchUp\SketchUp 2014\SketchUp\Plugins

What is your current Windows OS ?
Please fill in your Profile properly...
It might well be incompatible ?

Many users have this tool installed successfully in many SketchUp versions.

Starting off "on an aggressive preemptive attack" might work in wing chung, but when your are asking for advice or help, then a more conciliatory tone often attracts a more sympathetic and helpful response... :shock:
2
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby fredo6 » Thu Sep 19, 2019 11:08 pm

This is related with the non-ascii deficiencies of old Sketchup versions in some Windows configurations, and there is nothing that can be done (except to migrate to newer versions).

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby LisaG » Wed Dec 04, 2019 3:14 am

Hi,
Just downloaded LibFredo6 plugin for SketchUp Make V2017. The installation is not yet complete as under Preferences there is no "Extensions" listed. Not sure where else to find it!
Thanks.
0

LisaG 
 

Re: [Plugin] BezierSpline - v2.1a - 01 Nov 18

Postby Dave R » Wed Dec 04, 2019 1:25 pm

LisaG wrote:The installation is not yet complete as under Preferences there is no "Extensions" listed. Not sure where else to find it!
Thanks.


LibFredo6 appears in the Window menu and Bezier Spline Curves appears in the Draw menu. Did you look there?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

Previous


 

Return to Plugins

Who is online

Users browsing this forum: Bing [Bot], nnabilahsnf and 12 guests

Visit our sponsors: