[Plugin] QuadFaceTools

Re: [Plugin] QuadFaceTools

Postby jo-ke » Mon Nov 10, 2014 9:48 am

it seems to be that the model in version SU7 is quad face and when I import it to SU2015 it is a sandbox mesh.

I converted it again to quadface and the UV texture mapper worked.

everything fine!
0
User avatar
jo-ke 
Premium Member
Premium Member
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Mon Nov 10, 2014 3:31 pm

Did you remember to convert the Sandbox Tool mesh into a QuadFace Tools compatible mesh first?
1
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby jo-ke » Mon Nov 10, 2014 3:51 pm

Yes. I've did it like that and saved the component as SU7 some years ago and used it many times, just using the UV Mapper.

But now, when I import the same component to SU2015 it lost the Quadface- Information and I have to reconvert it to quads, as you described above.
0
User avatar
jo-ke 
Premium Member
Premium Member
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Mon Nov 10, 2014 3:55 pm

Any chance you can provide a sample model with exact steps (video?) of what you do?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby jo-ke » Mon Nov 10, 2014 5:16 pm

the sample model is attached above.

here's the component:

If you load it in SU7 it is already converted to quadface
If you load it in SU2015 you have to convert it to quadface
0
User avatar
jo-ke 
Premium Member
Premium Member
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Fri Nov 21, 2014 2:27 pm

jo-ke wrote:the sample model is attached above.

here's the component:

If you load it in SU7 it is already converted to quadface
If you load it in SU2015 you have to convert it to quadface


I do not see a difference in behaviour between the two versions. In both SU7 and SU2015 I had to use SandboxTools Quads to QuadFace Quads for the mapping to work.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby jo-ke » Fri Nov 21, 2014 5:48 pm

On my machines in Version 7 the model is already converted and can be mapped directly.

It is not really a problem, I was just a bit surprised of that fact.
0
User avatar
jo-ke 
Premium Member
Premium Member
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Fri Nov 21, 2014 7:21 pm

Can you do a screen capture? I might be missing a step or something. There should be no difference between machines.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby DareDevil » Thu Feb 26, 2015 5:28 pm

I missed this plugin ! I tried it now because I need quad (planar or non planar) for paneling surface. But I have some problems with the OBJ export (SU pro 2015 on Win 8.1 64)
First, the export setup windows use an huge typo. So I can't see the Scale setup. I edited the CSS file to change it and it's almost OK...
Second and worse, SU suddently close after export. The exported OBJ seems OK but SU dont like do that. Anyone have the same issue ?
0
User avatar
DareDevil 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Thu Feb 26, 2015 6:04 pm

DareDevil wrote:First, the export setup windows use an huge typo. So I can't see the Scale setup. I edited the CSS file to change it and it's almost OK...

Screenshot? Do you have a high DPI monitor?

DareDevil wrote:Second and worse, SU suddently close after export. The exported OBJ seems OK but SU dont like do that. Anyone have the same issue ?

Hmm... not seen that. Does it happen will all epxorts? Or does it happen with a particular model. If so, can you share it?

Does it simply close? No BugSplat dialog?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby DareDevil » Thu Feb 26, 2015 6:46 pm

thomthom wrote:
DareDevil wrote:First, the export setup windows use an huge typo. So I can't see the Scale setup. I edited the CSS file to change it and it's almost OK...

Screenshot? Do you have a high DPI monitor?

I think. It's a HD 1080 screen on a 13" lenovo laptop.
DareDevil wrote:Second and worse, SU suddently close after export. The exported OBJ seems OK but SU dont like do that. Anyone have the same issue ?

Hmm... not seen that. Does it happen will all epxorts? Or does it happen with a particular model. If so, can you share it?

Does it simply close? No BugSplat dialog?

No BugSplash. It's a nice "clean" instant shutdown ;) I will try further with different model tonight and I will tell you more.
I will try too on my second computer on Win 7 64.

I want to "resurect" my old Paracloud Gem that use OBJ quad to panel mesh.
0
User avatar
DareDevil 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Fri Feb 27, 2015 12:29 am

If you can reproduce it, please send me the model. PM it if you don't want to share publicly.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby DareDevil » Fri Feb 27, 2015 3:18 pm

For the typo, here is the setup window without my CSS modificaton :
QuadExport.jpg

When I comment the line about the font in the base.css, it's better but not perfect...

For the crash, is not depending on the model. A simple square exporte is the same as more complicated model : all seem ok, but after this window SU shut down immediatly. The OBJ (and MTL) exported seems OK.
QuadExport2.jpg


If I cancel on the export setup windows, SU close too...
I remove the other two plugins (tt_bitmap2mesh and Artisan demo) but it's the same...

Other detail : it's a french version of SU 2015.

-------------------
EDIT
With SU 8 pro on the same machine (Win 8 64) all is ok !!!
0
User avatar
DareDevil 
 

Re: [Plugin] QuadFaceTools

Postby DareDevil » Sat Feb 28, 2015 10:09 am

I tried on my other "old" computer, running on Win 7 64 : same crash after the OBJ Format export but I have a BugSplash.
Both computers have 64 bits system (Win 7 and 8), french SU 2015 pro (v 15.3.331), no good openGL graphic card (old nVidia 9600 and Intel HD chip).
BugSlash generate 4 files in the Temp directory. These files can help you ?
0
User avatar
DareDevil 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Tue Mar 03, 2015 8:08 pm

I think I have a fix for the crash - try this patched version of TT_Lib:
https://bitbucket.org/thomthom/tt-libra ... 2.10.2.rbz

I think I might have a tweak for the font issue as well, but I don't have a patch right now for that one.
1
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby DareDevil » Tue Mar 03, 2015 10:24 pm

thomthom wrote:I think I have a fix for the crash - try this patched version of TT_Lib:
https://bitbucket.org/thomthom/tt-libra ... 2.10.2.rbz

The OBJ export seems to work nice :thumb: !!!
I tried on my Window 7 64 computer and I will try with my Win 8 64 computer tomorrow.

Thanks a lot Thomthom !!!

[EDIT]
It's OK on my Win 8 64 computer too ;)
Thanks again !
1
Last edited by DareDevil on Wed Mar 04, 2015 5:04 pm, edited 1 time in total.
User avatar
DareDevil 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Wed Mar 04, 2015 12:39 am

Thanks! The patch should go live soon to everyone. :) Thanks for testing.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby xiombarg » Thu Jun 25, 2015 5:20 am

I'm working on the mesh below, most of which is from another application, but I'm hoping to do a portion of it in SU if I can import it and export it with sufficient correctness between programs. I'm wondering what is the best import format when working with relatively complicated meshes being brought into Quadface tools and into SU in general? My experience with .obj files brought into SU is that they look like a mess with missing faces and whatnot. What you see in my pic is a .dae collada file, which might work ok as long as it exports as a functional .obj in quads.

So I guess I'm just wondering what tips anyone has for cleanly importing, what type of quad conversion different file types require, and hopefully export cleanly?

0
User avatar
xiombarg 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Thu Jun 25, 2015 12:39 pm

I'm currently working on a OBJ importer that import QuadFace Tools quads. This would let you import and export quad based meshes to and from SketchUp.
I still got some testing to do before I release it. But if you send me some OBJ files I can run them through the current development build.
2
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby juju » Thu Jun 25, 2015 12:51 pm

also, there is this tool in development, I don't think it will integrate with SU though...

http://www.topologica.org/toplog/wp/
0
Save the Earth, it's the only planet with chocolate.
User avatar
juju 
Premium Member
Premium Member
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Thu Jun 25, 2015 4:24 pm

juju wrote:also, there is this tool in development, I don't think it will integrate with SU though...

http://www.topologica.org/toplog/wp/

Oh! Interesting link!
Well, if it export OBJs with quads then the importer should handle it.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby xiombarg » Thu Jun 25, 2015 9:57 pm

That's great news Thom. I'll be seriously looking forward to it. For now I'll probably stick with building certain parts in SU and then exporting out to put together in Modo, but thanks for the offer.

Topologica looks interesting too. It would be nice to have an affordable option for reorganizing bad topology.
0
User avatar
xiombarg 
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Fri Jun 26, 2015 8:35 pm

Version 0.9.0
  • OBJ Importer (File > Import... > "OBJ Files - QuadFace Tools"

Note that I expect there will be issues with the importer as there are probably many variations of exporters I'd not accounted for. If you experience issues please keep your Ruby Console open and report back the errors and example model.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby xiombarg » Mon Jun 29, 2015 7:32 am

Appreciate the importer Thom!

One thing I've found as I've been experimenting with importing and exporting between various programs is that collada .dae files always import and export surprisingly cleanly between programs. I don't hear much talk about collada files being used, but almost every program supports them, and where obj files often create artifacts when dealing with bad geometry, collada files don't seem to have a problem with this.
0
User avatar
xiombarg 
 

Re: [Plugin] QuadFaceTools

Postby pilou » Fri Sep 04, 2015 12:21 am

For Windows 8.1 and I suppose some all versions ? :geek:

If you want install QuadFace tool, Install first TT-LIb2 else you will obtain a very beautiful "Bug SPlatch" and of course no possibility to use Sketchup! ;)

I have started the French manual of it! ;) Done! :enlight:
Other French Manual SUbD done ;)
1
Last edited by pilou on Tue Jan 19, 2016 9:56 am, edited 1 time in total.
Frenchy Pilou
Is beautiful that please without concept!
Speedy Galerie
User avatar
pilou 
Top SketchUcator
 

Re: [Plugin] QuadFaceTools

Postby ithil » Tue Jan 19, 2016 8:41 am

Greetings thomthom
Thanks again for your scripts. It's just a bomb.
I'm happy as a kid =) :enlight:

There is another question.

I tried to export an OBJ file using your plugin.
The program UVLayout imported excellent correct poly mesh!
No need to deal with triangles and mapinga is a 3 times faster.

I save the finished OBJ file in UVLayout.
But it is imported in SketchUp without texture.
I thought QuadFaceTools did not know how to import textures. But another model from SketchUp saved opens with texture.

Maybe there is some kind of setup?
In UVLayout seen the name of the material - it is assigned by the model.

Before that, I used the plug-in SketchUV to communicate with SketchUp and UVLayout.
ExportUVs, ImportUVs. But it turns out OBJ broken into triangles. And it is very difficult to work in the program. UVLayout works with polygon mesh.
Do you plan to make an analog ExportUVs, ImportUVs but with your excellent polygons?

ps. I checked.
After mapping in 3D max OBJ file also imports without texture.
0
User avatar
ithil 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby pilou » Tue Jan 19, 2016 9:58 am

After mapping in 3D max OBJ file also imports without texture.

Thats's true ? Seems incredible ! I suppose you have choice yes or no ? :o
0
Frenchy Pilou
Is beautiful that please without concept!
Speedy Galerie
User avatar
pilou 
Top SketchUcator
 

Re: [Plugin] QuadFaceTools

Postby ithil » Tue Jan 19, 2016 10:38 am

I tested again and recorded video.
From 3D MAX imported black material without texture.
But with UVLayout happened.
Apparently up to this program is not the path to texture. This is strange. I have 5 times the same thing done =)
I think. texture file must be in the same folder as an OBJ file.

https://youtu.be/jYMi7Nj3moQ
0
User avatar
ithil 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby thomthom » Tue Jan 19, 2016 4:29 pm

Can you share the OBJ along with the MTL and textures? Zip them up please?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools

Postby panixia » Tue Jan 19, 2016 6:17 pm

thomas i rememember we had the same problems in beta.. the zbrush obj were running fine but the 3dsmax ones gave same problem.
if i don't remember wrong, you said that was a matter of the texture-files path.. and also i remember you fixed those models in some way.. maybe reloading the texture from sketchp material editor from a new path? can't remember..

also i remember there was something related to the upside-down flipping, but maybe that was from the zbrush models? not sure.. i'm trying to find those obj models to check the path of the textures..
0
User avatar
panixia 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

cron

Who is online

Users browsing this forum: Adko74, marktaucher, railwaxking, seranay seren, smartsizer and 12 guests

Visit our sponsors: